Closed Bug 913323 (window-identifier) Opened 6 years ago Closed 5 years ago

[meta][Window Management] Refine Gaia Window Identifier

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1036788

People

(Reporter: alive, Assigned: alive)

References

Details

There's still lots of modules using origin to identify an app.
To identify an app, manifestURL is the way to go.
To identify a frame, pageURL is the way to go.

EntryPoint is an exception, but we could wrap them IMO.
Duplicate of this bug: 796629
Component: Gaia::System → Gaia::System::Window Mgmt
No longer blocks: task-manager
Summary: [Window Management] Remove origin reference; Use manifestURL identify an app and use pageURL identify an frame. → [meta][Window Management] Refine Gaia Window Identifier
Alias: window-identifier
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036788
You need to log in before you can comment on or make changes to this bug.