Closed Bug 915453 Opened 7 years ago Closed 6 years ago

FxAccounts should send notification to observers on user authentication changes

Categories

(Firefox :: Sync, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 909967

People

(Reporter: zaach, Assigned: zaach)

References

()

Details

(Whiteboard: [qa?])

Attachments

(1 file)

When a user sings in/creates an account, or signs out, we should emit an assertion changed notification for observers.
Summary: FxAccounts should send notification to observers on assertion changes → FxAccounts should send notification to observers on user authentication changes
Updated the title to be less specific. We can simply emit an "auth status changed" notification. The data may include new user credentials, or the observer can use the fxaccounts service to get the user's current session status.
Whiteboard: [qa?]
We notify observers when the signed-in user's credentials change. Topic is "fxaccounts:auth:change" and the data is stringified account credentials.
Attachment #804023 - Flags: feedback?(spenrose)
Blocks: 905997
No longer blocks: 912188
No longer depends on: 910479, 910844
Can we close this one out?
No, we'll want this.
Attachment #804023 - Flags: feedback?(spenrose)
FxAccounts.jsm currently notifies two events: fxaccounts:onlogout and fxaccounts:onlogin. This was added in bug 909967, which has landed in m-c. We can open additional bugs if we need to refine this.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 909967
OK. Verifying this as a duplicate.
Status: RESOLVED → VERIFIED
Blocks: 951296
No longer blocks: 905997
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.