[Email] Complete integration tests for notifications

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jrburke, Assigned: jrburke)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The user stories around email notifications will be closed soon, as the operational code has landed. However, we are still building up all the integration test plumbing, so we landed those stories without full integration tests. This bug tracks adding the integration tests for those stories. Specifically:

* Bug 892523 - [User Story] Email Invocation from Notification
* Bug 892525 - [User Story] Ability to Disable Email Notifications
* Bug 892518 - [User Story] Ability to Change Sync Interval
* Bug 892522 - [User Story] Email Notification Grouping
* Bug 892526 - [User Story] Display of Email Info with Notification 
* Bug 892521 - [User Story] Email Notifications - Email App Foreground

As the code was demonstrated to UX and Product and shown to be working, these tests are now more about preventing regressions in the future.
(Assignee)

Updated

5 years ago
Assignee: nobody → jrburke
(Assignee)

Comment 1

5 years ago
Created attachment 810379 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12199

Pointer to Github pull-request
(Assignee)

Comment 2

5 years ago
Comment on attachment 810379 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12199

Includes tests for the recent stories, except for checking the text of the notifications:

Bug 892526 - [User Story] Display of Email Info with Notification 

because the format of those will change with the changes in bug 918998 and bug 919004.

Asking :gaye for review as he has very relevant marionette test experience. :lightsofapollo is also welcome to take a look, but I expect he is impacted by other tasks.
Attachment #810379 - Flags: review?(gaye)
(Assignee)

Comment 3

5 years ago
Asking for koi+ since further koi+ bugs that will have integration tests will want to use the helpers in this pull request. No material changes to code that runs on the phone in this change, just a class added for better integration test targeting. The rest of the changes are in the integration test directory.
blocking-b2g: --- → koi?
blocking-b2g: koi? → koi+
Comment on attachment 810379 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12199

Thanks jrburke! This is great work. I have a couple comments on GitHub, but nothing blocking.
Attachment #810379 - Flags: review?(gaye) → review+
(Assignee)

Comment 5

5 years ago
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/49e118a2dd514a4a290b6f11ee567969f09b993e

from pull request:
https://github.com/mozilla-b2g/gaia/pull/12199

Gareth, I will be filing separate issues with the marionette pieces you mentioned.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 49e118a2dd514a4a290b6f11ee567969f09b993e to:
v1.2: 6c6010b255548a040a09d864aad8db2c507e0e96
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.