Closed Bug 915812 Opened 7 years ago Closed 6 years ago

[Buri][Bluetooth] Cannot successfully connect Bluetooth headsets

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Assigned: echou)

Details

(Keywords: regression)

Attachments

(2 files)

Attached file bluetooth.txt
Buri while running:

Gaia   9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
SourceStamp a98569f21abe
BuildID 20130912040201
Version 26.0a1

STR:
1. Attempt to Pair Plantronics PLT_M165 to Buri device
2. In Settings it shows "Connecting"
3. Incoming calls are not routed to Bluetooth headset

The Plantronics headset indicates "Pairing successful" but the incoming call is not routed to the headset.

Logcat attached.
Attempted to Pair JabraSP200 and Rocketfish model RF-QX4 to Buri device and was unable to connect consistently.

Environmental Variables
Build ID: 20130912040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/a98569f21abe
Gaia: 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
Platform Version: 26.0a1
QA Contact: nkot
blocking-b2g: --- → koi?
Summary: [Buri][Bluetooth] Cannot successfully pair Plantronics headset → [Buri][Bluetooth] Cannot successfully pair Bluetooth headsets
- Works (Pairs and routes calls) -
Environmental Variables
Build ID: 20130911040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/f9e8e8ce552c
Gaia: ebbb325958c66c3e68e1f190472d5f6e9076d83a
Platform Version: 26.0a1

- Broken (Doesn't connect and route calls consistently) -
Environmental Variables
Build ID: 20130912040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/a98569f21abe
Gaia: 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
Platform Version: 26.0a1
This likely to be caused by bug 914175.
Blocks: 914175
No longer blocks: 914175
Summary: [Buri][Bluetooth] Cannot successfully pair Bluetooth headsets → [Buri][Bluetooth] Cannot successfully connect Bluetooth headsets
From the bug description, it seems that the pairing process has been completed. However, we failed to connect with the Bluetooth headset.
Can somebody help to check the latest build? I tried several Bluetooth headsets and had no luck to reproduce this issue. Here's my build info:

Gecko: 006afb699818
Gaia: 008d86b55a18e52cf7c41b2cfbee39d7c3527fbb
QA Wanted for comment 5
Keywords: qawanted
I switched Gaia back to version 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05, which is used in the original comment, and remain the Gecko as the version mentioned in comment 5 (b2g-inbound). The testing result was the same as the reporter said. Please refer to the screenshot I just attached.

In summary, the problem should have been fixed with a Gaia commit in the range between 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05 and 008d86b55a18e52cf7c41b2cfbee39d7c3527fbb.
From my observation, Gaia made some changes in bug 910140, which might be the root cause.
Tested and able to pair and connect two bluetooth devices (JabraSP200 and Rocketfish model RF-QX4)

Unable to receive and pick up a call using either bluetooth device when a call is made to mobile device. Let the call ring 10 times for JabraSP200 and 10 times for Rocketfish. Press the pick up button at each ring was not successful.

Environmental Variables
Base Image: 20130912
Build ID: 20130913040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/b9029b1de410
Gaia: 8ccb741b6adcfe9a78b842c17e5874242c0f8b86
Platform Version: 26.0a1
I tested using my Plantronics device and I was able to get this working today using:

Found device
Gaia   8ccb741b6adcfe9a78b842c17e5874242c0f8b86
SourceStamp b9029b1de410
BuildID 20130913040201
Version 26.0a1

The device pairs and I am able to answer the incoming call using the bluetooth, as well as hear the outbound call in the headset.

It seems though that from comment 10, it is not working for certain headsets? Adding needs info from mclemmons to test again with a different Buri device.
Flags: needinfo?(mclemmons)
Keywords: qawanted
in response to comment 11

tested on 3 Buri devices. 

First Buri device (different than the one tested in comment 10) was able to be paired with Bluetooth device but an incoming call could not be answered using the bluetooth device.

Second Buri device (different than the one tested in comment 10) was able to be paired with a Bluetooth device yet an incoming call could be answered using the bluetooth device.

Retested Buri device from Comment 10 and was able to be paired with a Bluetooth device yet an incoming call could be answered using the bluetooth device.

The above three tests occurred in that order and within a 10 minute timeframe demonstrating intermittent/inconsistent behavior
Flags: needinfo?(mclemmons)
If this headset-specific, then this isn't a smoketest blocker. We should continue to investigate here, however.
No longer blocks: b2g-central-dogfood
Keywords: smoketest
QA Contact: nkot
This doesn't seem to be headset specific, it seems to be more inconsistent behavior.
Assignee: nobody → echou
Followed STR to test with SonyEricsson MW600 and Nokia BH-503. It worked ok. I've recorded a video to show how I test. It's a shorter version. I usually did pair and unpair everytime.

video link: https://www.dropbox.com/s/jdrnzffg31jx63t/Bug-915812.mp4
build     : gecko - 148217:6f76fe060186, gaia - 0505d8adb0a76556584e302cd524c0bed41445f9

Based on current implementation, once you click the target device in Bluetooth page, the description which appears under the device name should go through these phases:

   Pairing with device -> Connecting -> Connected to phone -> Connected to phone/media audio(if the remote device supports A2DP)

Moreover, you can see the icon on the status bar changed as well.

For those devices that couldn't respond to the incoming call, I was wondering if they were all at the final phase or it stuck in the other state like "Connecting". Could someone test again? It would be great if we can have more information, such as hcidump log or a video.
QA Wanted for comment 15
Keywords: qawanted
QA Contact: sparsons
Unable to reproduce on Buri 1.2 Aurora Build ID: 20130925004005 

Environmental Variables
Build ID: 20130925004005
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/fb764e648a8f
Gaia: b0e4a1333bb7bf0a749a384ba99e4f03f111e39a
Platform Version: 26.0a2
RIL Version: 01.01.00.019.197
Keywords: qawanted
Works for me for comment 17.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.