Do debug B2G desktop builds

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: catlee, Assigned: simone)

Tracking

({leave-open})

other
leave-open
Dependency tree / graph

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

(Whiteboard: [b2g])

Attachments

(6 attachments, 3 obsolete attachments)

(Reporter)

Description

4 years ago
We need to build debug variants of all our desktop B2G builds.
(Reporter)

Updated

4 years ago
Blocks: 916113
(Reporter)

Updated

4 years ago
Blocks: 916127
Blocks: 916356
+1, I was about to file a new bug when b.m.o's duplicate check feature found this.

This should allow folks to run Marionette using a debug Gaia profile present in these debug B2G builds.
Is the plan for just builds or tests as well?
(Reporter)

Comment 3

4 years ago
Tests too

Updated

4 years ago
Duplicate of this bug: 956451
Blocks: 941505

Updated

4 years ago
Assignee: nobody → sbruno
Blocks: 825889

Updated

4 years ago
Depends on: 956451
(Assignee)

Updated

3 years ago
Depends on: 991203

Comment 5

3 years ago
Simone, can you update this bug for status?
(Assignee)

Comment 6

3 years ago
Sure! Final patches for linux OS's and Mac OSX upcoming today; plan is to complete the windows one as well by the end of the week.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 956451
(Assignee)

Updated

3 years ago
Duplicate of this bug: 991203
(Assignee)

Updated

3 years ago
No longer depends on: 956451, 991203
(Assignee)

Comment 9

3 years ago
Created attachment 8408340 [details] [diff] [review]
buildbot-configs_WIP.diff

Work In Progress - Patch to buildbot-configs doing the following:
- add linux32_gecko-debug and win32_gecko-debug platforms and relative configuration sections
- explicitly disable nightly builds on m-c, aurora, mozilla-b2g28_v1_3t and mozilla-b2g28_v1_3
- remove code which enabled linux64 and macOS builds on m-c and aurora only (violating visibility rules); now they should run on the same branches where the regular desktop builds run

WIP since I need to run tests on the two newly added platforms in staging environment.

For Aki:
- What repos should I add the mozconfig debug files to, in order not to break any of the builds?
Flags: needinfo?(aki)

Comment 10

3 years ago
(In reply to Simone Bruno [:simone] from comment #9)
> Created attachment 8408340 [details] [diff] [review]
> buildbot-configs_WIP.diff
> 
> Work In Progress - Patch to buildbot-configs doing the following:
> - add linux32_gecko-debug and win32_gecko-debug platforms and relative
> configuration sections
> - explicitly disable nightly builds on m-c, aurora, mozilla-b2g28_v1_3t and
> mozilla-b2g28_v1_3

You might be able to do that via enable_nightly=False inside the *_gecko-debug config blocks (you're setting enable_dep=True; you can set enable_nightly=False).

> - remove code which enabled linux64 and macOS builds on m-c and aurora only
> (violating visibility rules); now they should run on the same branches where
> the regular desktop builds run

You probably want to remove them, but with an if statement like


    for name, branch in items_before(BRANCHES, 'gecko_version', 30):

which will get everything older than mozilla-aurora.

> 
> WIP since I need to run tests on the two newly added platforms in staging
> environment.
> 
> For Aki:
> - What repos should I add the mozconfig debug files to, in order not to
> break any of the builds?

b2g-inbound will get all the trunk-level repos after some time.  You'll explicitly need to uplift to mozilla-aurora.
Flags: needinfo?(aki)
(Assignee)

Comment 11

3 years ago
Created attachment 8410483 [details] [diff] [review]
buildbot-configs.diff

Given the changes occurred since last week in the underlining code-base, this patch became simpler: just adding sections for debug builds, disabling nightlies in the main configuration section for each, and enabling only for gecko_version >= 30.
Attachment #8408340 - Attachment is obsolete: true
Attachment #8410483 - Flags: review?(aki)
(Assignee)

Comment 12

3 years ago
Created attachment 8410484 [details]
win32_debug_mozconfig

mozconfig file to be used for win32 gecko debug build
Attachment #8410484 - Flags: review?(aki)
(Assignee)

Comment 13

3 years ago
Created attachment 8410486 [details]
mozconfig_linux32_gecko-debug
Attachment #8410486 - Flags: review?(aki)

Updated

3 years ago
Attachment #8410486 - Flags: review?(aki) → review+

Updated

3 years ago
Attachment #8410484 - Flags: review?(aki) → review+

Comment 14

3 years ago
Comment on attachment 8410483 [details] [diff] [review]
buildbot-configs.diff

As long as you land the mozconfigs this week, aurora is good.  If it's after Monday, you'll need to land them in mozilla-b2g30_v1_4.

This should [hopefully] handle all the builds.  Now we need tests.
That'll involve setting enable_debug_unittests to True:
http://hg.mozilla.org/build/buildbot-configs/file/e1778eb13d63/mozilla-tests/b2g_config.py#l620
ideally we also turn that off on the older-than-1.4 branches to avoid creating unnecessary builders.  We also need to populate the debug_unittest_suites: http://hg.mozilla.org/build/buildbot-configs/file/e1778eb13d63/mozilla-tests/b2g_config.py#l623

Let me know if you have questions about that.
Attachment #8410483 - Flags: review?(aki) → review+

Comment 15

3 years ago
Jonathan: same unittest suites for desktop debug builds?
Flags: needinfo?(jgriffin)
(In reply to Aki Sasaki [:aki] from comment #15)
> Jonathan: same unittest suites for desktop debug builds?

Yes, please.  We may have to disable some tests to get green, but that's a good starting point.
Flags: needinfo?(jgriffin)
(Assignee)

Comment 17

3 years ago
Thanks Aki, Jonathan.
I will add a new patch to enable unittests first thing tomorrow morning.
(Assignee)

Comment 18

3 years ago
Created attachment 8410890 [details] [diff] [review]
buildbot-configs_II_unittests.diff

- enabling unittests
- defining unittest suites
- disabling unit test suites on older branches
Attachment #8410890 - Flags: review?(aki)

Comment 19

3 years ago
Comment on attachment 8410890 [details] [diff] [review]
buildbot-configs_II_unittests.diff

Thanks!  I wasn't able to apply this due to bitrot -- if you can run test-master.sh before landing, great.  If not, a) we should get you able to do so in the future, and b) watch releng-ci in #releng for a green result.
Attachment #8410890 - Flags: review?(aki) → review+
(Assignee)

Comment 20

3 years ago
mozconfigs for linux32 and win32 pushed to aurora, now pushing to b2g-inbound
(Assignee)

Updated

3 years ago
Attachment #8410484 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8410486 - Flags: checked-in+
(Assignee)

Comment 21

3 years ago
mozconfig files checked in with commits:
http://hg.mozilla.org/integration/b2g-inbound/rev/6c67c3dec3d0
http://hg.mozilla.org/releases/mozilla-aurora/rev/4dc5063a4574
https://hg.mozilla.org/mozilla-central/rev/6c67c3dec3d0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v1.4: --- → fixed
status-b2g-v2.0: --- → fixed
status-firefox30: --- → fixed
status-firefox31: --- → fixed

Comment 23

3 years ago
We still need the buildbot bits aiui.
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
(Assignee)

Comment 24

3 years ago
Buildbot part pushed to default branch of buildbot-configs as well:
https://hg.mozilla.org/build/buildbot-configs/rev/18feb0e40ad8
plus extra bug fix:
https://hg.mozilla.org/build/buildbot-configs/rev/67c339f110df
Depends on: 1004610
Depends on: 1004635
(Assignee)

Comment 25

3 years ago
Created attachment 8416041 [details] [diff] [review]
enable_tests_on_cedar_only.diff

As agreed with RyanVM and coop (in #releng), these tests need to be enabled on cedar only until they green up before enabling them in prod.
Attachment #8416041 - Flags: review?(aki)

Updated

3 years ago
Attachment #8416041 - Flags: review?(aki) → review+
(Assignee)

Comment 26

3 years ago
Comment on attachment 8416041 [details] [diff] [review]
enable_tests_on_cedar_only.diff

https://hg.mozilla.org/build/buildbot-configs/rev/f6924a6fa84a
Attachment #8416041 - Flags: checked-in+
Merged and deployed to production.
Per bug 1004610 comment 9, we're now ok to enable Linux64 (only) debug gaia-ui-test on all trunk trees (or at the least: {mozilla-central, mozilla-inbound, fx-team, b2g-inbound, try}).

Updated

3 years ago
No longer depends on: 1004610
Duplicate of this bug: 1004610
(Assignee)

Comment 30

3 years ago
Created attachment 8421837 [details] [diff] [review]
enable_gaia_ui_tests_for_linux64
Attachment #8421837 - Flags: review?(aki)
(Assignee)

Updated

3 years ago
Attachment #8421837 - Flags: review?(aki)
(Assignee)

Comment 31

3 years ago
Created attachment 8421845 [details] [diff] [review]
enable_gaia_ui_tests_for_linux64
Attachment #8421837 - Attachment is obsolete: true
Attachment #8421845 - Flags: review?(aki)

Updated

3 years ago
Attachment #8421845 - Flags: review?(aki) → review+
(Assignee)

Comment 32

3 years ago
Comment on attachment 8421845 [details] [diff] [review]
enable_gaia_ui_tests_for_linux64

Checked in: https://hg.mozilla.org/build/buildbot-configs/rev/3fc51abcc61a
Attachment #8421845 - Flags: checked-in+
something here is in production
Simone: bad news, that patch didn't turn back on just gaia-ui-tests, it turned everything back on. We're now back to running all of the still-broken jobs on every tree.

(Worse news, though you couldn't have expected it: turning something back on that quickly, before the thing that cleans up old schedulers gets a chance to remove the old ones, causes us to schedule all the jobs between the time they were turned off and when they were turned back on, so we're currently trying to run the intervening 3000-odd jobs.)

Comment 35

3 years ago
Ugh, I should have (or you could have) run builder_list.py and diffed:
https://wiki.mozilla.org/ReleaseEngineering:TestingTechniques#builder_list.py_.2F_dump_master.py
https://bugzilla.mozilla.org/show_bug.cgi?id=1009517#c3

Comment 36

3 years ago
Comment on attachment 8421845 [details] [diff] [review]
enable_gaia_ui_tests_for_linux64

Backed out: https://hg.mozilla.org/build/buildbot-configs/rev/86a72a6bb486
Attachment #8421845 - Flags: checked-in+ → checked-in-
(Assignee)

Comment 37

3 years ago
The problem was... a missing comma while looping on slave_platforms :-|

I am now testing the patch as recommended by aki in comment 35 before submitting for review.
(Assignee)

Comment 38

3 years ago
Created attachment 8423229 [details] [diff] [review]
enable_gaia_ui_tests_for_linux64_take_02

This time I tested this using braindump/buildbot-related/dump_masters.sh to verify that only "gaia-ui-test" tests are added on non-cedar branches.
Attachment #8421845 - Attachment is obsolete: true
Attachment #8423229 - Flags: review?(aki)

Comment 39

3 years ago
Comment on attachment 8423229 [details] [diff] [review]
enable_gaia_ui_tests_for_linux64_take_02

I also verified we're only adding gaia-ui-tests, across linux, linux64, and macosx test masters :)

>+            for slave_platform in (('linux64_gecko', 'ubuntu64_vm-b2gdt'),):

This is an odd construct for a single tuple (i.e., why are we running a for-loop once?)
I'm currently guessing we might want to add more slave_platforms in here later?

If so, can you put a space after the final comma for pep8-niceness?

    ... 'ubuntu64_vm-b2gdt'), ):
Attachment #8423229 - Flags: review?(aki) → review+
(Assignee)

Comment 40

3 years ago
Thanks aki!
That was my (arguable) idea behind the looping on a one-item tuple: keep the code ready for simple changes when we will enable more tests as soon as they are fixed on cedar.

Checked in: https://hg.mozilla.org/build/buildbot-configs/rev/0f6a6991ad9e
(Assignee)

Updated

3 years ago
Attachment #8423229 - Flags: checked-in+

Comment 41

3 years ago
Simone: jgriffin says we can mark this bug RESO FIXED.

* I see debug b2g desktop builds here: https://tbpl.mozilla.org/?showall=1&rev=9d8d16695f6a
* we can have a separate bug to enable desktop debug tests
* we may be shifting gears to emphasize mulet builds+tests instead of b2g desktop

Thanks!  (I'm leaving it REOPENED in case you wanted to resolve it yourself.)
(Assignee)

Comment 42

3 years ago
Thanks a lot Aki!

I create Bug 1013914 (Enable tests for debug B2G desktop builds as soon as they are green on Cedar) to track enabling of tests on platfroms other than linux64.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Depends on: 1045200
Depends on: 1060949
You need to log in before you can comment on or make changes to this bug.