enable position:sticky in release builds (already done in B2G)

VERIFIED FIXED in mozilla32

Status

()

Core
Layout
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: coyotebush, Assigned: kip)

Tracking

(Blocks: 1 bug, {dev-doc-complete, feature, perf})

Trunk
mozilla32
dev-doc-complete, feature, perf
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 32+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Bug 902992 enables position:sticky only on Nightly and Aurora. Among other things, we should wait for a more stable specification before enabling it on Beta and Release.
(Reporter)

Updated

4 years ago
Depends on: 915302, 916302, 915474, 915476
Depends on: 902992, 919156
Depends on: 920688
Keywords: dev-doc-needed
Depends on: 926155
Depends on: 886646
Keywords: feature
(Reporter)

Updated

4 years ago
Depends on: 930419
(Reporter)

Updated

4 years ago
Depends on: 931450
Depends on: 935765
(Reporter)

Updated

4 years ago
Depends on: 931460
Blocks: 942460
Blocks: 943849
Blocks: 945472
Blocks: 945481
No longer blocks: 945481
No longer blocks: 945472
No longer blocks: 942460
Depends on: 919434
(Reporter)

Updated

4 years ago
Depends on: 926728
(Reporter)

Updated

4 years ago
Depends on: 946235
Depends on: 949932
Can we prioritize that for 1.4 ? 

The code of sms/contacts/call log is using their own fixed header solution implemented in JS and will let us remove it as well as saving some extra repaints.
The feeling of fixed headers will be also much better since the current code relies on "scroll" events and the fixed headers are lagging behind the user gesture with APZC enabled.
blocking-b2g: --- → 1.4?
Blocks: 965341
David, can we get this for 1.4?
Flags: needinfo?(dbaron)
Keywords: perf
Assignee: nobody → dbaron
Milan

Do we need this for 1.4? Or is this something that can be moved to 1.5
Flags: needinfo?(milan)
I'm basing 1.4+ on Comment 1, so I'll leave it to Vivien to answer that. I personally have a feeling that this would be identified as a blocker by our partners, but only in a few weeks, at which point it would be much more expensive to fix.
Flags: needinfo?(milan)
Actually, I think this is enabled in B2G already (bug 945777), and most of our apps are now using position:sticky (eg bug 945481 for Messages).

Not sure why this bug is a blocker then.
Got it.  I'll update the summary so that it's clear this is for non-B2G platforms.
blocking-b2g: 1.4? → ---
Flags: needinfo?(dbaron)
Summary: enable position:sticky in release builds → enable position:sticky in release builds (already done in B2G)

Updated

3 years ago
Depends on: 979602
Depends on: 980247

Comment 7

3 years ago
Any ETA? Would be great if that could be activated soon. Fiddling around with sicky js-libraries that all are a bit buggy (for our use-case, for others they seem to work just fine), where-as position:sticky on the nightly works perfectly.

Updated

3 years ago
Depends on: 983523
(Assignee)

Updated

3 years ago
No longer depends on: 915302
(Assignee)

Updated

3 years ago
No longer depends on: 979602
(Assignee)

Comment 8

3 years ago
Created attachment 8418434 [details] [diff] [review]
Bug 916315 Patch To Enable Sticky Preference By Default, r=dbaron

This patch enables the layout.css.sticky.enabled preference by default in release builds.
Attachment #8418434 - Flags: review?(dbaron)
Did you send an intent to ship message to dev-platform per https://wiki.mozilla.org/WebAPI/ExposureGuidelines ?
Assignee: dbaron → kgilbert
Flags: needinfo?(kgilbert)
(Assignee)

Comment 10

3 years ago
(In reply to David Baron [:dbaron] (needinfo? me) (UTC-7) from comment #9)
> Did you send an intent to ship message to dev-platform per
> https://wiki.mozilla.org/WebAPI/ExposureGuidelines ?

I have sent the intent to ship message to dev-platform and am awaiting feedback.
Flags: needinfo?(kgilbert)
FYI, I think we had to disable position:sticky in a number of gaia apps for performance reasons.  For example, see bug 977680 and bug 978067.  I guess the issue is that it creates additional layerization costs.

I don't think this should hold up exposing the API, but just wanted to share that since comment 5 mentioned b2g was using it.
Attachment #8418434 - Flags: review?(dbaron) → review+
(Assignee)

Updated

3 years ago
Attachment #8418434 - Attachment description: Bug 916315 Patch To Enable Sticky Preference By Default → Bug 916315 Patch To Enable Sticky Preference By Default, r=dbaron
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/15cb2598a361
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/15cb2598a361
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32

Comment 14

3 years ago
Thead and table type of element is still not supported Sticky, Chrome Canary has supported.
That's bug 975644.

Comment 16

3 years ago
(In reply to David Baron [:dbaron] (Away/Busy May 10-22) (UTC+9) from comment #15)
> That's bug 975644.

Thanks! Current position: sticky does not seem to realize iOS 7 contacts that effect.

Updated

3 years ago
relnote-firefox: --- → ?
relnote-firefox: ? → 32+
Verified on Win 7 x64, Ubuntu 12.10 x86, Mac OS X 10.9.4 with Firefox 32 Beta 1 (BuildID: 20140722195627): "layout.css.sticky.enabled" pref is "true" by default, and position sticky seems to work fine (http://html5-demos.appspot.com/static/css/sticky.html).
Status: RESOLVED → VERIFIED
The compat table of
https://developer.mozilla.org/en-US/docs/MDN/Contribute/Tools_with_restricted_access
has been updated.
https://developer.mozilla.org/en-US/Firefox/Releases/32#CSS , too.
Keywords: dev-doc-needed → dev-doc-complete
Blocks: 1257938
You need to log in before you can comment on or make changes to this bug.