Closed Bug 916537 Opened 8 years ago Closed 8 years ago

Lightning not working, many files are missing in the .xpi package

Categories

(Calendar :: Build Config, defect)

Lightning 2.8
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: Paenglab)

Details

(Keywords: dogfood, regression)

Attachments

(1 file)

Lightning 2.8 doesn't work because many files are missing in the .xpi package. You can see this by just looking at the download size. Usual download size is about 1.8M or 1.5M:

lightning/nightly/latest-comm-central/
> lightning-2.8a1.en-US.linux-i686.xpi      14-Sep-2013 11:30     135K
> lightning-2.8a1.en-US.linux-x86_64.xpi    15-Sep-2013 11:04     135K
> lightning-2.8a1.en-US.mac.xpi             14-Sep-2013 11:56     1.5M
> lightning-2.8a1.en-US.win32.xpi           14-Sep-2013 11:28     143K
> lightning-2.8a1.en-US.win64-x86_64.xpi    14-Sep-2013 11:32     143K

All platforms except Mac OS X seem to be broken.
Regression range is between 2013-09-05 and 2013-09-10.

Size is     OK in lightning/nightly/2013/09/2013-09-05-04-59-33-comm-central/
Size is not OK in lightning/nightly/2013/09/2013-09-10-03-02-44-comm-central/

No other builds available during that time.
I still get broken views and no events showing, even if I download Lightning from as far back as 2013-08-16 (see below).

I've tried installing:

https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/lightning-2.8a1.en-US.win32.xpi

https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2013-08-16-03-02-03-comm-central/lightning-2.8a1.en-US.win32.xpi

https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2013-09-01-03-02-17-comm-central/lightning-2.8a1.en-US.win32.xpi

I'm on Thunderbird trunk:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Thunderbird/26.0a1

Am I doing something wrong? Is it bug 906344
The last build with correct size is from 2013-09-05. After this we had the build breakage. The first Linux build after the breakage from 2013-09-10 shows the small file size. I suppose a build config change could be the cause of this bug.
Peter, Trunk is a very fast moving target. It is possible that there were API or ABI changes in between that causes old Lightning builds to not work in current Thunderbird builds. If you want to test old builds try matching Thunderbird and Lightning builds, i.e. from same day.
Keywords: dogfood
Stefan: That's the *first* thing I tried. Only because that didn't work did I start trying "other" (older) builds. You may have noticed that the first link in my Comment#2 was to /latest-comm-central/ <-- "latest"!!! :-) And whose bright idea was it to remove the date from Thunderbird's UA? I am using the *current* trunk build.
Does lightning uses XPI_PKGNAME and INSTALL_EXTENSION_ID? The checkin for bug 916625 might have made a difference, but you might need to port other parts of bug 914560 too.
Attached patch proposed fix β€” β€” Splinter Review
Fix after Neil's proposal. Locally on Win 8 the package looks complete and Lightning is working again.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #805828 - Flags: review?(philipp)
Comment on attachment 805828 [details] [diff] [review]
proposed fix

Cool, thanks for the patch! r=philipp
Attachment #805828 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/452390823d77
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.8
Hmm, Linux and Windows are still missing the calendar-js directory with the files in it.
The strange is ftp://ftp.eu.mozilla.org/pub/calendar/lightning/tinderbox-builds/comm-central-win32/1379346422/ which is pre my check-in (but with Neil's patch from bug 916625) is complete and working.

I tried to build on Win7 with my patch backed out and it is working again. With my patch it failed on Win7. Maybe it worked on my Win8 because I hadn't Neil's patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The strange is, on my Win8 system with m-c and c-c on tip of today, Lightning only works with my patch. With backed out patch Lightning fails. Completely inverse to my Win7 system (and to the Tinderbox builder).
I can confirm the new problem. The 2.8a1 nightly build that was created yesterday after the check-in for Bug 916625 works for me. The 2.8a2 nightly build that contains the check-in for Bug 916537 and was created today doesn't work.

Should we back out the patch to see if it fixes comm-central and comm-auroa?

Do you clobber your builds to ensure that there are no leftovers from a previous build?
Yes, this was with clobber builds.
I built it now again on my Win8 tablet and now it also need the backout to work. I don't know why it was the other way before on my Win8 system.

Philipp, should I back out this patch to become working Lightning packages? I can leave this bug open if you want to check if a change is needed in the future.
Flags: needinfo?(philipp)
Sure, lets give the backout a try.
Flags: needinfo?(philipp)
https://tbpl.mozilla.org/php/getParsedLog.php?id=28191644&tree=Thunderbird-Trunk#error0
/usr/local/bin/ccache /builds/slave/tb-c-cen-osx64-000000000000000/build/mozilla/../clang/bin/clang -arch i386 -o ../../../../libical/src/libical/icalderivedproperty.o -c -fvisibility=hidden -DXPI_NAME=lightning -DOSTYPE=\"Darwin\" -DOSARCH=Darwin -DNO_NSPR_10_SUPPORT -DSHARED_LIBRARY=libcalbasecomps.dylib -DXPIDL_MODULE= -I/builds/slave/tb-c-cen-osx64-000000000000000/build/calendar/base/backend/libical/build/.. -I/builds/slave/tb-c-cen-osx64-000000000000000/build/calendar/base/backend/libical/build -I. -I../../../../../mozilla/dist/include -I../../../../../mozilla/dist/include/nsprpub  -I/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/mozilla/dist/include/nspr -I/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/mozilla/dist/include/nss      -fPIC -Qunused-arguments  -Qunused-arguments -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-unused -isysroot /Developer/SDKs/MacOSX10.6.sdk -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -DNO_X11 -pipe  -DNDEBUG -DTRIMMED -g -O3 -fno-omit-frame-pointer   -Qunused-arguments  -include ../../../../../mozilla/mozilla-config.h -DMOZILLA_CLIENT -MD -MP -MF .deps/icalderivedproperty.o.pp /builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/calendar/libical/src/libical/icalderivedproperty.c
icalderivedvalue.c
/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/calendar/libical/src/libical/icalderivedparameter.c:35:10: fatal error: 'icalparameter.h' file not found
#include "icalparameter.h"
         ^

https://tbpl.mozilla.org/php/getParsedLog.php?id=28192258&tree=Thunderbird-Trunk#error0

/usr/bin/ccache /tools/gcc-4.7.3-0moz1/bin/gcc -o ../../../../libical/src/libical/icalderivedparameter.o -c -I../../../../../mozilla/dist/system_wrappers -include /builds/slave/tb-c-cen-l64-00000000000000000/build/mozilla/config/gcc_hidden.h -DXPI_NAME=lightning -DMOZ_GLUE_IN_PROGRAM -DOSTYPE=\"Linux2.6.32-220.el6\" -DOSARCH=Linux -DNO_NSPR_10_SUPPORT -DSHARED_LIBRARY=libcalbasecomps.so -DXPIDL_MODULE= -I/builds/slave/tb-c-cen-l64-00000000000000000/build/calendar/base/backend/libical/build/.. -I/builds/slave/tb-c-cen-l64-00000000000000000/build/calendar/base/backend/libical/build -I. -I../../../../../mozilla/dist/include -I../../../../../mozilla/dist/include/nsprpub  -I/builds/slave/tb-c-cen-l64-00000000000000000/build/objdir-tb/mozilla/dist/include/nspr -I/builds/slave/tb-c-cen-l64-00000000000000000/build/objdir-tb/mozilla/dist/include/nss      -fPIC  -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-unused -Wcast-align -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fno-omit-frame-pointer    -include ../../../../../mozilla/mozilla-config.h -DMOZILLA_CLIENT -MD -MP -MF .deps/icalderivedparameter.o.pp /builds/slave/tb-c-cen-l64-00000000000000000/build/objdir-tb/calendar/libical/src/libical/icalderivedparameter.c
icalderivedproperty.c
In file included from /builds/slave/tb-c-cen-l64-00000000000000000/build/calendar/libical/src/libical/icalcomponent.h:28:0,
                 from /builds/slave/tb-c-cen-l64-00000000000000000/build/calendar/libical/src/libical/icalcomponent.c:29:
/builds/slave/tb-c-cen-l64-00000000000000000/build/calendar/libical/src/libical/icalproperty.h:37:34: fatal error: icalderivedparameter.h: No such file or directory
compilation terminated.
This could be fixed by a clobber.
The Lightning from Tinderbox is working now in my Win7 Daily.
For the record: this patch is also in comm-aurora and maybe should also backed out there.
Just tested the builds at http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-aurora-linux64/1379941048/ and they are working nicely in my arch linux system.
Philipp, do you want this bug leave still open to check if it is somehow needed or can it be closed?
Flags: needinfo?(philipp)
Using SeaMonkey on win7, I still have no working calendar for either the trunk or the aurora nightlies.  Lightning installs fine from the .xpi, starts in a new tab as it should, but my calendars do not display (although the tickboxes shows that they are "on").  

I am using today's aurora nightly and today's Lightning .xpi.  Starting SeaMonkey mail produces many errors in the Error Console, such as 

Timestamp: 09/24/13 12:48:23 PM
Error: Assert failed: TypeError: Components.classes['@mozilla.org/calendar/ics-service;1'] is undefined
2: [resource://calendar/modules/calStorageHelpers.jsm:144] getTimezone
3: [resource://calendar/modules/calStorageUpgrade.jsm:399] ensureUpdatedTimezones
4: [resource://calendar/modules/calStorageUpgrade.jsm:231] upgradeDB
5: [file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendar.js:348] cSC_prepareInitDB
6: [file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendar.js:157] calStorageCalendar.prototype.id
7: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js:693] cmgr_assureCache
8: [resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js:660] cmgr_getCalendars
9: [file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:146] calCompositeCalendar.prototype.prefPrefix
10: [chrome://calendar/content/calUtils.js:1896] getCompositeCalendar
11: [chrome://calendar/content/calendar-task-tree.xml:132] calendar-task-tree_XBL_Constructor

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1029

Timestamp: 09/24/13 12:48:23 PM
Error: TypeError: Components.classes[cid] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 22

Timestamp: 09/24/13 12:48:23 PM
Error: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDateTimeFormatter.js
Line: 25

Timestamp: 09/24/13 12:48:23 PM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 98

Timestamp: 09/24/13 12:48:23 PM
Error: Components.classes['@mozilla.org/calendar/ics-service;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Daniel%20Kies/AppData/Roaming/Mozilla/SeaMonkey/Profiles/XXXXXX.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 67

Opening the calendar tab in SeaMonkey mail generates the following error:

Timestamp: 09/24/13 12:57:06 PM
Error: TypeError: Components.classes[cid] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 22

A fresh profile does not resolve these problems.
The Seamonkey problem rather looks like its a version number mismatch? Dan, what size does your lightning xpi have? What version numbers are you using?

I'm closing this bug for now since I think its fixed, we can always reopen.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Flags: needinfo?(philipp)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.