Bug 918793 (browser-in-system)

[Meta] Merge the browser app into the system app

RESOLVED DUPLICATE of bug 945259

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 945259
4 years ago
4 years ago

People

(Reporter: vingtetun, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Assignee: nobody → dale
Hey Vivien, so this is pretty much impossible to do without stuffing the browser UI in the system app right? I looked into this and possible ways to split the UI into homescreen, but without a communication mechanism between homescreen and system, plus the fact the url scrolling stuff most certainly wont work cross process it seems like we are going to have to go with a pain copy and paste from browser into the system?

I think you might have had more ideas about this since the moving folder thing (as we do for lockscreen + camera) is a 2 minute job
Flags: needinfo?(21)
Sorry should have needinfod you before.

I am on PTO next week so its likely someone else will need to pick this up before the 18th, as far as I can tell looking into it there isnt a clean migration path from app browser to in system browser, I would suggest leaving the app browser as is, and porting parts of the browser piece by piece, the current browser code has a lot of refactoring needed so this seems like it would be the cleanest way
Chatted on IRC, will port piece by piece
Flags: needinfo?(21)
And deassigning as this is a meta
Assignee: dale → nobody
Alias: browser-in-system
rationale? (jus' curious)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 945259
You need to log in before you can comment on or make changes to this bug.