Remove empty screen for "Top sites"

VERIFIED FIXED in Firefox 26

Status

()

Firefox for Android
General
P4
normal
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: liuche, Assigned: liuche)

Tracking

27 Branch
Firefox 27
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox26 fixed, firefox27 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

"Top sites" now includes thumbnails of the most visited sites, so the empty screen for that page will never be displayed. We should remove the resources and references to those resources.
Whiteboard: [mentor=liuche][lang=java]

Comment 1

4 years ago
this sounds like it would be a good first bug for me. java is my strongest language so it would be a good intro to development for fennec. would you be happy to mentor me on this as my first bug fix when i get my build environment set up?
Hi basscase, I actually completely forgot I had filed this bug and ended up writing a patch for it in another bug - if you'd like to look at the patch, I'll be uploading it here.

I apologize for the confusion on my part - there another bug that you think you'd like to try out?

And feel free to drop into #mobile on Mozilla's irc server: irc.mozilla.org - we're happy to answer any questions you have there!
Whiteboard: [mentor=liuche][lang=java]
Created attachment 809973 [details] [diff] [review]
1-remove-empty-topsites

Moved the patch from bug 919230, because I forgot I filed this bug.
Assignee: nobody → liuche
Status: NEW → ASSIGNED
Attachment #809973 - Flags: review?(sriram)
Comment on attachment 809973 [details] [diff] [review]
1-remove-empty-topsites

Review of attachment 809973 [details] [diff] [review]:
-----------------------------------------------------------------

Nice :D
Attachment #809973 - Flags: review?(sriram) → review+
https://tbpl.mozilla.org/?tree=Fx-Team&rev=e6af0f7d99da
Target Milestone: --- → Firefox 27
Version: Firefox 26 → Firefox 27
https://tbpl.mozilla.org/?tree=Fx-Team&rev=e6af0f7d99da
(oops, clipboard fail)
https://hg.mozilla.org/integration/fx-team/rev/e6af0f7d99da
https://hg.mozilla.org/mozilla-central/rev/e6af0f7d99da
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Blocks: 920317
Created attachment 819190 [details] [diff] [review]
Aurora patch: remove top sites

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 917394
User impact if declined: bug 920317 depends on this patch
Testing completed (on m-c, etc.): on m-c for a few weeks
Risk to taking this patch (and alternatives if risky): low, code removal of xml and resources
String or IDL/UUID changes made by this patch: none (leaving in strings that are removed in 27)
Attachment #819190 - Flags: approval-mozilla-aurora?
Created attachment 819280 [details] [diff] [review]
Aurora patch: remove top sites

(Updated the patch message to match this bug)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 917394
User impact if declined: bug 920317 depends on this patch
Testing completed (on m-c, etc.): on m-c for a few weeks
Risk to taking this patch (and alternatives if risky): low, code removal of xml and resources
String or IDL/UUID changes made by this patch: none (leaving in strings that are removed in 27)
Attachment #819190 - Attachment is obsolete: true
Attachment #819190 - Flags: approval-mozilla-aurora?
Attachment #819280 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Flags: needinfo?(aaron.train)
Keywords: verifyme

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox27: --- → verified
Flags: needinfo?(aaron.train)
Keywords: verifyme
Attachment #819280 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/92d60b740d28
status-firefox26: --- → fixed
You need to log in before you can comment on or make changes to this bug.