Last Comment Bug 919797 - Insufficient Color Contrast in Folder Pane
: Insufficient Color Contrast in Folder Pane
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: Thunderbird 27.0
Assigned To: Josiah Bruner [:JosiahOne] (needinfo for responses)
:
:
Mentors:
Depends on: 921606
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 15:53 PDT by David E. Ross
Modified: 2013-10-18 20:11 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed
fixed
unaffected
+
fixed


Attachments
Fix. (1.16 KB, patch)
2013-09-24 06:11 PDT, Josiah Bruner [:JosiahOne] (needinfo for responses)
richard.marti: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
standard8: approval‑comm‑esr24+
Details | Diff | Splinter Review

Description David E. Ross 2013-09-23 15:53:21 PDT
Windows XP
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Thunderbird/24.0
Default 24.0 theme
All extensions disabled

The names of those newsgroups with unread messages that are new in the current session are displayed in the folder pane with a light blue font.  If I select such a newsgroup, a dark blue bar appears across the newsgroup entry in the folder pane.  There is insufficient color contrast to read the name of the newsgroup.
Comment 1 rsx11m 2013-09-23 17:17:11 PDT
Try changing the color for "Unvisited Links" in Tools > Options > Display > Formatting > Colors settings to a darker blue. Does it resolve the issue?

If yes, that's a fallout from bug 845807 changing the link color to some lighter blue (which is also used as highlight color for folders with new messages on Windows platforms).
Comment 2 David E. Ross 2013-09-23 18:56:04 PDT
It is the color for unvisited links (not visited links) that is also the color for folders with new unread messages.  Linking these together is a really bad idea, so bad that it is indeed a bug.
Comment 3 rsx11m 2013-09-23 20:26:54 PDT
It sounded like a good idea in bug 567603, but that was before the default link color got washed out to a lighter blue. :-\ That was the kind of side effect I expected in bug 845807 comment #16. A possible solution might be to change the folder color to a straight "color: blue;" instead, matching the OSX theme.
Comment 4 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-24 04:47:28 PDT
I can not reproduce the issue. It appears that we still use 'color: blue' for the folderpane and that the color choice in "Unvisited Links" does not affect it.

David, could you upload a screenshot of the problem?
Comment 5 Richard Marti (:Paenglab) 2013-09-24 05:12:24 PDT
The light blue is correct, see http://mxr.mozilla.org/comm-central/source/mail/themes/windows/mail/folderPane.css#223 and should be corrected to blue.

But in selected state the color should change to white, see http://mxr.mozilla.org/comm-central/source/mail/themes/windows/mail/folderPane.css#228 and http://mxr.mozilla.org/comm-central/source/mail/themes/windows/mail/folderPane.css#234

David, are you playing with userChrome and have set !important for new messages?
Comment 6 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-24 06:11:37 PDT
Created attachment 809153 [details] [diff] [review]
Fix.

So I believe this is all we really need. 

Richard, did I miss anything? (XP's selected color seems to be fine)
Comment 7 Richard Marti (:Paenglab) 2013-09-24 06:46:56 PDT
Comment on attachment 809153 [details] [diff] [review]
Fix.

Review of attachment 809153 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.

Maybe you can ask for approval‑comm‑esr24.
Comment 8 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-24 06:51:30 PDT
Comment on attachment 809153 [details] [diff] [review]
Fix.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 845807
User impact if declined: Would make it much harder for the user to read the folder item text when new mail arrives.
Testing completed (on m-c, etc.): It's a single-line theme change, not much to test.
Risk to taking this patch (and alternatives if risky): None.
String or IDL/UUID changes made by this patch: N/A
Comment 9 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-24 06:52:50 PDT
Comment on attachment 809153 [details] [diff] [review]
Fix.

Whoops. Wrong one, clearing approval flag.
Comment 10 Ryan VanderMeulen [:RyanVM] 2013-09-24 07:21:58 PDT
https://hg.mozilla.org/comm-central/rev/b9912ce44610
Comment 11 David E. Ross 2013-09-24 09:44:07 PDT
How can I obtain the fixed theme to install it now rather than waiting for the next version of Thunderbird?
Comment 12 rsx11m 2013-09-24 12:28:24 PDT
You could either apply a userChrome.css override (yes, I've seen your bug 919802) or hack folderPane.css in the omni.ja file of your installation. The easiest fix should be to just go into Tools > Options > Display > Formatting > Colors and change the color for unvisited links to a darker blue.

Josiah: You've removed approval-mozilla-aurora? but didn't request approval-comm-aurora? at the same time, on purpose?
Comment 13 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-24 12:51:22 PDT
Comment on attachment 809153 [details] [diff] [review]
Fix.

[Approval Request Comment]
Regression caused by (bug #): Bug 845807
User impact if declined: Users with less-than-perfect vision may be unable to clearly read the text in the folder pane when new messages arrive.
Testing completed (on c-c, etc.): Landed on c-c.
Risk to taking this patch (and alternatives if risky): Absolutely none.
Comment 14 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-24 12:55:53 PDT
(In reply to rsx11m from comment #12)
> Josiah: You've removed approval-mozilla-aurora? but didn't request
> approval-comm-aurora? at the same time, on purpose?

Kind of. I started to do the esr request but got distracted. That's why there was a delay until now.
Comment 15 Jim Porter (:squib) 2013-09-24 14:08:31 PDT
It'd be nice if we kept the current (TB 24.0) colors on Aero, where there shouldn't be a contrast issue.
Comment 16 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-09-25 06:39:47 PDT
(In reply to Jim Porter (:squib) from comment #15)
> It'd be nice if we kept the current (TB 24.0) colors on Aero, where there
> shouldn't be a contrast issue.

I don't really see any benefit in doing that. Why have different colors when we could just keep them consistent across platforms, thereby making theme developers lives easier?
Comment 17 Richard Marti (:Paenglab) 2013-09-25 07:01:03 PDT
(In reply to Josiah Bruner [:JosiahOne] from comment #16)
> (In reply to Jim Porter (:squib) from comment #15)
> > It'd be nice if we kept the current (TB 24.0) colors on Aero, where there
> > shouldn't be a contrast issue.

With this patch there is no change for Aero.

> I don't really see any benefit in doing that. Why have different colors when
> we could just keep them consistent across platforms, thereby making theme
> developers lives easier?

All systems except OS X could have a lot of different color schemes where the fixed blue can be not readable. But it's hard (or almost impossible) to find a good system color, so let's stay to use blue for all systems except Aero.

Maybe in not so long time a bug would be filed for the Windows high contrast themes were blue isn't readable. Then we need to find a good system color for all system themes...
Comment 18 rsx11m 2013-09-25 07:25:42 PDT
Avoiding the "dark blue on black" issue for High-Contrast desktop themes was part of the idea to use the unvisited-link color in bug 567603, assuming that a user may change that to something more readable if the HC theme is used permanently. Thus, the same change would also apply to a folder with new messages.
Comment 19 Mark Banner (:standard8) 2013-10-09 13:17:16 PDT
Comment on attachment 809153 [details] [diff] [review]
Fix.

[Triage Comment]
a=Standard8
Comment 21 serge.lacombe 2013-10-18 17:35:34 PDT
Hi,

Seams every time you upgrade I have a new bug to solve. This time a new one... I have design images that I use as a signature on the bottom of my email and suddenly after upgrading to version 24... the image/signature was blurred like pale... like if it was covered with a veil.

I'm not an expert, but I think you «Propeller-head» should stop changing and stick to a version... for good! But my experience with Mozilla lead me to believe this bug will disappear with the next upgrade... just be patient. loll
Comment 22 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-10-18 20:11:42 PDT
(In reply to serge.lacombe from comment #21)
> Hi,
> 
> Seams every time you upgrade I have a new bug to solve. This time a new
> one... I have design images that I use as a signature on the bottom of my
> email and suddenly after upgrading to version 24... the image/signature was
> blurred like pale... like if it was covered with a veil.
> 
> I'm not an expert, but I think you «Propeller-head» should stop changing and
> stick to a version... for good! But my experience with Mozilla lead me to
> believe this bug will disappear with the next upgrade... just be patient.
> loll

Bugzilla is a development-related site for development-related topics. Please do not use it as a ranting site. This bug does not contribute to your problem at all. However, we are aware of that issue and it has been fixed in bug 917906. The change should arrive within the next '.' release. Thanks, 

Josiah Bruner

Note You need to log in before you can comment on or make changes to this bug.