Closed Bug 920413 Opened 8 years ago Closed 7 years ago

A new preference to disable mail count on badge of Thunderbird on Mac OS

Categories

(Thunderbird :: OS Integration, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 391674

People

(Reporter: jonpublic2, Unassigned)

Details

Currently, the badge for Thunderbird in both the dock and task switcher shows either the unread mail or new mail count (depending on the value of mail.biff.use_new_count_in_mac_dock). However, I find this distracting, since I often should be doing something other than checking at my e-mail! There is no such count in Windows (perhaps partly for technical reasons). It would be great if there were an option to simply disable the mail count so the badge just showed the Thunderbird icon. 

To show that I am not the only person affected by this, consider these links:
http://forums.mozillazine.org/viewtopic.php?f=39&t=1097885
http://superuser.com/questions/473374/in-thunderbird-on-os-x-how-can-i-disable-seeing-how-many-new-messages-i-have-wh
Check Notifications settings for Thunderbird badge options, please.
I don't see Thunderbird badge options. Where are they? Alternatively, could you indicate settings in about:config?
On the System Preferences for OS X, section Notifications. On the left there is a list of apps. One of them should be Thunderbird. When selected, on the right panel there would be a checkbox for disable the badge on the Dock icon.

Check http://support.apple.com/kb/HT5362
While I have an option for Mail, I don't have one for Thunderbird. Do you? And the one for Mail doesn't seem to work for Thunderbird.
On my Notification section I do have both of them. well, as I am using trunk build, it is called "Daily" but except that fact, it is  there and can be setup.

As far as I know there is no preference for disabling the badge, neither a hidden one on about:config.
Same problem here. Does anyone have a link to the "Daily" version that Javi mentioned?
(In reply to Scott from comment #6)
> Same problem here. Does anyone have a link to the "Daily" version that Javi
> mentioned?

Daily is the name for the development stage in which the application is unstable and things could change a lot on a day to day basis. In a more general way to say it, it is the compilation of code which resides on the trunk repository.

If you want the compilation I was referring to on my comment, you could try latest Thunderbird release, as code has now passed through the alpha and beta stages.

Just for your information, Daily build are stored on https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/ and latest one is https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/ but take note that they could (and are very likely to) include some problems still not fixed. It is NOT for final users or on a production site.
Looks like I'd managed to find the dailies previously. I had downloaded a daily in May and just assumed I had the wrong thing because no notification option was added in the System Preferences. Neither that build or the latest seem to add anything to the notifications preferences. From what I'm seeing, this issue has been marked fixed/resolved in multiple bug reports, with somewhat of a controversy...

bug 728385
bug 852648

In the spirit of this report, there's already a place in the TB preferences for the app icon count. (General->App Icon Options...) The "Badge app icon with:" section seems like an obvious place for a "Don't Show" option to be added.

Image of the area mentioned:
http://imgur.com/1pMIhft
Could you provide your Build Information, Scott? You could copy and paste it form "Help/Troubleshooting Information/User Agent"
Flags: needinfo?(scooterbaga)
Despite a restart and sending myself a test email, the notifications for Daily didn't fire until I received the "more info" request. The "Daily" option didn't appear in the notification preferences until after I'd received a notification. This option allowed me to turn off the badge count.

I doubt it's still necessary, but the following is the requested info:



  Application Basics

    Name: Thunderbird
    Version: 34.0a1
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:34.0) Gecko/20100101 Thunderbird/34.0a1
    Profile Folder: Show in Finder
    Application Build ID: 20140723030201
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Memory Use: about:memory

  Mail and News Accounts
    account1:
      INCOMING: account1, , (imap) imap.mail.me.com:993, SSL, passwordCleartext
      OUTGOING: smtp.mail.me.com:587, alwaysSTARTTLS, passwordCleartext, true

    account2:
      INCOMING: account2, , (none) Local Folders, plain, passwordCleartext

    account3:
      INCOMING: account3, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, false

    account5:
      INCOMING: account5, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, false

  Crash Reports

  Extensions
    Google Contacts, 0.7.12, true, {BDD92442-0534-4D6F-A966-BAB7D561D781}
    Google Search for Thunderbird, 1.0, true, gsearch@standard8.plus.com
    Minimize On Start and Close, 1.3.2, true, {480adee0-f020-4fef-917d-b05502b17aaf}
    MoreFunctionsForAddressBook, 0.6.11.2, true, {3e17310d-82e8-4a43-bd2f-7c3055bfe589}

  Important Modified Preferences

    Name: Value

      accessibility.typeaheadfind.flashBar: 0
      browser.cache.disk.capacity: 358400
      browser.cache.disk.smart_size_cached_value: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      extensions.lastAppVersion: 34.0a1
      font.internaluseonly.changed: false
      font.name.monospace.el: Consolas
      font.name.monospace.tr: Consolas
      font.name.monospace.x-baltic: Consolas
      font.name.monospace.x-central-euro: Consolas
      font.name.monospace.x-cyrillic: Consolas
      font.name.monospace.x-unicode: Consolas
      font.name.monospace.x-western: Consolas
      font.name.sans-serif.el: Calibri
      font.name.sans-serif.tr: Calibri
      font.name.sans-serif.x-baltic: Calibri
      font.name.sans-serif.x-central-euro: Calibri
      font.name.sans-serif.x-cyrillic: Calibri
      font.name.sans-serif.x-unicode: Calibri
      font.name.serif.el: Cambria
      font.name.serif.tr: Cambria
      font.name.serif.x-baltic: Cambria
      font.name.serif.x-central-euro: Cambria
      font.name.serif.x-cyrillic: Cambria
      font.name.serif.x-unicode: Cambria
      font.name.serif.x-western: Cambria
      font.size.fixed.el: 14
      font.size.fixed.tr: 14
      font.size.fixed.x-baltic: 14
      font.size.fixed.x-central-euro: 14
      font.size.fixed.x-cyrillic: 14
      font.size.fixed.x-unicode: 14
      font.size.fixed.x-western: 14
      font.size.variable.el: 17
      font.size.variable.tr: 17
      font.size.variable.x-baltic: 17
      font.size.variable.x-central-euro: 17
      font.size.variable.x-cyrillic: 17
      font.size.variable.x-unicode: 17
      font.size.variable.x-western: 13
      gfx.blacklist.direct2d: 3
      gfx.blacklist.layers.direct3d9: 3
      gfx.blacklist.webgl.msaa: 4
      mail.openMessageBehavior.version: 1
      mail.spotlight.enable: true
      mail.spotlight.firstRunDone: true
      mail.spotlight.global_reindex_time: 1401471692
      mail.winsearch.firstRunDone: true
      mailnews.database.global.datastore.id: 54dd41f5-e412-4746-9b8e-414bb35eec9
      network.cookie.cookieBehavior: 2
      network.cookie.prefsMigrated: true
      places.database.lastMaintenance: 1407538296
      places.history.expiration.transient_current_max_pages: 104858
      plugin.importedState: true

  Graphics

      Vendor ID: 0x1002
      Device ID: 0x6741
      WebGL Renderer: false
      GPU Accelerated Windows: 2/2 OpenGL

      AzureCanvasBackend: quartz
      AzureSkiaAccelerated: 0
      AzureFallbackCanvasBackend: none
      AzureContentBackend: quartz

  JavaScript

  Incremental GC: 1

  Accessibility

    Activated: 0
    Prevent Accessibility: 0

  Library Versions

      Expected minimum version
      Version in use

      NSPR
      4.10.7 Beta
      4.10.7 Beta

      NSS
      3.17 Basic ECC Beta
      3.17 Basic ECC Beta

      NSS Util
      3.17 Beta
      3.17 Beta

      NSS SSL
      3.17 Basic ECC Beta
      3.17 Basic ECC Beta

      NSS S/MIME
      3.17 Basic ECC Beta
      3.17 Basic ECC Beta
Flags: needinfo?(scooterbaga)
(In reply to Scott from comment #10)
>     User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:34.0)
> Gecko/20100101 Thunderbird/34.0a1

This line was the only one I needed. Thank you, Scott.

Jonathan, could you also proved User Agent for your build?
Flags: needinfo?(jonpublic2)
Hi.

It's
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Thunderbird/31.0

Actually, as Javi suggested it would, I now have an option for configuring Thunderbird in System Preferences for OS X | Notifications, where I can disable the badge, which seems to resolve this issue. I didn't check it until now. I am actually on a loner machine at the moment, because my primary computer is in the shop, so I can't check on there.

If this does, in fact, work consistently (which it might not for Scott) it still might be nice if there were a note of some sort in the Thunderbird preferences that there are more options in the OS X Notification options. However, if the same options appear on my primary computer when it returns, I considered this issue resolved (for me).
Flags: needinfo?(jonpublic2)
Bug 39674 was asking the same. Duping this one as it is not older.

Jonathan, in case you want to provide more information that could make it easier to fix your problem, or provide any tip, you could use bug 391674 from now on. Thank you for your collaboration.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391674
You need to log in before you can comment on or make changes to this bug.