[User Story] Display a message at the end of a call (FFOS 1.3)

RESOLVED FIXED in 1.3 Sprint 5 - 11/22

Status

Firefox OS
Gaia::Dialer
P1
blocker
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: WDM, Assigned: rexboy)

Tracking

(Blocks: 1 bug, {feature})

unspecified
1.3 Sprint 5 - 11/22
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: [ucid:Comms34, 1.3:p1, ft:comms])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User story:

As a user I want to be informed with a simple screen when a call has ended.

Acceptance Criteria:

AC9.1 I want the call ended modal screen not to contain any detailed information than simple text saying "call ended".

AC9.2 I want this information to be displayed for 2 seconds after the call has ended.

AC9.3 when in a conference call I want only the message to display when last participant has left the call or in as the conf call owner, hang up the call.
Flags: in-moztrap?(jhammink)
Duplicate of this bug: 910041
Whiteboard: [ucid:Comms34, 1.3:p1]

Comment 2

4 years ago
Steal the in-moztrap? flag and start to analysis the user story
Flags: in-moztrap?(jhammink) → in-moztrap?(atsai)

Comment 3

4 years ago
#10558, #10559
Flags: in-moztrap?(atsai) → in-moztrap+
blocking-b2g: 1.3? → 1.3+
ni? jsavory on UX spec
Flags: needinfo?(jsavory)
Assignee: nobody → rexboy
Target Milestone: --- → 1.3 Sprint 4 - 11/8
Created attachment 822488 [details]
Dialer_JS_131015.pdf

I've attached the most recent version of the wireframes for this story to the bug, please let me know if there are any questions.
Flags: needinfo?(jsavory)

Comment 6

4 years ago
So, follow the design, will the contacts app use the same layout (Name + Portrait) to display?
blocking-b2g: 1.3+ → 1.3?
Flags: needinfo?(jsavory)
Target Milestone: 1.3 Sprint 4 - 11/8 → ---

Comment 7

4 years ago
Contact app & call log dialer app doesn't show picture in thread list view.  Please help to confirm if we add this design in v1.3
(Reporter)

Updated

4 years ago
blocking-b2g: 1.3? → 1.3+

Comment 8

4 years ago
(In reply to Paul Yang [: pyang] from comment #7)
> Contact app & call log dialer app doesn't show picture in thread list view. 
> Please help to confirm if we add this design in v1.3

Just flash latest master and see it is there.

Comment 9

4 years ago
Clean ni? since issue solved
Flags: needinfo?(jsavory)
Working on a WIP.
I'm not sure if showing "Call ended" directly (p.10) on hanging conference call is easy to implement.. since when ending conference call, the last two call remaining in conference is moved out to normal call on mozTelephony and therefore the dialer reacts against events and move these calls out too. I'm still investigating a good idea for this.

For p.9 and p.11 I have an initial version now.
For ending conference call in p.10, can we just show arbitrary one of those phones inside conference call rather than showing group? As mentioned in comment 10, the last call in conference call always come back to normal call before it's hanged up, so it would be much easier if we just keep the same state with it.

Jsavory may you give some input on this?
Flags: needinfo?(jsavory)
Target Milestone: --- → 1.3 Sprint 4 - 11/8
I worry that if the user is suddenly brought from a group call to an ended single call, it may appear very confusing. This may cause the user to assume that they hung up on a individual who was calling them when they did not intend to. 

I feel that it would be a much better experience if the user can, in some manner, see that they have ended their conference call and not one with an individual. Is there any way to make this possible?
Flags: needinfo?(jsavory)
Flags: needinfo?(rexboy)
Alright, I have a light on implementing it. Let me try on it.
I'll put an updated patch later. It may need some confirmation with reviewer though.
Flags: needinfo?(rexboy)
Target Milestone: 1.3 Sprint 4 - 11/8 → 1.3 Sprint 5 - 11/22

Updated

4 years ago
Blocks: 937014
Created attachment 830133 [details]
patch

Finally arranged a patch here.
I may need some opinion since this patch changed behavior of CallScreen.SingleLine to make the 2-second lasting possible, see detail comments in Github.
Hello Etienne, would you mind reviewing this patch? 


I tested with some cases including
1. Hang-up single call
2. Hang-up single conference call
3. Hang-up double call
4. Hang-up conference call while there's another call is on hold
5. continuing 4, join the remaining call into conference call and hang up again
6. When incoming call arrives, choose hang-up active call

And they seems works well (as what I imagined). I can take some movie for its reaction if required.
Attachment #830133 - Flags: review?(etienne)
Oh, almost forgot to mention...
I've found a mozTelephony bug which affects the patch, opened in bug 936982.
It causes the last call exiting conference call goes back to connected status even it's already been hanging up.
I wrote some workaround in the patch for that.
Comment on attachment 830133 [details]
patch

Comments are on github, hope I covered everything.
Attachment #830133 - Flags: review?(etienne)
Thanks for the detailed review, Etienne!

Finished most of them but the .duration position of isTimer of multi-call mode... I'll take care of it on Monday.
Whiteboard: [ucid:Comms34, 1.3:p1] → [ucid:Comms34, 1.3:p1, ft:comms]
Comment on attachment 830133 [details]
patch

OK, changes are inside another commit.

Etienne may you take a look again?
Attachment #830133 - Flags: review?(etienne)
Comment on attachment 830133 [details]
patch

Added a few comments on github but all test-related so we're very close to landing :)
Attachment #830133 - Flags: review?(etienne)
Comment on attachment 830133 [details]
patch

Minor changes per discussion on github.

I'll squash all commits before landing. Thanks!
Attachment #830133 - Flags: review?(etienne)
Comment on attachment 830133 [details]
patch

All good!

We'll probably want some special QA attention for this since it's a big change.
Attachment #830133 - Flags: review?(etienne) → review+
Thanks for all the helping Etienne!

landed in master. There are some rebase work to deconflict with patch of bug 923646 before merging.
https://github.com/mozilla-b2g/gaia/commit/e8fc65323606c4b0df848c23b13a483d0da37baf
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.