No sound is played when connecting a Delay Node

VERIFIED FIXED in mozilla27

Status

()

Core
Web Audio
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: adalucinet, Assigned: karlt)

Tracking

Trunk
mozilla27
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed in bug 910174])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Reproducible on Firefox 25 beta 3 (BuildID: 20130926170421)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Reproducible on the latest Aurora (BuildID: 20130927004007)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Reproducible on the latest Nightly (BuildID: 20130927030202)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:27.0) Gecko/20100101 Firefox/27.0

Steps to reproduce:
1. Launch Firefox.
2. Navigate to http://webaudioplayground.appspot.com/.
3. Use the dropdown "Add audio source" and create an AudioBufferSourceNode.
4. Use the dropdown "Add Module" and create a DelayNode.
5. Connect the nodes.
6. Press the Play button on the AudioBufferSourceNode.
7. Repeat step 6 when the Play button is displayed again.

Expected results: Sound is played.

Actual results: No sound is played.

Notes:
1. Not reproducible with Chrome.
2. Reproducible with Firefox 25 beta 3 on Windows XP 32bit, Windows 7 64bit, Mac OS X 10.8 and Ubuntu 13.04 64bit.
3. Reproducible with Nightly from 2013-09-03, when the fix for bug 890528 was pushed.

Comment 1

5 years ago
Over to Maire for owner hunt down.  :-)
Assignee: nobody → mreavy
CCing Alex Keybl since he wanted to be kept in the loop on QA for Web Audio.
Created attachment 811259 [details]
testcase.zip

This is a minimal testcase that shows the issue. Just click the 'trigger' button more than once.

Expected: we hear a number of sound equal to the number of clicks
Actual: we hear only one sound.
(Assignee)

Comment 4

5 years ago
Paul's testcase at least is fixed by something in my patch queue.
https://tbpl.mozilla.org/?tree=Try&rev=ff30e14e1fd3
Probably the patch for bug 910174.
Assignee: mreavy → karlt
Depends on: 910174
(In reply to Karl Tomlinson (:karlt) from comment #4)
> Paul's testcase at least is fixed by something in my patch queue.
> https://tbpl.mozilla.org/?tree=Try&rev=ff30e14e1fd3
> Probably the patch for bug 910174.

Alexandra -- Could you retest this bug with the Try build that Karl references in Comment 4 above?  If this bug is fixed (not reproducible) using that Try build, I think we can dupe this bug to Bug 910174.  Thanks!
Flags: needinfo?(alexandra.lucinet)
(Reporter)

Comment 6

5 years ago
(In reply to Maire Reavy [:mreavy] from comment #5)
> Alexandra -- Could you retest this bug with the Try build that Karl
> references in Comment 4 above?  If this bug is fixed (not reproducible)
> using that Try build, I think we can dupe this bug to Bug 910174.  Thanks!

When I try to build the ff30e14e1fd3 changeset, I get the following error: "abort:unknown revision 'ff30e14e1fd3'" on both Ubuntu and Mac OS X. Same result for 5112c9b09e92 changeset. Could you please provide guidance in order to retest this issue?
Flags: needinfo?(alexandra.lucinet)
(Reporter)

Updated

5 years ago
Flags: needinfo?(mreavy)
 (In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #6)
> 
> When I try to build the ff30e14e1fd3 changeset, I get the following error:
> "abort:unknown revision 'ff30e14e1fd3'" on both Ubuntu and Mac OS X. Same
> result for 5112c9b09e92 changeset. Could you please provide guidance in
> order to retest this issue?

To test this, you need to download the Try build from here: https://tbpl.mozilla.org/?tree=Try&rev=ff30e14e1fd3

Don't try to build it yourself.
Flags: needinfo?(mreavy)
(In reply to Maire Reavy [:mreavy] from comment #7)
>  (In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #6)
> > 
> > When I try to build the ff30e14e1fd3 changeset, I get the following error:
> > "abort:unknown revision 'ff30e14e1fd3'" on both Ubuntu and Mac OS X. Same
> > result for 5112c9b09e92 changeset. Could you please provide guidance in
> > order to retest this issue?
> 
> To test this, you need to download the Try build from here:
> https://tbpl.mozilla.org/?tree=Try&rev=ff30e14e1fd3
> 
> Don't try to build it yourself.

I want to know if the Try build shows this bug or not.  Thanks!
(Assignee)

Comment 9

5 years ago
Alexandra, the try build above has only mobile builds and includes some extra patches.  Please use the link below instead.  It includes desktop builds and only the patches that have landed for Bug 910174.

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=cb856e6d57c1

When the builds have completed, mouse click on a 'B' and then "go to build directory" to find builds to download.
(Reporter)

Comment 10

5 years ago
Karl, thanks for guidance.

The Try build (Build ID: 20130930145650) doesn't show this issue: is fixed with both STR from comment 0 and attached testcase - the number of sound is equal with the number of clicks. Verified on Ubuntu, Mac OS X and Windows XP since only this builds were completed:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

While testing, I have encountered an issue on the URL from comment 0 with the following STRs:
1. Navigate to http://webaudioplayground.appspot.com/.
2. Create an AudioBufferSourceNode and a DelayNode.
3. Connect the nodes.
4. Press the Play button on the AudioBufferSourceNode.
5. Change the sound while another is still playing (eg: play glass-hit.ogg and change it to drums.ogg)
6. Repeat step 7.

This new issue is intermittent and reproducible only when the DelayNode is present; works on Chrome. 
Could it be related with this bug?
(Assignee)

Comment 11

5 years ago
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #10)
> (Build ID: 20130930145650) doesn't show this issue: is fixed
> with both STR from comment 0 and attached testcase

Thanks.  That is the Mozilla-Inbound build, which is good.

> While testing, I have encountered an issue on the URL from comment 0 with
> the following STRs:
> 1. Navigate to http://webaudioplayground.appspot.com/.
> 2. Create an AudioBufferSourceNode and a DelayNode.
> 3. Connect the nodes.
> 4. Press the Play button on the AudioBufferSourceNode.
> 5. Change the sound while another is still playing (eg: play glass-hit.ogg
> and change it to drums.ogg)
> 6. Repeat step 7.

I don't know.  Can you file a new bug, please, with a description of the difference in behavior between when the bug reproduces and when it doesn't?
Is it reproducible enough to compare with an older Inbound or older Nightly build to see whether the issue is related to the changes that landed for Bug 910174?
Perhaps step 6 is "Repeat step 4"?
(Reporter)

Comment 12

5 years ago
(In reply to Karl Tomlinson (:karlt) from comment #11)

> I don't know.  Can you file a new bug, please, with a description of the
> difference in behavior between when the bug reproduces and when it doesn't?
> Is it reproducible enough to compare with an older Inbound or older Nightly
> build to see whether the issue is related to the changes that landed for Bug
> 910174?

Filled bug 922639 and added you and Maire Reavy to :cc. Please see there the answers for the above questions.

> Perhaps step 6 is "Repeat step 4"?

Sorry for the typo, you are right.

Updated

5 years ago
Blocks: 779297

Comment 13

5 years ago
Can we close this bug now?
(Assignee)

Comment 14

5 years ago
Yes :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in bug 910174]
Target Milestone: --- → mozilla27
Alexandra, please verify this is fixed in Firefox 27.
Flags: needinfo?(alexandra.lucinet)
Keywords: verifyme
(Reporter)

Comment 16

5 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0


Verified as fixed with Nightly 27.0a1 (Build ID: 20131010030202): sound is played by using STRs from comment 0 and the attached testcase.
Status: RESOLVED → VERIFIED
Flags: needinfo?(alexandra.lucinet)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.