No sound is played while switching .ogg files with DelayNode present

RESOLVED DUPLICATE of bug 857610

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 857610
6 years ago
5 years ago

People

(Reporter: adalucinet, Assigned: karlt)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
Steps to reproduce:

1. Navigate to http://webaudioplayground.appspot.com/ 
2. Create an AudioBufferSourceNode and a DelayNode.
3. Connect the nodes.
4. Press the Play button on the AudioBufferSourceNode.
5. Change the sound while the one from step 4 is still playing (eg: play glass-hit.ogg and change it to drums.ogg)
6. Press the Stop button.
7. Repeat steps from 4 to 6 a couple of times.

Expected results: Sound is played.

Actual results: No sound is played.

Notes:
1. Reproduced this issue with the Try build (Build ID: 20130930145650) from https://bugzilla.mozilla.org/show_bug.cgi?id=921457#c9 on Windows XP, Ubuntu and Mac OS X:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

2. Cannot reproduce this issue with the latest Beta, Aurora and Nightly builds due the existence of bug 921457.
3. This issue is intermittent and reproducible only when the DelayNode is present.
4. I can reproduce this issue before the changes landed for bug 910174, but see Note 2, down to Nightly 23.0a1 (2013-04-05). In Nightly from 2013-04-04 there are no sounds when DelayNode is present.
5. Works on Chrome.
Assignee

Comment 1

6 years ago
Thanks.  This is due to different channel counts in the different buffers.
It works if waiting between pressing the stop button (6) and play button (4) but not if the time between the two is less than the maximum delay of the DelayNode, which defaults to 1 second.

Bug 857610 tracks supporting different channel counts in DelayNode.
Depends on: 857610
Blocks: webaudio
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #0)
> Steps to reproduce:
> 
> 1. Navigate to http://webaudioplayground.appspot.com/ 
> 2. Create an AudioBufferSourceNode and a DelayNode.
> 3. Connect the nodes.
> 4. Press the Play button on the AudioBufferSourceNode.
> 5. Change the sound while the one from step 4 is still playing (eg: play
> glass-hit.ogg and change it to drums.ogg)
Now double click quickly on the STOP button
AR: No sound
ER: Second song should play
Priority: -- → P2
Assignee

Updated

5 years ago
Assignee: nobody → karlt
Assignee

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 857610
Resolution: --- → DUPLICATE
Duplicate of bug: 857610
You need to log in before you can comment on or make changes to this bug.