[B2G][Call Log][Lockscreen] Call log does not record missed calls when in the lockscreen

RESOLVED FIXED in Firefox OS v1.2

Status

Firefox OS
Gaia::Dialer
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gbennett, Assigned: rik)

Tracking

({regression})

unspecified
1.2 C3(Oct25)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 812182 [details]
CallLogIMG.zip

Description:
While in the lockscreen get a missed call then go into call log and no missed call shows up.

Repro Steps:
1) Updated Buri 1.2 mozRIL to Build ID: 20130929004004
2) Have device locked with no missed calls in the call log
3) Have another device call yours and have them hang up to trigger a missed call
4) Unlock device and go into the call log missed tab

Actual:
No missed calls display.

Expected:
All missed calls are shown properly.

Environmental Variables
Device: Buri 1.2 mozRIL
Build ID: 20130929004004
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/48faa2668dd8
Gaia: 1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
Platform Version: 26.0a2
Firmware Version: 20130912

Notes: 
Repro frequency: 100%, 3/3
See attached: CallLogIMG.zip

Updated

5 years ago
blocking-b2g: --- → koi?
Component: General → Gaia::Dialer
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
blocking-b2g: koi? → ---
Component: Gaia::Dialer → General
Keywords: regression, regressionwindow-wanted

Comment 1

5 years ago
Collision errors
blocking-b2g: --- → koi?
Component: General → Gaia::Dialer
Keywords: regressionwindow-wanted

Updated

5 years ago
Keywords: regression

Updated

5 years ago
QA Contact: sparsons

Comment 2

5 years ago
This issue started to occur on the 9/21 Buri Aurora 1.2 Build ID: 20130921004001

Environmental Variables
Device: Buri
Build ID: 20130921004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/20fe34362674
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2

Last working Buri 1.2 Aurora build: Build ID: 20130920004004

Environmental Variables
Device: Buri
Build ID: 20130920004004
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/46b216260c1d
Gaia: 88e73da95f1c550f2fb0572480a40c989d37c997
Platform Version: 26.0a2

This issue did not reproduce on Leo 1.1 Comm and Moz RIL Build ID: 20130930041201

Environmental Variables
Device: Leo
Build ID: 20130930041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
Keywords: regressionwindow-wanted
Severity: normal → critical
To note, I missed a call because of this and lost it; I don't want to dogfood my device without a fix for this.
blocking-b2g: koi? → koi+
(Assignee)

Updated

5 years ago
Assignee: nobody → anthony
Target Milestone: --- → 1.2 C3(Oct25)
(Assignee)

Comment 4

5 years ago
This was introduced with efeb1a2feba6c85e3167ecdd0285e9b2e765143e and the redesign of the lockscreen with an incoming call.
Blocks: 913378
(Assignee)

Comment 5

5 years ago
I'm seeing those two errors around these lines of code https://github.com/mozilla-b2g/gaia/blob/17e871ae1f82699793e3cd28acda805ba724a8b6/apps/communications/dialer/js/handled_call.js#L348-L351 :
E/GeckoConsole( 1924): [JavaScript Error: "NS_ERROR_XPC_BAD_CONVERT_JS: Component returned failure code: 0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS) [nsIXPCComponents_Utils.createObjectIn]" {file: "resource://gre/modules/ObjectWrapper.jsm" line: 56}]
E/GeckoConsole( 1438): [JavaScript Error: "TypeError: this.url is undefined" {file: "app://system.gaiamobile.org/js/browser_config_helper.js" line: 41}]
(Assignee)

Comment 6

5 years ago
After investigation, I think we close the window too early because we're not animating the closing of the call screen. And we're not animating closing because we're not animating the opening either. So we always have animating = true in calls_handler.js, and exitCallScreen() can't animate.
blocking-b2g: koi+ → koi?
Sorry koi? was a mistake
blocking-b2g: koi? → koi+
Comment on attachment 818472 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/12921

I really don't like the fact that we're leaving the CallScreen.toggle callback hanging until a side effect from the picking up/hanging up triggers it.

If the CallScreen is in locked layout we should call the callback directly, it will be much safer and tested :)
Attachment #818472 - Flags: review?(etienne) → review-
Duplicate of this bug: 925700
(Assignee)

Updated

5 years ago
Attachment #818472 - Flags: review- → review?(etienne)
Comment on attachment 818472 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/12921

Much  better :)
Land this baby! (on a green travis ;))
Attachment #818472 - Flags: review?(etienne) → review+
(Assignee)

Comment 12

5 years ago
https://github.com/mozilla-b2g/gaia/commit/e3bac924375cf99d5489b62c8b3fcf31b717bd99
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 929409
(Assignee)

Updated

5 years ago
Duplicate of this bug: 921381
Uplifted e3bac924375cf99d5489b62c8b3fcf31b717bd99 to:
v1.2: 3779edd0ce1e9711a826e106482ecde7bad36a6b
status-b2g-v1.2: affected → fixed
Wayne, can you ask the helix team to see if they can place this in 1.1 hd if they haven't please?
Flags: needinfo?(wchang)
:rik - do you know if your patch is v1.1HD friendly?

(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #16)
> Wayne, can you ask the helix team to see if they can place this in 1.1 hd if
> they haven't please?
Flags: needinfo?(wchang)
(Assignee)

Comment 18

5 years ago
Please use needinfo if you expect an answer, that way, it doesn't disappear in the stream of emails.

No, this patch doesn't apply cleanly on 1.1.0hd.
You need to log in before you can comment on or make changes to this bug.