Closed Bug 923228 Opened 7 years ago Closed 6 years ago

Add UX support for screen/app/window sharing

Categories

(Core :: WebRTC, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 906956

People

(Reporter: mreavy, Unassigned)

References

(Blocks 1 open bug)

Details

Add UX support for screen sharing (as well as app and window sharing) in WebRTC
After Florian landed bug 952166 (Thanks, Florian!), I finished up a port of blassey's trivial front-end (Thanks, Brad, for that and the whole backend :-).  It's a port from a patch to mobile Firefox in another bug to an desktop Firefox XPI.  The intent is to make it possible to experiment with various user experiences for tab-sharing.  

https://github.com/dmose/tabshare/blob/master/TabShare.xpi?raw=true is the XPI; if you save it to disk and install it on a recent Firefox desktop nightly, the "share tab" in the permissions dropdown will offer the active tab as a source.  This is actually a fairly bizarre UX; but it's a first step.  It's slightly easier to see the potential if one uses it while playing around with http://talkilla.mozillalabs.com/

Note that the backend currently always only shares the top box of the document, bug 952625 is now on file to make it possible to share scrolling viewports as well.
https://github.com/dmose/tabshare is the link to the repo itself, for easy clickability.
There's something wrong with the link I posted.  I'll fix shortly.
The XPI and repos above are now fixed, and should work in 29.0a1 and higher (currently Nightly).
The remaining work for this was completed on bug 906956
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906956
You need to log in before you can comment on or make changes to this bug.