Closed Bug 923514 Opened 11 years ago Closed 2 years ago

[UX] Add "paste as plaintext" context menu option within main content panel.

Categories

(Firefox :: Menus, enhancement)

enhancement
Points:
2

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox105 --- fixed

People

(Reporter: myselfasunder, Assigned: Gijs)

References

()

Details

(Keywords: parity-chrome, pm-triage-needed, uiwanted, Whiteboard: [ux])

Attachments

(1 file)

Every time something is copied to the clipboard from webpage content, it comes along with some styling from that page. Similar to Chrome, a "paste as plain text" option in the context-menu from any text-input in the page would be very useful. 

As I, and most people who aren't ignorant of this, would currently have to copy this into a plaintext editor and then copy it back into the clipboard to strip any styling, this feature would remove one annoying element from the experience. In theory, any user who shares content by copying webpage text into a rich-text editor of some kind would be affected.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Version: unspecified → Trunk
Needs UI decision and spec.
Keywords: uiwanted
Dupe of bug 476837?
That's seven years old, hasn't been modified in two, and has no further progress than this one. I'd go with this one just on account of age. Obviously, that one was ignored.

Watchers: Is there a general feeling for one or the other?
Summary: Add "paste as plaintext" context menu option within main content panel. → [UX] Add "paste as plaintext" context menu option within main content panel.
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: [ux] p=0 → [ux] p=2
Points: --- → 2
Flags: qe-verify-
Whiteboard: [ux] p=2 → [ux]
Please add this functionality. More and more applications are becoming browser only such as i.e. Dropbox paper. Copy & pasting into notepad/texteditor and back is really 90's. Chrome has it, too.
Would also like this functionality added. It turns out that Ctrl-Shift-V does the same thing, but it's nice to have it in the context menu next to "Paste" like Chrome does.
Component: General → Menus
Keywords: parity-chrome

I, too, am annoyed by the need to paste into a plain text editor, then select all, copy, and paste again elsewhere.

Please support Ctrl+Shift+V (and Cmd+Shift+V on Mac). Chrome does it, too, and so does Safari.

I totally don't understand why that option disappeared and has not been reintroduced :-(. Please some FF dev, re-introducing this saves the world so much time!

Please add this option (or make it configurable in about:config). Paired together with this bug (https://community.atlassian.com/t5/Confluence-questions/paste-unformatted/qaq-p/895273) in Confluence which remaps the Ctrl+Shift+V hotkey it's a UX nightmare.

If i paste something out of my IDE, i have to paste it into a texteditor without formatting, copy it again and then paste it into confluence. If i had a menu item in Firefox for "Paste unformatted", my workflow would be so much simpler.

See Also: → 1718929

It turns out that Ctrl-Shift-V does the same thing, but it's nice to have it in the context menu next to "Paste" like Chrome does.

Does Ctrl-Shift-V work for anyone on current Firefox? For me, it does nothing (and there is no "paste as plain text" either). This is with FF 102.0b9 on Linux.

Ania, this came up through a more recent dupe. I think we should add this to the quality improvements pile but it'll need some small UX/content/product involvement.

Severity: normal → --
Flags: needinfo?(asafko)

Added a JIRA ticket for this to the Quality foundation epic and linked the task.

Do you think you can add an SP estimation to it off the top of your head - assuming the scope is limited to adding a context menu item?

Flags: needinfo?(asafko)

@:Gijs (he/him)
@Ania

There hasn't been any progress on this bug in 9 years.

Please post all follow ups here:
Bug 1782343 There should be a right click menu option for pasting as plain text

Thanking you.

P.S. I've added all the people on the CC list here to the CC list there so they will receive updates posted there.

Those bugs have been closed as duplicates. Please continue to post comments to this bug.

(In reply to wmattw81 from comment #18)

@:Gijs (he/him)
@Ania

There hasn't been any progress on this bug in 9 years.

Please post all follow ups here:
Bug 1782343 There should be a right click menu option for pasting as plain text

Thanking you.

P.S. I've added all the people on the CC list here to the CC list there so they will receive updates posted there.

(In reply to Ania from comment #17)

Added a JIRA ticket for this to the Quality foundation epic and linked the task.

Do you think you can add an SP estimation to it off the top of your head - assuming the scope is limited to adding a context menu item?

Done. I also have a patch ready from a technical perspective - but we're going to need content design to pick text for this. comment 0 suggests "Paste As Plain Text", but Chrome currently has "Paste and Match Style". Google docs has "Paste without formatting". Can you help confirm with the content design team what we should use? Off-hand the second ("Paste and Match Style") seems clearest about what it does.

Flags: needinfo?(asafko)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

Off-hand the second ("Paste and Match Style") seems clearest about what it does.

I was about to say that that one makes no sense at all to me. Match which style? If anything I would expect that to be the next for pasting with formatting (match the style of where it was copied from).

LibreOffice calls it "Paste unformatted text".

(In reply to Ralf Jung from comment #23)

Off-hand the second ("Paste and Match Style") seems clearest about what it does.

I was about to say that that one makes no sense at all to me. Match which style?

The style used at the insertion point (ie where you opened the context menu).

I'd argue that saying "unformatted" is confusing because it could be read to imply that, if you're in the middle of text that's bold/underlined/whatever, the pasted text would not have any of those styles.

Anyway, I'm not a wordsmith and I'm sure our content design team can come to some reasonable conclusion here.

Yay, that's great to hear, thank you, Gijs! I'll work with the content design and will post the final string here. The language that Chrome uses (Paste and match style) is super confusing to me as a non-native speaker.

Meridel, can we please ask for your help with this?

To summarize the ticket very quickly:

Currently, we support a shortcut (Cmd + Shift + V) to paste the copied text without formatting, but do not support a context menu item like Chrome.

We need to add this action to the context menu and figure out the best possible language.

Here’s the language used in a few other applications:

Google docs, Adobe: Paste without formatting

Various small products: Paste as plain text

Microsoft Word: Paste text only

A few other Microsoft apps: Paste unformatted

Chrome: Paste and match style

A note from a non-native EN speaker:

  • "plain text" feels much harder to translate to French, Ukrainian, Polish, and Russian to me than "without formatting", "unformatted".
  • I checked how "Paste and match style" is translated to Ukrainian and Polish and it's literally "Paste and apply a style". I feel like it's really hard to understand that it means applying a style (unformatted) of the web app where the text is being pasted to.
Flags: needinfo?(asafko) → needinfo?(mwalkington)

Chrome: Paste and match style

There are also reports of Chrome using other language. On my system it uses "Paste as plain text".

Thanks, Ania. Let's use: Paste without formatting

Rationale:

  1. Potentially less troublesome for localization
  2. Most popular term in Google Trends comparison:
    https://visit.doximity.com/llc-4bw-1sp?e=rg29bq&s=sh8semcjip84vgaa52iy10msjqairr9
  3. Consistency with some other major tools, most notably Google Docs which is focused on text manipulation so gets a bit more credence here.
Flags: needinfo?(mwalkington)

Meridel, thank you so much!

Ralf, thank you for the note!

I think we are good to go now.

Attachment #9288091 - Attachment description: Bug 923514 - add plaintext paste item to page context menu, r?bgrins → Bug 923514 - add plaintext paste (paste without formatting) item to page context menu for richtext / contenteditable inputs, r?bgrins
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7a401461c7a8
add plaintext paste (paste without formatting) item to page context menu for richtext / contenteditable inputs, r=bgrins,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Thank you so much for finally adding this.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: