Last Comment Bug 92453 - Remove lowsrc support
: Remove lowsrc support
Status: RESOLVED FIXED
[need extensive lowsrc tests]
: testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: mozilla0.9.6
Assigned To: Stuart Parmenter
: Chris Petersen
: Jet Villegas (:jet)
Mentors:
http://www.filemaker.com
Depends on:
Blocks: 142477
  Show dependency treegraph
 
Reported: 2001-07-26 11:49 PDT by Chris Petersen
Modified: 2003-11-24 10:46 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
simple test case that reproduces (257 bytes, text/html)
2001-07-26 11:52 PDT, Chris Petersen
no flags Details
Fix (8.35 KB, patch)
2001-10-12 14:13 PDT, Stuart Parmenter
no flags Details | Diff | Splinter Review
Real removal of lowsrc (7.69 KB, patch)
2001-10-13 17:47 PDT, Stuart Parmenter
jag-mozilla: review+
attinasi: superreview+
Details | Diff | Splinter Review

Description Chris Petersen 2001-07-26 11:49:34 PDT
Build: 2001072418
Platform: All
Expected Results: LOWSRC image should be replaced by higher resolution image
What I got: LOWSRC image is displayed only

Steps to reproduce: 

1) Go to url. Look at the center image (Free Preview CD- Filemaker 5.5). This
image should be the high resolution version.

2) Now , press the reload button.

3) LOWSRC image replaces the high rez image

4) Multiple reloads doesn't seem to correct the problem. User must place focus
in URL field and press return to reflow the document.
Comment 1 Chris Petersen 2001-07-26 11:50:56 PDT
You might see the problem when upon visiting the site. If not , reloading the
page should cause the problem.
Comment 2 Chris Petersen 2001-07-26 11:52:07 PDT
Created attachment 43688 [details]
simple test case that reproduces
Comment 3 Chris Petersen 2001-07-26 12:03:27 PDT
Reassigning to attinasi@netscape.com
Comment 4 Marc Attinasi 2001-07-26 16:34:09 PDT
LOWSRC is totally broken. We need some tests to really assess the extent of the
problems, but for now I think we are better off disabling it until we get it
working right. Currently, the lowsrc image either fails totally or gets stuck
and prevents the proper image from displaying.

Question: do we even want to implement lowsrc? At the very least we need to
restrict it to Quirks mode since it is not standard.
Comment 5 Christopher Aillon (sabbatical, not receiving bugmail) 2001-07-29 21:21:38 PDT
Off the top of my head, I don't recall MSIE handling lowsrc.  I always thought
it was just NS 4. Can someone verify this?  If this is the case, then I think we
shouldn't support it either.  It is outdated and not standard, and although it
gives a "cool" effect on some sites if the user is on a dialup, high speed
connections are gaining popularity and this is less of a concern.  I always
thought it more of a nuisance while visiting gimp.org on a high speed
connection.  It creates a weird effect that looks like the browser is having
issues or something.  If a webmaster really wants this feature, he can do it
with DOM to gain more control of the invocation and extent of it.  But that's
just my opinion...

Adding 4xp keyword.
Comment 6 Christopher Hoess (gone) 2001-10-10 14:27:26 PDT
Bleah. "lowsrc" isn't in HTML4, deprecated or otherwise; it's a disgusting hack
outside the proper realm of HTML that should be laid to rest in the same grave
as <layer> (all the more so because it has no impact on the final rendering of
the page). Changing summary.
Comment 7 Stuart Parmenter 2001-10-10 17:24:43 PDT
I'd vote for removing support for it all together.  Currently do we the load for
lowsrc properly, but we never display it.. so we waste time downloading the
image if one is present.
Comment 8 Stuart Parmenter 2001-10-12 14:13:04 PDT
Created attachment 53322 [details] [diff] [review]
Fix
Comment 9 Stuart Parmenter 2001-10-12 14:14:08 PDT
reassigning to myself.

need r= and sr=
Comment 10 Stuart Parmenter 2001-10-13 17:46:41 PDT
Comment on attachment 53322 [details] [diff] [review]
Fix

this patch was missing the removal of a html attribute
Comment 11 Stuart Parmenter 2001-10-13 17:47:09 PDT
Created attachment 53439 [details] [diff] [review]
Real removal of lowsrc
Comment 12 jag (Peter Annema) 2001-10-13 17:58:55 PDT
Comment on attachment 53439 [details] [diff] [review]
Real removal of lowsrc

r=jag

(including the other bug fix that's in there).
Comment 13 Marc Attinasi 2001-10-13 18:14:02 PDT
Comment on attachment 53439 [details] [diff] [review]
Real removal of lowsrc

sr=attinasi - Thanks Pavlov
Comment 14 Stuart Parmenter 2001-10-13 18:28:04 PDT
fixed.  no more lowsrc.  we may want to note this somewhere so people know.
Comment 15 Marc Attinasi 2001-10-15 13:34:12 PDT
layout newsgroup might be good. 

BTW: I checked Composer and it has no lowsrc stuff int eh image attributes lists
- good thing! :)
Comment 16 Dwayne 2001-10-17 21:35:45 PDT
Agggh, ya bastards.  I spent so much time getting this fixed (bug 27388) just to
get scrapped.  I understand why we don't need it anymore, but damn...

BTW, these window tabs are sweet.  They make bug tracking a lot easier!  :) 
(Hmm, what bug was that?  Oh yeah, it says it at the top)
Comment 17 neil@parkwaycc.co.uk 2001-10-25 04:44:57 PDT
According to a comment in 23066 there's a DOM level 1 property lowSrc - has this
been removed as well?
Comment 18 Stuart Parmenter 2001-10-25 13:05:20 PDT
lowSrc in the dom1 spec was, as i understand it, an error.  it is going to be
removed from future revisions of the spec.
Comment 19 Brian Wilson 2002-03-15 14:43:43 PST
I was just doing some HTML support testing and noticed that you had dropped 
LOWSRC. It looks like the train has long-since left on this issue, but someone 
raised the hypothetical Q of whether IE supports this attribute so I thought I 
would address that.

It does. It has since IE4. (Opera does not, BTW.) 

Granted, this is a small feature that IE implemented as a "me too" to netscape, 
but now IE is the "me first" case. I have no idea if that will affect your 
decision here.
Comment 20 Stuart Parmenter 2002-03-15 17:04:23 PST
this bug is fixed.  if you want to file a new bug, go ahead, but it isn't going
to get fixed.
Comment 21 Shawn Wright 2002-10-18 10:13:46 PDT
Opera 6.05 *does* support lowsrc, for the record. It's hard to explain to users
that something that worked in Netscape 4.79, does work in both IE and Opera, and
worked in earlier Mozilla releases, now has been removed from Mozilla and Netscape.
Comment 22 Michael T. Babcock 2002-11-18 15:44:16 PST
I'm actually upset that lowsrc doesn't exist anymore, but I guess I'll just
browse slow sites with IE instead, right?
Comment 23 Serge Gautherie (:sgautherie) 2003-11-24 10:46:47 PST
For the record:

Bug 158610 comment 6:
{
Created an attachment (id=124847)
Implement lowsrc attribute

This patch implements the setting and querying of the lowsrc attribute to allow
these sites to work.

It does NOT make lowsrc work, and we have no plans to do that.
}

LowSrc support:
First, this bug patch removed it completely;
Then, bug 158610 patch restored the get/set part (only).

Note You need to log in before you can comment on or make changes to this bug.