In <img008.html> JavaScript Testcase: 'Image.lowsrc' should return '../res/lowstar.gif' instead of 'undefined'.

VERIFIED FIXED

Status

()

Core
ImageLib
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: pietro canevarolo, Assigned: Prashant Desale)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
img008.html
Description Pass Bug Number Actual Result Expected Result
Read Image.lowsrc ../res/lowstar.gif failed Bug report required undefined
../res/lowstar.gif

Comment 1

16 years ago
Pietro, can you please explain, where to find this gif image?
Or send it here as an attachment? (maybe the html page, where it should be
loaded, too)

Comment 2

16 years ago
Ok, the reporter explained to me, he ran the "Debug -> Verification ->
JavaScript" menu, clicked on "image" and then on "img008.html" and there it said
that this verification failed (actual result: "undefined", expected result: 
"../res/lowstar.gif").

Yes, I can reproduce it with me with 2002041711 on Win2k. (=> somebody may
change OS to "all")

You can easily test this yourself with:
http://mozilla.org/quality/ngdriver/suites/javascript/img008.html

Comment 3

16 years ago
I can reproduce it with build 2002042408 on linux.
This test fails because we don't support lowsrc images.(pavloc removed the
support a few months ago)

The testcase is out of date but who owns this ?
desale owns the testcases, iirc.
Assignee: rogerl → desale
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Hardware: PC → All
Summary: Read Image.lowsrc ../res/lowstar.gif failed → Read Image.lowsrc ../res/lowstar.gif failed (testcase needs to be removed)

Updated

16 years ago
Component: JavaScript Engine → ImageLib

Comment 6

16 years ago
Setting QA accordingly -
QA Contact: pschwartau → desale

Comment 7

16 years ago
>> This test fails because we don't support lowsrc images.(pavloc removed
>> the support a few months ago)

do you know the bug number where lowsrc was removed?
A quick search on "remove lowsrc" in the summary shows bug 92453

Comment 9

16 years ago
*** Bug 144062 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 196849 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 203034 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 142649
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

Bug still there.


In the meantime, who can do the following to be more precise ?

In <http://mozilla.org/quality/ngdriver/suites/javascript/img008.html> source,
replace "Bug report required" by "Bug# 142477".
Depends on: 92453
Summary: Read Image.lowsrc ../res/lowstar.gif failed (testcase needs to be removed) → In <img008.html> JavaScript Testcase: 'Image.lowsrc' should return '../res/lowstar.gif' instead of 'undefined'. (Actually, this testcase needs to be removed)
The bug is that the test needs to be removed completely.  Updating it seems silly.
Re comment 13:

Well, forgive me: I said "in the meantime".
I only thought that if there would be more delay for the bug fix, it could avoid
getting some more duplicates :-|

If there is no more "meantime", I kind of agree with you.
My point is that anyone who can update the test can aslo remove it just as easily...

Comment 16

15 years ago
lowSrc is still implemented in the DOM (for compat with DOM1 HTML), even though
it has no effect in imglib.
The testcase passes for me using Firebird0.7 on winxp. Marking WORKSFORME.
Please reopen if there's something I missed here, thanks!
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 17

15 years ago
Moz 1.6a on Win2k also passes the test.
I guess this bug can be verified, however I don't do so in case someone wants to
(mis-/re-)use it to remove this testcase (it is still there, now under
Debug-Verification-DOM). But those are not built into the browser, but on the
moz.org website anyway, so...
For the record:

Bug 158610 comment 6:
{
Created an attachment (id=124847)
Implement lowsrc attribute

This patch implements the setting and querying of the lowsrc attribute to allow
these sites to work.

It does NOT make lowsrc work, and we have no plans to do that.
}

LowSrc support:
First, this bug patch removed it completely;
Then, bug 158610 patch restored the get/set part (only).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: In <img008.html> JavaScript Testcase: 'Image.lowsrc' should return '../res/lowstar.gif' instead of 'undefined'. (Actually, this testcase needs to be removed) → In <img008.html> JavaScript Testcase: 'Image.lowsrc' should return '../res/lowstar.gif' instead of 'undefined'.
Re comment 18:

Read "First, bug _92453_ patch removed it completely;".


Re comment 13, comment 16:

Changing WorksForMe to Fixed, (see bug 158610).
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 20

15 years ago
Thanks Serge, VERIFIED fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.