Build error since Bug 924615: Venkman and Chatzilla can't build because: "shell metacharacter '{' in command line"

RESOLVED FIXED in mozilla27

Status

()

Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Trunk
mozilla27
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
Since Bug 924615 I have been getting this build error.

make.py[8]: Entering directory 'c:\t1\hg\objdir-sm\mozilla\extensions\venkman\locales'
c:\t1\hg\comm-central\mozilla\config\rules.mk:1752:0$ if test -d ../../../dist/bin ; then touch ../.
./../dist/bin/.purgecaches ; fi
make.py[8]: Leaving directory 'c:\t1\hg\objdir-sm\mozilla\extensions\venkman\locales'
make.py[8]: Entering directory 'c:\t1\hg\objdir-sm\mozilla\extensions\venkman\locales'
Traceback (most recent call last):
  File "c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py", line 30, in <module>
    pymake.process.ParallelContext.spin()
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\process.py", line 523, in spin
    c.run()
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\process.py", line 453, in run
    cb(*args, **kwargs)
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\data.py", line 869, in _depfinishedparallel
    self.resolvecb(error=self.error, didanything=self.didanything)
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\data.py", line 763, in resolvecb
    self.runnext()
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\data.py", line 783, in runnext
    self.rlist.pop(0).runcommands(self.indent, self.commandscb)
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\data.py", line 953, in runcommands
    self._commandcb(False)
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\data.py", line 890, in _commandcb
    self.commands.pop(0)(self._commandcb)
  File "c:\t1\hg\comm-central\mozilla\build\pymake\pymake\data.py", line 1419, in __call__
    raise DataError("native command '%s': shell metacharacter '%s' in command line" % (self.cline, badchar), self.loc)
pymake.data.DataError: c:\t1\hg\comm-central\mozilla\config\rules.mk:1454:0:native command 'mozbuild
.action.jar_maker main   -j ../../../dist/xpi-stage/venkman/chrome -t c:/t1/hg/comm-central/mozilla
-f flat  -e --relativesrcdir=extensions/venkman/locales -c c:/t1/hg/comm-central/mozilla/extensions/
venkman/locales/en-US -DNDEBUG -DTRIMMED -DXPI_NAME=venkman -DNO_NSPR_10_SUPPORT -DAB_CD=en-US -DINS
TALL_EXTENSION_ID={f13b157f-b174-47e7-a34d-4815ddfdfeb8} -DVENKMAN_VERSION=0.9.89 -DVENKMAN_BASE_VER
SION=0.9.89 -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DHAVE_SEH_EXCEPTIONS=1 -DMOZ_M
SVC_STL_WRAP__RAISE=1 -DHAVE_WINSDKVER_H=1 -DWINVER=0x502 -D_WIN32_WINNT=0x502 -D_WIN32_IE=0x0603 -D
MOZ_WINSDK_TARGETVER=0x06010000 -DMOZ_NTDDI_WIN7=0x06010000 -DMOZ_WINSDK_MAXVER=0x06020000 -DHAVE_IO
_H=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DX_DISPLAY_MISSING=1 -DJSGC_INCREMENTAL=1 -DMOZ_ENABLE_PROFILE
R_SPS=1 -DMOZILLA_VERSION=\"27.0a1\" -DMOZILLA_VERSION_U=27.0a1 -DMOZILLA_UAVERSION=\"27.0\" -DHAVE_
SNPRINTF=1 -D_WINDOWS=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LE
AN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DMOZ_DEBUG_SYMBOLS=1 -DNS_ATTR_MALLOC= -DNS_WARN_U
NUSED_RESULT= -DMALLOC_H=\<malloc.h\> -DHAVE_FORCEINLINE=1 -DHAVE_LOCALECONV=1 -DNIGHTLY_BUILD=1 -DN
S_ENABLE_TSF=1 -DMOZ_UPDATE_CHANNEL=default -DEARLY_BETA_OR_EARLIER=1 -DMOZ_SUITE=1 -DMOZ_MORK=1 -DM
OZ_MAPI_SUPPORT=1 -DMOZ_BUILD_APP=../suite -DMOZ_PDF_PRINTING=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_
DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -
DMOZ_WEBRTC=1 -DMOZ_WEBRTC_ASSERT_ALWAYS=1 -DMOZ_WEBRTC_SIGNALING=1 -DMOZ_PEERCONNECTION=1 -DMOZ_SCT
P=1 -DMOZ_SRTP=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_WEBSPEECH=1 -DMOZ_RAW=1 -DMOZ_OGG=1 -DMOZ_WEBM=1
-DMOZ_DIRECTSHOW=1 -DMOZ_WMF=1 -DMOZ_MEDIA_NAVIGATOR=1 -DMOZ_VP8=1 -DMOZ_VP8_ERROR_CONCEALMENT=1 -DM
OZ_VP8_ENCODER=1 -DVPX_X86_ASM=1 -DMOZ_WAVE=1 -DMOZ_SPEEX_RESAMPLER=1 -DMOZ_SOUNDTOUCH=1 -DMOZ_CUBEB
=1 -DMOZ_VORBIS=1 -DMOZ_OPUS=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ_WEBGL=1 -DMOZ_GAMEPAD=1 -DMOZ_
CRASHREPORTER=1 -DMOZ_CRASHREPORTER_INJECTOR=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURB
O_X86_ASM=1 -DMOZ_UPDATER=1 -DMOZ_ENABLE_GTEST=1 -DGTEST_HAS_RTTI=0 -D_VARIADIC_MAX=10 -DMOZ_FEEDS=1
 -DMOZ_HELP_VIEWER=1 -DMOZ_URL_CLASSIFIER=1 -DGL_PROVIDER_=1 -DMOZ_LOGGING=1 -DMOZ_MEMORY=1 -DMOZ_ME
MORY_WINDOWS=1 -DJSGC_INCREMENTAL=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMOZ_OMNIJAR=1 -DMOZ_USER_
DIR=\"Mozilla\" -DMOZ_TREE_PIXMAN=1 -DHAVE_STDINT_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_ENA
BLE_SKIA=1 -DUSE_SKIA=1 -DSKIA_DLL=1 -DGR_DLL=1 -DUSE_SKIA_GPU=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1
-DBUILD_CTYPES=1 -DMOZ_PLACES=1 -DMOZ_SOCIAL=1 -DMOZ_SERVICES_COMMON=1 -DMOZ_SERVICES_CRYPTO=1 -DMOZ
_SERVICES_SYNC=1 -DMOZ_APP_COMPONENT_MODULES=MODULE\(nsMailModule\)\ MODULE\(nsImportServiceModule\)
\ MODULE\(nsLDAPProtocolModule\)\ MODULE\(nsMorkModule\) -DMOZ_MACBUNDLE_ID=org.mozilla.seamonkey -D
MOZ_B2G_VERSION=\"1.0.0\" -DMOZ_B2G_OS_NAME=\"\" -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"2.24a
1\" -DFIREFOX_VERSION=27.0a1 -DMOZ_TELEMETRY_DISPLAY_REV=2 -DMOZ_DATA_REPORTING=1 -DMOZ_DLL_SUFFIX=\
".dll\" c:/t1/hg/comm-central/mozilla/extensions/venkman/locales/jar.mn': shell metacharacter '{' in command line
c:\t1\hg\objdir-sm\mozilla\extensions\venkman\Makefile:48:0: command 'set -e;                     \
for locale in en-US; do   \
  c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C locales AB_CD=$locale; \
done' failed, return code 1
evaluation from c:\t1\hg\comm-central\mozilla\config\recurse.mk:186:53:7:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C venkman libs
' failed, return code 2
evaluation from c:\t1\hg\comm-central\mozilla\config\recurse.mk:186:53:12:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py venkman_libs inspector_libs irc_libs' failed, return code 2
c:\t1\hg\comm-central\mozilla\config\recurse.mk:159:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C extensions libs' failed, return code 2
c:\t1\hg\comm-central\mozilla\config\rules.mk:695:0: command 'c:/DEV/mozilla-build/python/python.exe 
 c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py libs' failed, return code 2
c:\t1\hg\objdir-sm\Makefile:52:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C mozilla default' failed, return code 2
c:\t1\hg\comm-central\client.mk:391:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -j4 -C c:/t1/hg/comm-central/../objdir-sm' failed, return code 2
(Assignee)

Updated

4 years ago
Duplicate of this bug: 926278

Updated

4 years ago
Duplicate of this bug: 926278
Looks like it does not like this part:
-DINSTALL_EXTENSION_ID={f13b157f-b174-47e7-a34d-4815ddfdfeb8}
(Assignee)

Comment 4

4 years ago
(In reply to Frank Wein [:mcsmurf] from comment #3)
> Looks like it does not like this part:
> -DINSTALL_EXTENSION_ID={f13b157f-b174-47e7-a34d-4815ddfdfeb8}

Or it might not like this bit:

VENKMAN_BASE_VERSION=$(shell echo "$(VENKMAN_VERSION)" | sed "s|\([0-9]\{1,\}\.[0-9]\{1,\}\.[0-9]\{1,\}\).*|\1|"

q.v.
> c:/t1/hg/comm-central/mozilla/extensions/venkman/locales/jar.mn':
> shell metacharacter '{' in command line

Regardless, this needs to be fixed.
(In reply to Frank Wein [:mcsmurf] from comment #3)
> Looks like it does not like this part:
> -DINSTALL_EXTENSION_ID={f13b157f-b174-47e7-a34d-4815ddfdfeb8}

Indeed. Just add quotes around the extension id.
(Assignee)

Updated

4 years ago
Summary: Build error since Bug 924615 .../venkman/locales/jar.mn': shell metacharacter '{' in command line → Build error since Bug 924615: Venkman and Chatzilla can't build because: "shell metacharacter '{' in command line"
(Assignee)

Comment 6

4 years ago
Created attachment 817150 [details] [diff] [review]
Patch v1.0 Chatzilla Makefile.in fix rs=Gijs for makefile changes

Gijs has given me rs+ over IRC for makefile/build config changes to both Chatzilla and Venkman.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #817150 - Flags: review+
(Assignee)

Comment 7

4 years ago
Created attachment 817155 [details] [diff] [review]
Patch v1.0 Venkman Makefile.in fix rs=Gijs for makefile changes

rs=Gijs over IRC
Attachment #817155 - Flags: review+
(Assignee)

Comment 8

4 years ago
Pushed venkman tip:
https://hg.mozilla.org/venkman/rev/e52e9642dee1
Pushed Chatzilla tip:
https://hg.mozilla.org/chatzilla/rev/ceea033a25da
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Comment on attachment 817150 [details] [diff] [review]
Patch v1.0 Chatzilla Makefile.in fix rs=Gijs for makefile changes

That looks so wrong.
https://hg.mozilla.org/venkman/file/e52e9642dee1/locales/Makefile.in#l47
https://hg.mozilla.org/chatzilla/file/ceea033a25da/locales/Makefile.in#l47

This is where the change should have been made.
(Assignee)

Comment 11

4 years ago
I guess I misunderstood your hint.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

4 years ago
Chatzilla:
backout ceea033a25da https://hg.mozilla.org/chatzilla/rev/0857d9f1cdea
fixed fix: https://hg.mozilla.org/chatzilla/rev/2f987156f68a
Venkman:
backout e52e9642dee1 https://hg.mozilla.org/venkman/rev/a1627f45e576
fixed fix: https://hg.mozilla.org/venkman/rev/97eeca2f0a89
(In reply to Philip Chee from comment #12)
> Chatzilla:
> backout ceea033a25da https://hg.mozilla.org/chatzilla/rev/0857d9f1cdea
> fixed fix: https://hg.mozilla.org/chatzilla/rev/2f987156f68a
> Venkman:
> backout e52e9642dee1 https://hg.mozilla.org/venkman/rev/a1627f45e576
> fixed fix: https://hg.mozilla.org/venkman/rev/97eeca2f0a89

Shouldn't this go back to FIXED?
Flags: needinfo?(philip.chee)
(In reply to Tony Mechelynck [:tonymec] from comment #13)
> (In reply to Philip Chee from comment #12)
> > Chatzilla:
> > backout ceea033a25da https://hg.mozilla.org/chatzilla/rev/0857d9f1cdea
> > fixed fix: https://hg.mozilla.org/chatzilla/rev/2f987156f68a
> > Venkman:
> > backout e52e9642dee1 https://hg.mozilla.org/venkman/rev/a1627f45e576
> > fixed fix: https://hg.mozilla.org/venkman/rev/97eeca2f0a89
> 
> Shouldn't this go back to FIXED?

Nope, because it's not doing anything useful... the quotes are inside the variable reference instead of around them.
(Assignee)

Comment 15

4 years ago
> Nope, because it's not doing anything useful...
It does allow venkman and chatzilla to build properly though so it's doing /something/.

> the quotes are inside the variable reference instead of around them.
So something like?:
DEFINES += -DINSTALL_EXTENSION_ID=$"(INSTALL_EXTENSION_ID)"
Flags: needinfo?(philip.chee) → needinfo?(mh+mozilla)
(In reply to Philip Chee from comment #15)
> > Nope, because it's not doing anything useful...
> It does allow venkman and chatzilla to build properly though so it's doing
> /something/.
> 
> > the quotes are inside the variable reference instead of around them.
> So something like?:
> DEFINES += -DINSTALL_EXTENSION_ID=$"(INSTALL_EXTENSION_ID)"

="$(I...D)"
what Callek says.
Flags: needinfo?(mh+mozilla)

Updated

4 years ago
Flags: needinfo?(philip.chee)
(Assignee)

Comment 18

4 years ago
The HD on my Toshiba died. And took all my patches with it. Can someone else drive this bug/patch? No ETA on when I can get a build environment up and running again.
Flags: needinfo?(philip.chee)
(In reply to Philip Chee from comment #18)
> The HD on my Toshiba died. And took all my patches with it. Can someone else
> drive this bug/patch? No ETA on when I can get a build environment up and
> running again.

Philip: Both of these patches have r+. Does anything remain to be done before they can get checkin-needed?

Anyone: I have a clone and can write and attach patches, but I'm on Linux where builders are b0rken since end September. I suppose it would be better if someone on Windows could take this bug.
Flags: needinfo?(philip.chee)
To whoever may check in these patches (if and when): The Chatzilla bug is for the http://hg.mozilla.org/chatzilla/ repository, the Venkman patch is for the http://hg.mozilla.org/venkman/ repository. Not comm-central and not mozilla-central.
s/Chatzilla bug/chatzilla patch/
(Assignee)

Comment 22

4 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #19)
> (In reply to Philip Chee from comment #18)
> > The HD on my Toshiba died. And took all my patches with it. Can someone else
> > drive this bug/patch? No ETA on when I can get a build environment up and
> > running again.
> 
> Philip: Both of these patches have r+. Does anything remain to be done
> before they can get checkin-needed?

They are all wrong (I was using rs=rubber stamp". The right way is in Comment 16
e.g DEFINES += -DINSTALL_EXTENSION_ID="$(INSTALL_EXTENSION_ID)"
Flags: needinfo?(philip.chee)
Fixed the files: https://hg.mozilla.org/venkman/rev/06938db4dffc
https://hg.mozilla.org/chatzilla/rev/d7c3840b7f75
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Created attachment 824822 [details] [diff] [review]
Chatzilla branch patch

comm-aurora/beta use release branches for Chatzilla/Venkman (as those are extensions), so they need a separate fix.
Created attachment 824825 [details] [diff] [review]
Venkman branch patch
Attachment #824825 - Flags: review+

Updated

4 years ago
Attachment #824822 - Flags: review+

Updated

4 years ago
Attachment #824825 - Attachment is patch: true

Updated

4 years ago
Depends on: 937558
(Assignee)

Comment 26

4 years ago
Comment on attachment 824822 [details] [diff] [review]
Chatzilla branch patch

Bug 937558 is fixed
a=me for comm-aurora and comm-beta (if needed)
(Assignee)

Comment 27

4 years ago
Comment on attachment 824825 [details] [diff] [review]
Venkman branch patch

Bug 937558 is fixed
a=me for comm-aurora and comm-beta (if needed)
You need to log in before you can comment on or make changes to this bug.