Expand automated coverage around editing of gallery photos

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: AlinT)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Editing of gallery photos was a big hot spot for regressions in the 1.2 timeframe. We should explore resulting regressions that happened to figure out what automated coverage we should expand on. Should include running this test across multiple photos? Should we explore using more edit options? These are such questions we need to answer here. Then, implement the solution that will cover us against regressions we saw in the 1.2 timeframe.

Comment 1

5 years ago
This is very similar to bug 927126.

Let's seed the gmail account in the testvars file with one or two contacts.


Test case as follows:
1. Start b2g
2. Tap 'Settings'
3. Tap 'Import Contacts'
4. Tap 'Gmail'
5. Sign in to Gmail
6. After import process, verify list of contacts is shown.
7. Select the contact and tap 'Import'
8. Verify that the imported contact(s) are listed on the Contacts app main screen.

Comment 2

5 years ago
Ignore the comment #1, wrong bug.

Comment 3

5 years ago
We have a fair bit of good coverage here and have caught lots of bugs here before. 
I'll try and come up with some more test cases in this area but nothing immediately comes to mind!
(Reporter)

Comment 4

5 years ago
FWIW - gallery regression bugs motivating the filing of this bug are:

- bug 915876 (caught by automation)
- bug 917444 (not caught by automation)
- bug 899257 (not caught by automation)
- bug 908449 (not caught by automation)

For issues not caught by automation, trends I see are:

1. When entering crop mode in a gallery automated test, we need to verify that the photo is present and not blank
2. We need to verify that the color of the photo isn't blown away on an edit
3. Editing effects should affect the whole image, not part of it

[2] and [3] would require an ability to be able to analyze image results. [1] just requires verifying the present of the image on the crop page.
(Reporter)

Comment 5

5 years ago
Talking stephend, sounds like doing [2] & [3] won't be possible in gaia ui tests, but [1] might be.
(In reply to Jason Smith [:jsmith] from comment #5)
> Talking stephend, sounds like doing [2] & [3] won't be possible in gaia ui
> tests, but [1] might be.

We should be able to do all of these in automation. We can use Marionette to return a screenshot of the element and analyse it or compare it to a reference image. We don't have any such tests yet, and no good way to represent such failures, but that can be worked out if this is an area we need coverage in.

Comment 7

5 years ago
It sounds a bit edge-case and probably high maintenance, neither qualities that go well with automation.
(Reporter)

Comment 8

5 years ago
(In reply to Zac C (:zac) from comment #7)
> It sounds a bit edge-case and probably high maintenance, neither qualities
> that go well with automation.

I agree on the maintenance concern on the screenshot analysis approach. However, I don't think that causes [1] to be out of the picture - [1] indicates that we should be checking for presence of the picture being cropped, not analyze the picture itself.

Comment 9

5 years ago
Yes that might be possible. Let's treat this as an investigation task.

The image element's size may have a before/after states that represent whether it has been resized properly or not.

If we can do that we'll break out test_gallery_edit_photo.py into two tests:
1. test_gallery_crop_photo.py - Crops and asserts the size has changed
2. test_gallery_edit_photo.py - Goes through the options as now and looks for a graphics crash
(Assignee)

Comment 10

5 years ago
:jsmith :zac
I've investigated this issue today and it seems everything in the edit image frame is done in canvas( which we cannot query) so the only thing we could check would be the size of image before and after the croping.
(Assignee)

Updated

5 years ago
Assignee: nobody → alin.trif

Comment 11

5 years ago
To clarify an IRC conversation, by size I was talking about the image's x/y size rather than its kb size.
(Assignee)

Comment 12

5 years ago
Created attachment 824003 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13182#attch-to-bugzilla

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #824003 - Flags: review?(zcampbell)
Attachment #824003 - Flags: review?(moz.teodosia)
Attachment #824003 - Flags: review?(florin.strugariu)
Attachment #824003 - Flags: review?(andrei.hutusoru)

Comment 13

5 years ago
https://github.com/mozilla-b2g/gaia/commit/903fb4005ce7ac3047dc03363505082f739d4fe4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #824003 - Flags: review?(florin.strugariu) → review+
Created attachment 826447 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13329

Pointer to Github pull-request
Comment on attachment 826447 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13329

Uplifting to v1.2
Attachment #826447 - Flags: review?(zcampbell)
Attachment #826447 - Flags: review?(trifandreialin)
Attachment #826447 - Flags: review?(moz.teodosia)
Attachment #826447 - Flags: review?(florin.strugariu)
Attachment #826447 - Flags: review?(andrei.hutusoru)
Blocks: 934130
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

5 years ago
Comment on attachment 826447 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13329

LGTM
Attachment #826447 - Flags: review?(andrei.hutusoru) → review+

Comment 17

5 years ago
https://github.com/mozilla-b2g/gaia/commit/e977d9999e00388a5f059005871206e095253ac0
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Attachment #824003 - Flags: review?(zcampbell)
Attachment #824003 - Flags: review?(moz.teodosia)
Attachment #824003 - Flags: review?(andrei.hutusoru)

Updated

5 years ago
Attachment #826447 - Flags: review?(zcampbell)
Attachment #826447 - Flags: review?(trifandreialin)
Attachment #826447 - Flags: review?(moz.teodosia)
Attachment #826447 - Flags: review?(florin.strugariu)
Duplicate of this bug: 933250
You need to log in before you can comment on or make changes to this bug.