Closed Bug 927418 Opened 11 years ago Closed 3 years ago

files downloaded in private browsing mode get lost

Categories

(Firefox for Android Graveyard :: Download Manager, defect, P5)

ARM
Android

Tracking

(fennec+)

RESOLVED INCOMPLETE
Tracking Status
fennec + ---

People

(Reporter: c.ascheberg, Unassigned)

References

Details

There is no (easy / convenient) way to access files that were downloaded in private browsing mode after closing Firefox.

STR:
1. download file in Firefox private browsing mode
 -> download will show up in Firefox -> Extras -> Downloads
3. go to Android device settings -> Storage -> Downloads
 -> disk space used by the "Downloads" folder includes size of downloaded file
4. click "Downloads"
 -> downloaded file does not show up in Android download app (*)
5. quit Firefox, restart Firefox
 -> download will not show up in Firefox -> Extras -> Downloads anymore

Result:
There is no reference to the downloaded file, neither in Firefox nor in Android. It is only accessible with a third-party filebrowser or by PC via USB.

Expected:
download should not be deleted from Firefox downloads list / download should be deleted from storage when quitting Firefox
(*) or download should be displayed in the Android downloads app.
I was really confused when I saw the disk space used by the downloads folder but could not see any files in there. This seemed to be a bug to me, though if I understand this support article correctly, this is intended: https://support.mozilla.org/en-US/questions/950273
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Perhaps unrelated actually.

Is this reproducible on Nightly?

fedepaol, do you see this?
Status: RESOLVED → REOPENED
Flags: needinfo?(fedepaol)
Resolution: DUPLICATE → ---
Nightly (10/16)

↳ Downloaded a file in a private tab, I went to tools/downloads and saw it listed (marked as private by it's visual indicator) (See http://i.imgur.com/YaTNo16.png)

↳ Went to Settings/Storage/Downloads, yes we do not register downloads in the system download registry for them to be shown in the Download application in Android (backed out in bug 752014). I'm not sure which bug is open status talking about that adding this back.

↳ Went to about:download after a restart and didn't see my private download from my previous session. I'm not sure what we should or want to do in this case since it's wiped on end of private session by closing Firefox.

Let this bug talk about that last bullet point. Registering downloads to the ICS+ Download Manager should happen in another bug.
I couldn't find an existing discussion about my second bullet so I filed a new one: bug 927464.
First of all, I think this is not related to bug 921776

- The downloaded file is not showing app into the android download app because it only shows file downloaded through the DownloadManager service (http://developer.android.com/reference/android/app/DownloadManager.html), as described in the link reported by Christian. 
The reason is that using that would require more permissions which is something that we do not want (from my understanding of that article).

If any other app download a file on its own (as we do), the file is not expected to be found there. The same thing happens whenever you download a podcast file or any other kind of file with another app. 
I think we are just writing the files to Downloads folder because it's their natural place.

- Once fennec is closed, any private session is wiped out, so I think it is something we really want.

Anyway, once bug 921776 is (hopefully) fixed, the "download completed" notification will be visible again.
Flags: needinfo?(fedepaol)
(In reply to Aaron Train [:aaronmt] from comment #4)
> I couldn't find an existing discussion about my second bullet so I filed a
> new one: bug 927464.

Use system download application (my bug duped to bug 816318)
So in short, 4 possible solutions (so far):
1. use Android download manager entirely
2. only add finished download file to Android download manager
3. treat PB downloads same as regular downloads in Firefox download manager
4. remove PB downloaded files from storage when quitting Firefox

Solution 3 is essentially not different from 1 & 2 (apart from download app integration).
Only solution 4 deletes the files from the device. I do not know which behaviour users expect (desktop Firefox does not delete those files).

Chrome uses solution 1 and does not have its own built-in download manager.
tracking-fennec: --- → ?
ibarlow, any input here?
Flags: needinfo?(ibarlow)
Ian, my two cents: I think number 3 in comment 7 makes the most sense, thinking about it. We tell users that files won't be wiped when entering private mode, and you still may want to keep something that you found while private browsing (a pic of that fictitious engagement ring) that you wouldn't necessarily want wiped when you leave the session.
I agree with Karen here. 

While we continue using the Firefox Download manager we should send *all* files there, regardless of whether they were saved in Private or Normal browsing.  Down the road, when we switch to allowing files to go directly to the Android Download manager we should apply the same behaviour -- that all downloaded files get saved no matter what.

After all, who are we to get between someone and their carefully researched engagement ring pictures?
Flags: needinfo?(ibarlow)
FWIW, this has come up before -- some discussion here: https://bugzilla.mozilla.org/show_bug.cgi?id=823285#c13 and onward.
tracking-fennec: ? → +
Component: General → Download Manager
Depends on: 1070488
filter on [mass-p5]
Priority: -- → P5
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: REOPENED → RESOLVED
Closed: 11 years ago3 years ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.