Bug 927598 (clock-ux-changes)

Meta - Clock UX Changes for 1.2 / 1.3

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rmacdonald, Assigned: oconnore)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Based on a conversation with Bocoup, product and engineering on Oct 15, here are the list of UX changes for 1.2 / 1.3...

1.2 Requests (filed separately)

- Stop watch needs to show 1/100 of a second intervals (See - Bug 927581 - [clock] Stop watch - Add 1/100th of a second time intervals)
- Timer and Stopwatch fonts should be fixed width to prevent the text from jumping around as the numbers change. (See Bug 927583 - [clock] Stop watch and Timer - Use fixed width font to avoid text shifting)
- Timer should not have a seconds option (See Bug 927588 - [clock] Timer - Remove seconds from timer)
- New clock face implementation (See Bug 910854)

1.2 stretch issues or 1.3 if out of time...

- Stopwatch lap behaviour isn't quite as expected. When the user taps "Lap" the first time, there should be two items listed in the lap area. Lap 1 should have the first lap time and, above it, Lap 2 should display with a count of the current lap. So essentially, the time for the current lap always runs at the top of the lap list.
- Please update the tabs to #348C9E at 60% Opacity. Scroll bar should only display in the non-tab area.
- Value selector buttons, text label colours, font sizes vary from the visual spec and need to be aligned.
- Transition from left to right tabs is jagged (the transition is smooth with going from right to left) (to be confirmed)

Alarm tab
- In the digital mode, the size of the font does not seem to match the one in the spec. This is because of the new font Fira Sans. Please update it to 48pt with tracking of 21
- The "Edit Alarm" dialog has a white background. Please change this to black, as per the visual spec. Value selector buttons should also have a dark grey instead of white background. The text colours for both the label and the value selector buttons should also match the spec below. See bug 919530.

Timer tab
- Please add hour and minute labels above the values in the timer. These are included in the UI spec (https://mozilla.box.com/s/uzjssspdurvqw1cuf6kr) and latest visual spec (https://mozilla.box.com/s/rcqxczfz8t6wul8dtdvw)
- The value selector buttons for sound should have a grey background with white text, as per the edit alarm dialog.
(Reporter)

Comment 1

5 years ago
Flagging Eric for comment on transitions within clock and for general feedback. :)
blocking-b2g: --- → koi?
Flags: needinfo?(epang)
We don't block on meta bugs - nominate the relevant bugs that UX feels are blockers for release that are actionable.
blocking-b2g: koi? → ---
I added the four 1.2 blockers as dependencies. We aren't planning to address any of the others in 1.2 -- we'll eventually need separate bugs for each of the other issues mentioned in the description.
Depends on: 927581, 927583, 927588, 910854
(In reply to Rob MacDonald [:robmac] from comment #1)
> Flagging Eric for comment on transitions within clock and for general
> feedback. :)

Hey Rob, I loaded master and the transition looks good now.  No more jaggedness!
Flags: needinfo?(epang)
Depends on: 937748
Depends on: 926587
Depends on: 937716
Depends on: 919530
I've updated this bug's formal dependencies to capture all of the changes described in comment 0. Now it should be safe to close this meta-bug once all its dependencies are satisfied (three to go!)
Blocks: 914551
Alias: clock-ux-changes
Summary: Meta - UX Changes for 1.2 / 1.3 → Meta - Clock UX Changes for 1.2 / 1.3
No longer depends on: 937748
Unhooked the final dependency as it may depend on 1.4 changes. To 1.4!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.