Closed Bug 928230 Opened 7 years ago Closed 6 years ago

Global frame script doesn't load correctly when restartless add-on is installed

Categories

(Core :: DOM: Content Processes, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 687194
Tracking Status
e10s + ---

People

(Reporter: jorgev, Assigned: mrbkap)

References

Details

(Keywords: testcase)

Attachments

(1 file)

Steps to reproduce:
1) Install testcase add-on.
2) Go to a mozilla.org

Expected result:

After loading, the page will become blank. 

Observed result:

With e10s activated on the latest nightly (27.0a1 (2013-10-15)) and just after the extension is installed, nothing happens. If the browser is restarted, the extension works normally.

I noticed 2 identical errors in the console right after installation:

aDocShell is null browser.js:157

They appear to break gXPInstallObserver, so that's one possible cause for the problems. Another thing to take into account is that the file is being installed locally, by dropping it into the Add-ons Manager window.
(In reply to Jorge Villalobos [:jorgev] from comment #0)
> 2) Go to a mozilla.org

I meant "Go to mozilla.org", but anything under mozilla.org or mozilla.com should work.
Well if we're in e10s mode, there is no docshell for tabs, or the docshell is in the child process, 
not accessible to browser chrome.
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
Assignee: nobody → mrbkap
Depends on: 952201
Status: NEW → ASSIGNED
Component: IPC → DOM: Content Processes
It appears that we're not correctly propagating the new chrome:// stuff to the content process.
Depends on: 687194
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687194
You need to log in before you can comment on or make changes to this bug.