Closed Bug 928585 Opened 7 years ago Closed 5 years ago

Empty favicon after adding a search engine

Categories

(Firefox for Android :: Favicon Handling, defect)

All
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1029555
Tracking Status
firefox27 --- affected
firefox28 --- affected
firefox29 --- affected
firefox37 --- affected
firefox38 --- affected
firefox39 --- affected
firefox40 --- affected
fennec - ---

People

(Reporter: liuche, Unassigned)

References

Details

Attachments

(2 files)

This doesn't happen every time, and might be a timing issue, but sometimes newly added search engines don't have a favicon in the Search Settings.

I've seen this with adding another Twitter and Google search engine (but again, not always).

Seen on a Galaxy Nexus, Nightly 27.0a1 2013-10-18.
STR:
Add a search engine by long-tapping a search field. Navigate (quickly?) to Settings > Customize > Search settings

Expected:
New search engine is present in the search engine list with a favicon.

Actual:
Sometimes (not particularly often) new search engine is present without a favicon.
Does this also happen on Aurora, or just Nightly? I'm wondering if it's a regression from recent favicon work, or an issue that already existed.
tracking-fennec: --- → ?
Chenxia, can you look into whether or not this is a regression?
Flags: needinfo?(liuche)
Ok, it looks like this is not strictly a regression, because I can repro on 26.

STR: (this is timing dependent)
1. Load a site and *before the throbber disappears/favicon loads in urlbar* long-tap on a form element (editable text box) to bring up the context menu.
2. Click Add search engine and confirm name.
3. Navigate to Settings > Customize > Search Settings.

Expected:
Search engine in the search engines list displays icon.

Actual:
No icon ever displayed for that search engine in the search engine list.
Flags: needinfo?(liuche)
My hypothesis: at the point the search window goes to fetch the favicon, it hasn't finished being downloaded and stored in the DB or cache (either because the download hasn't finished, or because the page hasn't been parsed and thus it hasn't even been fetched yet).

If the favicon data isn't in the DB or cache, there's no way it can be fetched for display!

To fix this we'd need to do one or both of these things:

* Stuff the favicon URL into the DB as early as possible, and make sure that the code path used for the search list will trigger a fetch if necessary. (This should chain, too.)

* Have the search engine page register an observer of some kind, so it's aware of favicon changes.
tracking-fennec: ? → -
Still an issue?
Flags: needinfo?(liuche)
I guess so. I can reproduce this easily.

Conduct a search through Bing. Add the search engine from their search field. Head into our search settings, and see 'Bing 2' with no associated icon.
Flags: needinfo?(liuche)
(In reply to Richard Newman [:rnewman] from comment #6)
> My hypothesis: at the point the search window goes to fetch the favicon, it
> hasn't finished being downloaded and stored in the DB or cache (either
> because the download hasn't finished, or because the page hasn't been parsed
> and thus it hasn't even been fetched yet).
> 
> If the favicon data isn't in the DB or cache, there's no way it can be
> fetched for display!
> 
> To fix this we'd need to do one or both of these things:
> 
> * Stuff the favicon URL into the DB as early as possible, and make sure that
> the code path used for the search list will trigger a fetch if necessary.
> (This should chain, too.)
> 
> * Have the search engine page register an observer of some kind, so it's
> aware of favicon changes.

Or...
* Use your idea to fetch the favicon from the Favicon cache in Java instead of loading it from the DB.
See Also: → 961600
Depends on: 961600
Hardware: ARM → All
See Also: 961600
Component: General → Favicon Handling
Duplicate of this bug: 1129235
Hello, I have the same problem here. I have done some investigations with this bug. I noticed the problem was concerning Wiktionary but not Wikipedia's icons. So I started to search what could be different. The problem seems to be the available icons in the icon file. As you maybe know an icon file can store several icons, most often the same icon in different resolutions and color depth. I made a fake "search server" with node.js and could test the "add search engine" feature with different icons. Here are the results of my testing (all tests done with BMP icons, I did not test PNG icons):
- 48x48 4bits color depth, 32x32 4bits color depth, 16x16 4bits color depth (same case as Wikipedia's icon file) => succeed to retrieve icon in search engine list
- 16x16 32bits color depth, 32x32 32bits color depth, 48x48 32bits color depth (same case as Wiktionary's icon file) => fail to retrieve icon in search engine list
- 16x16 32bits, 32x32 32bits => success
- 16x16 32bits, 32x32 32bits, 48x48 1bit => success
- 16x16 32bits, 32x32 32bits, 64x64 32bit => fail
- 16x16 32bits, 32x32 32bits, 64x64 1bit => success
- 16x16 32bits, 32x32 32bits, 64x64 4bit => success
- 16x16 32bits, 32x32 32bits, 64x64 8bit => fail

As you can see, some icon resolutions can generate the failure, and the most ironic is those resolutions are completely irrelevant as the 16x16 icon should be took as a priority as its size is the best fit.
This isn't restricted to Android, is it?
If it isn't, then this should probably be recategorized.
Firefox for Android's favicon handling is not used in desktop.
Sorry this is for android? My bad, the bug I saw is for desktop.
You should check the bug is not related to this one:
https://bugzilla.mozilla.org/show_bug.cgi?id=361923

Ten years old.
Duping forward because that bug has better discussion. Mainly comments four and six.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1029555
You need to log in before you can comment on or make changes to this bug.