NewTabUtils.jsm js exceptions

VERIFIED FIXED in Firefox 30

Status

Firefox for Metro
Firefox Start
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ally, Assigned: jimm)

Tracking

unspecified
Firefox 30
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=1 s=it-30c-29a-28b.1 r=ff30)

Attachments

(1 attachment, 1 obsolete attachment)

884 bytes, patch
jimm
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
[JavaScript Error: "[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/NewTabUtils.jsm :: <TOP_LEVEL> :: line 223"  data: no]" {file: "resource://gre/modules/NewTabUtils.jsm" line: 223}]
[JavaScript Error: "Not a number" {file: "resource://gre/modules/PlacesDBUtils.jsm" line: 975}]
[JavaScript Error: "[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/NewTabUtils.jsm :: <TOP_LEVEL> :: line 223"  data: no]" {file: "resource://gre/modules/NewTabUtils.jsm" line: 223}]

m-c from monday, these were not here last week. appeared upon startup, not a new profile.
The NewTabUtils errors are trying to read the "browser.newtabpage.enabled" pref.  We may want to add this to metro.js:

 pref("browser.newtabpage.enabled", true);

(Or should it be false?)
(Assignee)

Comment 2

4 years ago
I think we want this set to true so our thumbnails update - 

http://mxr.mozilla.org/mozilla-central/ident?i=AllPages&tree=mozilla-central&filter=
(Assignee)

Comment 3

4 years ago
Created attachment 8372421 [details] [diff] [review]
fix

I've been doing update testing over on oak, and I keep seeing this in the console. Adding this pref solves the problem and doesn't appear to mess with our about:start thumbnails in any way.
Assignee: nobody → jmathies
Attachment #8372421 - Flags: review?(mbrubeck)

Updated

4 years ago
Blocks: 838081
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: p=0 s=it-30c-29a-28b.1
Target Milestone: --- → Firefox 30

Updated

4 years ago
Whiteboard: p=0 s=it-30c-29a-28b.1 → p=1 s=it-30c-29a-28b.1

Updated

4 years ago
Whiteboard: p=1 s=it-30c-29a-28b.1 → p=1 s=it-30c-29a-28b.1 r=ff30
Target Milestone: Firefox 30 → ---

Updated

4 years ago
Blocks: 861680
No longer blocks: 838081
Attachment #8372421 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 4

4 years ago
Created attachment 8373543 [details] [diff] [review]
export
Attachment #8372421 - Attachment is obsolete: true
Attachment #8373543 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/1c7a9d75142f
Keywords: checkin-needed
Whiteboard: p=1 s=it-30c-29a-28b.1 r=ff30 → p=1 s=it-30c-29a-28b.1 r=ff30[fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/1c7a9d75142f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: p=1 s=it-30c-29a-28b.1 r=ff30[fixed-in-fx-team] → p=1 s=it-30c-29a-28b.1 r=ff30
Target Milestone: --- → Firefox 30
Could anyone please give guidance in order for the QA to verify this?
Flags: needinfo?(jmathies)
(Assignee)

Comment 8

4 years ago
(In reply to Manuela Muntean [:Manuela] [QA] from comment #7)
> Could anyone please give guidance in order for the QA to verify this?

Open the browser, hit ctrl-shift-j, wait ten seconds. you shouldn't see any exceptions in NewTabUtils code in the console.
Flags: needinfo?(jmathies)
(In reply to Jim Mathies [:jimm] from comment #8)
> (In reply to Manuela Muntean [:Manuela] [QA] from comment #7)
> > Could anyone please give guidance in order for the QA to verify this?
> 
> Open the browser, hit ctrl-shift-j, wait ten seconds. you shouldn't see any
> exceptions in NewTabUtils code in the console.

Verified as fixed with latest Nightly on Win 8 64-bit, for iteration IT-30C-29A-28B.1 (it #24)
Status: RESOLVED → VERIFIED
Duplicate of this bug: 937393
You need to log in before you can comment on or make changes to this bug.