[e10] Jetpack Add-on SDK support for e10s

RESOLVED DUPLICATE of bug 1004745

Status

Add-on SDK
General
P4
normal
RESOLVED DUPLICATE of bug 1004745
4 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
bsmedberg says: "It is certainly a work item to make the Jetpack implementation e10s-compatible. I believe the following high-level (stable) APIs are affected; they already use the content-script pattern for touching content, so in general we just need to make sure that content scripts work, and then hook up tabs and widget."

* context-menu
* page-mod
* page-worker
* panel
* selection
* tabs
* widget
(cc'ing Mossop & Irakli)

It is true that by design the Add-on SDK's apis should work with e10s. There was a lot of work done in 2011 to achieve this goal. Large parts of the SDK codebase have changed since then so I suspect we will need to fix things up in various points. Bugs found in testing should block this bug.

I guess the first question is, with an e10s build so the SDK tests pass?
P4, because it's a tracking bug.
Priority: -- → P4
(Reporter)

Updated

4 years ago
tracking-e10s: --- → +
Important note to people starting to look at this: due to the new apis being added with Australis in Firefox 29, the widget api is now deprecated.
(Reporter)

Comment 4

3 years ago
Zombie: is this bug a duplicate of a different tracking bug you are using to track your Jetpack work?
Flags: needinfo?(tomica+amo)
you could say this is a dup of bug 1004745, i filed that one because i wanted my own tracking bug, without presumptions of setting someone else's agenda.

or i guess this could depend on that other one..
Depends on: 1004745
Flags: needinfo?(tomica+amo)
Blocks: 1046044

Comment 6

3 years ago
is there a timeline for e10s fix for jetpack addons?

because of the rather long lead time for AMO to approve addons (I'm a reviewer myself, I know it's a lot of work! not trying to complain, just addressing the reality of the situation), it would be really helpful to have an idea of when a fix might be forthcoming and how soon I need to work ahead of that to test, potentially get a new version submitted, etc.
(In reply to Steve Sobel from comment #6)
> is there a timeline for e10s fix for jetpack addons?
> 
> because of the rather long lead time for AMO to approve addons (I'm a
> reviewer myself, I know it's a lot of work! not trying to complain, just
> addressing the reality of the situation), it would be really helpful to have
> an idea of when a fix might be forthcoming and how soon I need to work ahead
> of that to test, potentially get a new version submitted, etc.

This is the remaining queue of issues. A key issue is the context menu, which will likely involve a compatibility break.

I currently don't expect e10s will get out of nightly until Gecko 37 or 38, and we hope to have Jetpack issues resolved prior to that point.

HTH
(In reply to Steve Sobel from comment #6)
> is there a timeline for e10s fix for jetpack addons?

there is still not a timeline for e10s as a whole. we hope to get "most things mostly working" in the next month, enough for e10s to be turned on by default in Nightly 36 (but probably without riding the train to Aurora right away).


> an idea of when a fix might be forthcoming and how soon I need to work ahead
> of that to test, potentially get a new version submitted, etc.

except the context-menu issue Jeff mentioned above (which we still don't have the complete answer for), there shouldn't be any changes required for most addons, and thus no need for most authors to re-submit to AMO..
No longer depends on: 1004745
I don't think there is any point having both these bugs open.
No longer blocks: 905436
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1004745
You need to log in before you can comment on or make changes to this bug.