Daily (Central) and Earlybird (Aurora) l10n builds failing because of lightning

RESOLVED FIXED in Thunderbird 27.0

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bhearsum, Assigned: standard8)

Tracking

unspecified
Thunderbird 27.0
x86_64
Linux
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird26 fixed)

Details

Attachments

(1 attachment)

make[1]: Entering directory `/builds/slave/tb-c-aurora-lx-l10n-ntly-00000/build/comm-aurora/objdir-tb/calendar/lightning'
/builds/slave/tb-c-aurora-lx-l10n-ntly-00000/build/comm-aurora/objdir-tb/mozilla/config/nsinstall -D ../../mozilla/dist/linux-i686
/builds/slave/tb-c-aurora-lx-l10n-ntly-00000/build/comm-aurora/objdir-tb/mozilla/config/nsinstall -R -m 644 ../../mozilla/dist/xpi-stage/lightning-2.8a2.uk.linux-i686.xpi ../../mozilla/dist/linux-i686
/builds/slave/tb-c-aurora-lx-l10n-ntly-00000/build/comm-aurora/objdir-tb/mozilla/config/nsinstall: cannot access ../../mozilla/dist/xpi-stage/lightning-2.8a2.uk.linux-i686.xpi: No such file or directory
make[1]: Leaving directory `/builds/slave/tb-c-aurora-lx-l10n-ntly-00000/build/comm-aurora/objdir-tb/calendar/lightning'
make[1]: *** [stage_upload] Error 1
make: *** [calendar-upload] Error 2
Duplicate of this bug: 926203
I've just done some manual reproduction for this bug. It appears the make installers-<AB_CD> command is failing to produce a lightning*.xpi, and hence when coming to the upload step, the xpi can't be found.

I think the command that fails is:

MOZ_PKG_PLATFORM=mac MOZ_UPDATE_CHANNEL=nightly make L10N_XPI_NAME=lightning-nn-NO L10N_XPI_PKGNAME=lightning-2.9a1.nn-NO.mac AB_CD=de recreate-platformini repack-stage repack-process-extrafiles libs-de

It seems it needs to run the 'tools' target.
Summary: aurora l10n builds failing because of lightning → Daily (Central) and Earlybird (Aurora) l10n builds failing because of lightning
This was fallout from bug 912292 and bug 916625.
Assignee: nobody → mbanner
Depends on: 916625, 912292
Posted patch The fixSplinter Review
The dependent bugs moved the packaging stage from libs to tools, so we now need to run the additional tools step to get the actual xpi.
Attachment #823259 - Flags: review?(philipp)
Comment on attachment 823259 [details] [diff] [review]
The fix

r=philipp, thanks!
Attachment #823259 - Flags: review?(philipp) → review+
Pushed, leaving open until we confirm repacks work again:

https://hg.mozilla.org/comm-central/rev/7460b4f8558a
Comment on attachment 823259 [details] [diff] [review]
The fix

[Triage Comment]
This is fixed now. Taking onto beta (as of yesterday's merges, its on aurora already).
Attachment #823259 - Flags: approval-comm-beta+
https://hg.mozilla.org/releases/comm-beta/rev/c43dd7dfaa8f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 27.0
You need to log in before you can comment on or make changes to this bug.