With Confirm-Address 1.2.6 addon, Ctrl-Return keyboard shortcut does not work for sending message on Thunderbird 24.1

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: Kunihiko Nishiyama, Unassigned)

Tracking

(Blocks: 1 bug)

24 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:Confirm-Address], URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; GTB7.5; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; MS-RTC LM 8)

Steps to reproduce:

Just to use keyboard short cut "Ctrl-Return" when I want to send e-mail.


Actual results:

Nothing happened. keyboard short cut "Ctrl-Return" does not work.


Expected results:

E-mail should be sent.

Comment 1

4 years ago
Kunihiko, are you sure that focus was correctly on the compose window when you tried that?
Pls click inside compose window to ensure focus, then try ctrl+Enter again, does it work?
When you send with Ctrl+click, would you normally get the confirmation prompt or you disabled that?

Updated

4 years ago
Blocks: 713979
(Reporter)

Comment 2

4 years ago
One supplement
I found that ctrl+Enter works correctly when I disable add-on Confirm-Address 1.2.6 .
Before thunderbird was updated, ctrl+Enter w/ Confirm-Address 1.2.6 worked correctly.
But I couldn't tell old version above.

Comment 3

4 years ago
(In reply to Kunihiko Nishiyama from comment #2)

Thank you Kunihiko for reporting more details.

> One supplement
> I found that ctrl+Enter works correctly when I disable add-on
> Confirm-Address 1.2.6 .

So it is a bug in the addon, not in TB.
Can you pls contact the addon author and notify him of this bug?

> Before thunderbird was updated, ctrl+Enter w/ Confirm-Address 1.2.6 worked
> correctly.
> But I couldn't tell old version above.

I don't understand that last sentence.
Severity: normal → minor
Summary: Ctrl-Return does not work when I want to send e-mail on Thunderbird 24.1. → With Confirm-Address 1.2.6 addon, Ctrl-Return keyboard shortcut does not work for sending message on Thunderbird 24.1
(Reporter)

Comment 4

4 years ago
I checked add-on confirm-address web and found this bug was already raised below.
http://code.google.com/p/confirm-address/issues/detail?id=25

Comment 5

4 years ago
Thanks Kunihiko, that's very helpful.
So we can close this bug because there's an addon bug on record:
http://code.google.com/p/confirm-address/issues/detail?id=25
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

4 years ago
With Confirm-Address 1.2.6 addon, Ctrl-Return keyboard shortcut correctly works for sending message on Thunderbird 24.1.1.
(Reporter)

Comment 7

4 years ago
Sorry Confirm-address is aready updated from 1.2.6 to 1.2.8.
Now I cannot tell which part is root cause.

Updated

3 years ago
Component: Untriaged → Message Compose Window
Whiteboard: [addon:Confirm-Address]
You need to log in before you can comment on or make changes to this bug.