Execution of <script defer> scripts not deferred

VERIFIED DUPLICATE of bug 28293

Status

()

Core
HTML: Parser
P5
enhancement
VERIFIED DUPLICATE of bug 28293
16 years ago
16 years ago

People

(Reporter: Robin Lionheart, Assigned: harishd)

Tracking

({html4})

Trunk
x86
All
html4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Mozilla does not support the "defer" attribute of the <script> element
(http://www.w3.org/TR/html4/interact/scripts.html#adef-defer).
(Reporter)

Updated

16 years ago
Blocks: 7954, 41368
(Reporter)

Updated

16 years ago
Keywords: html4

Comment 1

16 years ago
do we care?
Assignee: asa → harishd
Component: Browser-General → Parser
QA Contact: doronr → bsharma
(Reporter)

Comment 2

16 years ago
It's optional, and not very important. I think it only exists so Internet
Explorer 4.0 can render JavaScript-heavy pages slightly faster. Setting priority
to low and severity to enhancement.
Severity: normal → enhancement
OS: Windows 2000 → All
Priority: -- → P5
Summary: "defer" attribute of <script> not supported → Execution of <script defer> scripts not deferred
See bug 28293 (RFE: defer attribute not supported on script elements)

This is a dupe, though it doesn't look like it will be added soon as other
things have taken higher priority.  The blocker bugs should be removed from this
bug and added to bug 28293.

*** This bug has been marked as a duplicate of 28293 ***
No longer blocks: 7954, 41368
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Oh, didn't notice the dupe. My searh didn't include bugs which were resolved LATER.

Comment 5

16 years ago
vrfy. i don't blame you, see bugs about 'later considered harmful' :-(
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.