If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sLoadTasks removal incorrectly uses long, not Integer

RESOLVED FIXED in Firefox 27

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 28
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ fixed, firefox28 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
This will cause sLoadMap to grow endlessly, and -- due to some of the inefficiencies revealed in Bug 931843 -- it'll hold on to every view, every thumbnail, ...
(Assignee)

Updated

4 years ago
Summary: sLoadMap removal incorrectly uses long, not Integer → sLoadTasks removal incorrectly uses long, not Integer
(Assignee)

Comment 2

4 years ago
Created attachment 826140 [details] [diff] [review]
Proposed patch. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  FaviconsRewrite.

User impact if declined: 
  Eventual OOM.

Testing completed (on m-c, etc.): 
  Tested locally with logging, verified that sLoadTasks tends towards 0 items. Patch up for review now, will bake on m-c.

Risk to taking this patch (and alternatives if risky): 
  Should be none.

String or IDL/UUID changes made by this patch:
  None.
Attachment #826140 - Flags: review?(mark.finkle)
Attachment #826140 - Flags: approval-mozilla-aurora?
Attachment #826140 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/d6136cbe47d1
Severity: normal → critical
Target Milestone: --- → Firefox 28
(Assignee)

Updated

4 years ago
Blocks: 933814, 932054
Depends on: 914296

Updated

4 years ago
status-firefox26: --- → unaffected
tracking-firefox27: ? → +

Updated

4 years ago
Attachment #826140 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 4

4 years ago
Looks cheerful on fx-team, so:

https://hg.mozilla.org/releases/mozilla-aurora/rev/4aca57f111d3
status-firefox27: affected → fixed
status-firefox28: --- → fixed
(Assignee)

Comment 5

4 years ago
Looks like this merge didn't get recorded.

https://hg.mozilla.org/mozilla-central/rev/d6136cbe47d1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.