Closed Bug 934522 Opened 7 years ago Closed 7 years ago

[B2G][DSDS] WebIccManager API will be changed for DSDS so Single Variant: Preload Apps Runtime Customization by SIM scenario needs to be modified accordingly

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+)

RESOLVED DUPLICATE of bug 926343
1.3 Sprint 6 - 12/6
blocking-b2g 1.3+

People

(Reporter: noemi, Assigned: macajc)

References

Details

(Whiteboard: [systemsfe])

As a BU I want to be able to choose which apps are preloaded in the devices for my specific country as part of a single variant for several countries after WebIccManager change for DSDS

Acceptance Criteria:
* Same behavior as the one defined for a single SIM device, using the SIM at slot#0 as the equivalent of the single SIM for all purposes
* SIM card needs to be inserted in slot #0, in case not, the default core/common configuration will be applied or a specific warning asking for SIM card to be inserted in slot #0 will be shown depending on the scenario (SIM card is not mandatory vs SIM card is mandatory)

NOTE: Once the new WebIccManager api is landed, single SIM device implementation won’t work so it is a must to work on integrating the new interface
Assignee: nobody → cjc
Blocks: b2g-dsds-1.3
blocking-b2g: --- → 1.3?
QA Contact: rafael.marquez
Looks like a 1.3+ bug, because it affects the single SIM behavior. Do we know the possible target milestone for this bug?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(cjc)
(In reply to Kevin Hu [:khu] from comment #1)
> Looks like a 1.3+ bug, because it affects the single SIM behavior. Do we
> know the possible target milestone for this bug?

yes, it impacts single sim card scenario. 
On the other hand, the possible target milestone would be "1.3 Sprint 5" but it also depends on when the new WebIccManager api lands, beacuse of this, we haven't set Target Milestone field within this bug yet. We will do it once the new api lands. Thanks
Flags: needinfo?(cjc)
Renominating - we haven't discussed this as a 1.3 feature yet for Systems FE.

needinfo on Peter to figure this out
blocking-b2g: 1.3+ → 1.3?
Flags: needinfo?(pdolanjski)
Summary: [B2G][DSDS][User Story] Single Variant: Preload Apps Runtime Customization by SIM for DSDS → [B2G][DSDS][User Story] WebIccManager API will be changed for DSDS so Single Variant: Preload Apps Runtime Customization by SIM scenario needs to be modified accordingly
(In reply to Noemí Freire (:noemi) from comment #2)
> yes, it impacts single sim card scenario. 

If this is the case, we can't leave it as is.  I think we'll have to block on it as a result.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(pdolanjski)
Whiteboard: [systemsfe]
Remove blocking-b2g flag from User Story bugs. Use whiteboard to indicate what FxOS version we target.
blocking-b2g: 1.3+ → ---
It is not a new feature but a bug, once the new WebIccManager api is landed, single SIM device implementation won’t work. This bug covers the changes needed to recover single SIM card scenario. Because of this, setting v1.3+ flag again.
blocking-b2g: --- → 1.3+
Summary: [B2G][DSDS][User Story] WebIccManager API will be changed for DSDS so Single Variant: Preload Apps Runtime Customization by SIM scenario needs to be modified accordingly → [B2G][DSDS] WebIccManager API will be changed for DSDS so Single Variant: Preload Apps Runtime Customization by SIM scenario needs to be modified accordingly
Target Milestone: --- → 1.3 Sprint 6 - 12/6
(In reply to Noemí Freire (:noemi) from comment #6)
> It is not a new feature but a bug, once the new WebIccManager api is landed,

Oops! Sorry, my bad.
This bug has already been resolved in attach [1] of bug 926343

[1] https://bug926343.bugzilla.mozilla.org/attachment.cgi?id=823877
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926343
Blocks: b2g-dsds-1.4
No longer blocks: b2g-dsds-1.4
Just to summarize expected behavior:
* For devices with a single SIM, there is no change, so we only have to check there is no regression after landing dual SIM API
* For devices with dual SIM, only SIM card in slot #0 will be taken into account (ignoring SIM card in slot #1), so it is same scenario as single SIM using only slot #0
You need to log in before you can comment on or make changes to this bug.