Closed Bug 917705 (b2g-dsds-1.3) Opened 10 years ago Closed 9 years ago

(DSDS) [meta] Dual SIM Dual Stand-by for 1.3

Categories

(Firefox OS Graveyard :: RIL, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: khu, Unassigned)

References

Details

(Whiteboard: [dependency:Payments])

Attachments

(2 files, 2 obsolete files)

Meta bug to collect all user stories for DSDS feature.
Looping COMM's PMs to avoid opening duplicated bugs for DSDS, which are highly overlapped between RIL and COMM teams.
(In reply to Gene Lian [:gene] from comment #1)
> Looping COMM's PMs to avoid opening duplicated bugs for DSDS, which are
> highly overlapped between RIL and COMM teams.

Thanks, Gene!
No longer blocks: 1.3-RIL/Net/Conn
Alias: b2g-DSDS
Alias: b2g-DSDS → b2g-dsds
Depends on: 921393
Depends on: 921394
Depends on: 921968
Depends on: 921971
Depends on: 921980
Depends on: 923629
Depends on: 926342
Depends on: 926345
Depends on: 926347
Depends on: 926350
Depends on: 926351
Depends on: 926352
Depends on: 926355
No longer depends on: 856553, 926169
Depends on: 927764
No longer depends on: 921971
Depends on: 929257
Kevin, the operator variant logic in charge of customizing APNs, voicemail, cellbroadcast, and some messaging settings must be adapted to a DSDS scenario as well. See [1] please. Should we file a bug? Thanks!

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/operator_variant/operator_variant.js
Flags: needinfo?(khu)
Depends on: 933203
That's a good point, jaoo. But, it looks like it's too late for v1.3. I filed bug 933203 for this variant. Thanks!
Flags: needinfo?(khu)
Depends on: 934404
Depends on: 934522
No longer depends on: 858003
Depends on: 938422
Depends on: 938430
Depends on: 938433
Depends on: 938438
Depends on: 938440
Depends on: 938443
Depends on: 939934
Attached file [SPEC] DSDS v0.8 .pdf (obsolete) —
DSDS spec v0.8 is uploaded.
Depends on: 941476
No longer depends on: 933203
Blocks: b2g-dsds-1.4
Make summary clearly.
Alias: b2g-dsds → b2g-dsds-1.3
Summary: (DSDS) [meta] Dual SIM Dual Stand-by → (DSDS) [meta] Dual SIM Dual Stand-by for 1.3
No longer depends on: 937554
No longer depends on: 934404
No longer depends on: 937424
No longer depends on: 938433
No longer depends on: 938430
Depends on: 927896
Depends on: 927893
No longer depends on: 938438
No longer depends on: 938443
No longer depends on: 929257
No longer depends on: 921968
No longer depends on: 918553
Carrie,

Do we have assets for the large SIM icons (SIM1 & SIM2), specifically for the FTE info screen (page 16 of the spec) and SIM settings manager (page 21).

I see we have small sim1 and sim2 icons for the settings page:
https://github.com/mozilla-b2g/gaia/blob/1d82b5f63db21d049de10ff9de3215d916a0c2a7/apps/settings/style/images/simcards.png

But as far as large icons, it looks like we only have this without numbers 1 & 2:
https://github.com/mozilla-b2g/gaia/blob/5270a9e465112d8f4e18b68e53290e1ab649ca88/apps/communications/ftu/css/images/import_sim.png
Flags: needinfo?(cawang)
Hi Michael, 

Yes, the visual designer has designed the icons. She will attach here for you.

Hi Fang, 

Can you please provide the SIM icons on p.16? Thanks!
Flags: needinfo?(cawang) → needinfo?(fshih)
Attached file DSDS_20131125.zip
Hi Michael,
I've packed all the assets and the spec as a zip.
Thanks!
Flags: needinfo?(fshih)
(In reply to Fang Shih from comment #9)
> Created attachment 8339753 [details]
> DSDS_20131125.zip
> 
> Hi Michael,
> I've packed all the assets and the spec as a zip.
> Thanks!

Thank you Fang!

It looks like the size for these SIM icons are still 30x30. I think we will want something bigger for the SIM manager screen in the FTU?
Flags: needinfo?(fshih)
Hi Micheal, 

I don't think we need the bigger size icon for SIM manager screen in the FTU, What size are you looking for? 

Thanks!
Flags: needinfo?(fshih) → needinfo?(mhenretty)
I'm not sure the exact size we need here, but the 30x30 image looks pixelated when used for the FTU SIM manager page. As a reference, 30x30 is the same size we use for the "SIM Security" icon in the settings page, which is much smaller.
Attachment #8342499 - Flags: ui-review?(fshih)
Flags: needinfo?(mhenretty)
Comment on attachment 8342499 [details]
Screen Shot 2013-12-04 at 10.02.49 AM.png

Ah my fault, the spec in the zip file is different than the one uploaded to this bug. I'll attach that file here for easy access.
Attachment #8342499 - Attachment is obsolete: true
Attachment #8342499 - Flags: ui-review?(fshih)
Blocks: 948708
No longer blocks: 948708
Depends on: 948708
Whiteboard: [dependency:Payments]
The stage of features implementation for 1.3 is finished.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.