Closed Bug 93566 Opened 19 years ago Closed 19 years ago

convert nsMacLocale to use NS_GET_MODULE

Categories

(Core :: Internationalization, defect, P3)

PowerPC
Mac System 9.x
defect

Tracking

()

VERIFIED DUPLICATE of bug 94831
mozilla0.9.4

People

(Reporter: thesteve, Assigned: waterson)

References

Details

Attachments

(2 files)

remove nsLocaleSHLIB.cpp with the
deprecated NS_GET_FACTORY implementation; add a nsLocaleModule.cpp, with
NS_GET_MODULE implementation. 

In order to land the static Mac build (which requires this change for its
targets), on the branch, it would be better to already have these changes
working for existing targets on the trunk.

NOTE: this is separating out the nslocale issue from Bug #90763; which was
distinguished from #77151 by specifying only those NS_GET_FACTORY changes
neccesitated by the mac static branch landing issue.
accepting.  
I need a help from jbetak to compile the module under Mac once
the conversion is finished.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → mozilla0.9.4
Roy -- thanks for accepting.

The current status of the mac static build (Bug #81373), is that we have a build 
on a branch, STATIC_BUILD_20010628_BRANCH which builds (right now, the debug 
build works fine, the optimized build needs a little hand-holding). We are 
preparing to land, hopefully next week, or the one after.

I'll be attaching the current nsLocaleModule.cpp from the tip of this branch, 
which was hacked together by hanking code from the unix implementation, I think, 
and praying. Of course it links, but we are very uncertain that it is right.
Blocks: 81373
Roy can you reviw this bug soon?
This is one last blocker for landing mac static build.  
Thanks!!!
The patch seems straight forward.
/r=yokoyama
Blocks: 93100
roy/frank, could you please review the above changes? I need this for bug 93100
which is topembed. Thanks!
Assignee: yokoyama → waterson
Status: ASSIGNED → NEW
thanks Chris. 
/r=yokoyama;  
Dup'ing to bug 94831; I'll just fix all of these problems under that bug.

*** This bug has been marked as a duplicate of 94831 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
We love you, waterson.
Verified as dupe. Please re-open in case someone disagrees.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.