Closed Bug 93592 Opened 21 years ago Closed 4 years ago

floats can be overwritten

Categories

(Core :: Layout: Floats, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: brianclark44, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: css1, testcase, Whiteboard: [bae:20011129][CSS1-5.5.25])

Attachments

(4 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.3) Gecko/20010802
BuildID:    2001080214

Mozilla 0.9.3 for MacOS 9.1 fails a portion of the W3C's CSS1 Test Suite: 4.1.4
Floating Elements.

Some of the floated elements on the page are overwritten by some of the DIV text.  



Reproducible: Always
Steps to Reproduce:
1.Go to the above web page
2.Load the page
3.Scroll down to see the examples of the floated elements being overwritten by
portions of the DIV text.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css1
WFM, 2001-08-01-03 on Windows 98 SE.
Are you using a "View - Text Size" other than 100% ? I see text overlapping
the floaters if I use 90% or 120% for example.
I don't seem to have this "View - Text Size" option in Mozilla 0.9.3 for Mac. 
It should be on the "View" menu at the top of the screen, right?  I would have
to assume that since I don't have it, the text size is hard coded somewhere. 
Reassigning to attinasi.
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla1.0
behaviour confirmed on win98. DIV text overlaps floating elements' text.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011118
Target Milestone: mozilla1.0 → mozilla1.2
handing over to Pierre for debug
Assignee: attinasi → pierre
Whiteboard: [bae:20011129]
Target Milestone: mozilla1.2 → ---
Back to Layout.  Changed the summary line from "Mozilla fails a portion of the 
W3C's CSS1 Test Suite: 4.1.4 Floating Elements" to "[FLOAT] floats can be 
overwritten".

I understand it is bad to fail even a part of a testcase from the CSS1 test suite 
but in that case it doesn't seem to be too important.  Look at the attached 
simplified testcase.  The DIV text only overwrites the second float when:
* the two floats don't fit on the same line
* the margin on these floats is very small (either 0 or a few pixels)
Assignee: pierre → attinasi
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Mozilla fails a portion of the W3C's CSS1 Test Suite: 4.1.4 Floating Elements → [FLOAT] floats can be overwritten
Attached file simplified testcase
Keywords: testcase
I have another example of this bug, although it takes some work to find it.  The
URL is http://www.meyerweb.com/eric/css/edge/slantastic/demo.html but the bug
only manifests at certain browser window sizes (and thus certain flow
arrangements).  I'm going to attach a screenshot I took of the problem, so that
hopefully others can reproduce the same bug.  The screenshot was taken in
2002011803/Mac.  (It also shows a different bug that I'm going to be submitting.)

As for this being unimportant, I very much disagree.  If it's possible for
normal-flow text to overwrite floats, then floats become a lot less useful for
advanced page layout.  It also makes me less sanguine about our flow
calculations in general, since it implies that we don't really know where
everything is and so can't figure out when a line should be wrapped.  That
seems, well, bad.
You can see the words "is 1em" overlapping the borders of a floated text
element.  Other words can be coaxed to overlap the float to varying degrees by
resizing the browser window.
The erroneous white vertical line has been reported in bug 120783.
Target Milestone: --- → mozilla1.1
Whiteboard: [bae:20011129] → [bae:20011129][CSS1-5.5.25]
I do not see this problem occuring on win2000.
But I do see it on RedHat Linux 7.3 

Build ID tested on :-
win2000: 2002-05-12-20-XX-PR1
linux 7.3: 2002-05-12-23-XX-PR1
Priority: -- → P3
also see it on macOS 9.1 
buildID: 2002-05-12-17-XXpr1
Attached file Another testcase
->Floats
Assignee: attinasi → float
Component: Layout → Layout: Floats
QA Contact: petersen → ian
Summary: [FLOAT] floats can be overwritten → floats can be overwritten
Target Milestone: mozilla1.1alpha → ---
This is another slightly-more-complicated variant of bug 25888 (as is bug 41412).
Depends on: 25888
Target Milestone: --- → Future
Blocks: 228588
still fails Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060306 Firefox/1.6a1
Assignee: layout.floats → nobody
QA Contact: ian → layout.floats
Blocks: css2.1-tests
See Also: → 345369
Blocks: 345369
See Also: 345369
All the tests in this bug report now pass in Firefox 52.6.0 ESR buildID=20180123215146

Resolving as WORKSFORME
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.