Closed Bug 936849 Opened 6 years ago Closed 5 years ago

Tablet tabs tray seems to get stuck in some kind of selection mode

Categories

(Firefox for Android :: Theme and Visual Design, defect, P1, major)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 37
Tracking Status
firefox25 --- wontfix
firefox26 --- wontfix
firefox27 --- wontfix
firefox28 --- wontfix
firefox34 --- wontfix
firefox35 --- wontfix
firefox36 --- verified
firefox37 --- verified
fennec 36+ ---

People

(Reporter: rnewman, Assigned: mhaigh)

References

Details

(Keywords: steps-wanted, Whiteboard: kindle)

Attachments

(2 files)

Observed this on the Fire HDX with both Beta and Nightly.

After opening a few tabs, sometimes trying to switch tabs will just get you into a mode where tabs are outlined in bright or dark orange. The only reliable escapes seem to be to open a new tab and load a page, or to scroll to another section of the tab tray and pick a tab you couldn't originally see.

Video: http://youtube.com/watch?v=R8fwMNcV6g0
Can someone in QA, hiding behind a huge pile of tablets, verify whether this behavior exists elsewhere, or if it's just limited to the Fire?
Severity: normal → major
Keywords: verifyme
Whiteboard: kindle
The strange tabs behavior in the video also happens on my phone running Android 4.0.3 (Lenovo A750). Sometimes, I have to close and reopen Firefox for Android because I'm unable to switch tabs and scroll in the tabs list. This annoying bug was present in older Firefox versions as well (I use Firefox on my phone from about one year and this issue was has always been present). I thought that was a only-for-me bug for long time, but now I've seen this bug report and I think it can be a Firefox defect. Sorry for my English and thanks.
Need steps. Have not seen this on any of my tablets (TF201, Tab 3, Nexus 10), nor Note and Nexus 7 devices (2012/2013).
Keywords: verifymesteps-wanted
Steps: open a bunch of tabs (more than will fit on screen in the tab tray, to be sure), then do exactly what I do in the video linked from Comment 0 :P
After some research I found something that can help Firefox developers to diagnose this bug. I've discovered that the "Overscroll" feature in Android may be relevant. In my device (and certainly others), the overscroll on lists is ON, and when I try to scroll beyond the limits of the tabs list (up and down indifferently) the issue happens. So, I written a small Xposed module to turn off the overscroll feature. More specifically, I hooked the getScaledOverscrollDistance() function in the "android.view.ViewConfiguration" class to return always ZERO. Well, this workaround works for me. Without overscroll, this bug does not happens anymore. In stock Android and emulator, the overscroll is turned off, so most devices are not affected (check the OVERSCROLL_DISTANCE integer at https://github.com/android/platform_frameworks_base/blob/master/core/java/android/view/ViewConfiguration.java). Hope this can help. Sorry for my English and thanks again!
Thanks for the tip, Jutah!
Duplicate of this bug: 1097206
Assignee: nobody → lucasr.at.mozilla
Priority: -- → P1
I can reproduce this on the new tablet UI with the following steps:
1. Launch Fennec (a single tab is opened about:home);
2. Open a new tab and navigate to page e.g. google (two tabs are opened);
3. Open the tabs tray and close the first tab, from step 1;
4. Open the tab from step 2 by tapping on it.

Tab is outlined in dark orange and isn't opened. Same issue or I should file another bug?
Flags: needinfo?(lucasr.at.mozilla)
Same issue, thanks for the STR.
Flags: needinfo?(lucasr.at.mozilla)
We should track P1's.
tracking-fennec: --- → ?
tracking-fennec: ? → 36+
Assignee: lucasr.at.mozilla → mhaigh
I've also been able to repro on a Nexus 7 at the SF office.
I'll preface this by saying that I still wasn't able to assertain what the actual problem is.  That said, I believe this patch fixes it by changing some code which was a bit dodgy anyway.

Previously each cell was assigned an onClickListener and also had a ImageButton for the close functinality - something weird happened to the selection click listener when a tab was closed from the tabs panel view.

I've adjusted the code to follow a more Android centric approach of using a single selection listener for the entire layout.  The click then needs to pass down to the layout view, so this meant removing the focusable attribute from the item view and changing the ImageButton to an ImageView.  

Not only does this seem to fix things, but it's also more efficient as we reduce the number on listeners.
Attachment #8544001 - Flags: review?(wjohnston)
Comment on attachment 8544001 [details] [diff] [review]
Tablet tabs tray seems to get stuck in some kind of selection mode

Stealing review. LGTM
Attachment #8544001 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/359485b8b583
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Verified as fixed using steps from comment 9.
Build: Firefox for Android 37.0a1 (2015-01-06)
Device: Asus Transformer Pad TF300T (Android 4.2.1)

I'm able to reproduce this on Firefox for Android 36.0a2 so I will change the status for 36 to affected.
Martyn - Can you request approval for uplifting to Fx36 (aurora) ?
Flags: needinfo?(mhaigh)
Comment on attachment 8544001 [details] [diff] [review]
Tablet tabs tray seems to get stuck in some kind of selection mode

Approval Request Comment
[Feature/regressing bug #]: 
This has been a bug for a while but rarely occurred, the new layout used in the tablet refresh causes this issue to happen far more often - this patch changes how selections are made and eleminates this bug.

[User impact if declined]: 
This bug happens often when a user closes a tab and then selects another; when it happens it'll prevent the user from being able to select certain tabs.

[Describe test coverage new/current, TBPL]:
none

[Risks and why]: 
Worst case is that a bug has been introduced which will affect both tablet and phone and make tabs un-selectable and un-closable.  This is because the changes made alter the way the selection is handled and changes aspects of how the close button works.  This is unlikely to happen given local testing and that the patch landed on nightly and no issues have been raised against it.

[String/UUID change made/needed]: 
N/A
Flags: needinfo?(mhaigh)
Attachment #8544001 - Flags: approval-mozilla-aurora?
Attachment #8544001 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed:
Build: Firefox for Android 36.0a2 (2015-01-07)
Device: Asus Transformer Pad TF300T (Android 4.2.1)
Status: RESOLVED → VERIFIED
Target Milestone: Firefox 37 → Firefox 36
Target Milestone: Firefox 36 → Firefox 37
You need to log in before you can comment on or make changes to this bug.