Closed Bug 937948 Opened 6 years ago Closed 6 years ago

Set up holly project branch with nightlies and updates, same builders as m-c

Categories

(Release Engineering :: General, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Assigned: aki)

References

Details

(Whiteboard: [Australis:P1])

Attachments

(3 files)

Per https://msujaws.wordpress.com/2013/11/08/australis-landing-plans/ holly is going to m-c without australis, and nightly updates are going to be needed. Should we also be enabling l10n + l10n nightlies here ? Probably.

Also all the same builders that m-c has, in case we need to use holly to merge to Aurora - we don't want to detect regression at that point.

jaws, what's the timescale here ? See the l10n question above too.
Flags: needinfo?(jaws)
You can see https://mail.mozilla.org/pipermail/firefox-dev/2013-November/001117.html for the latest update on the potential timeline here. 

Thank you for filing this bug. We will need to make sure that the Holly build/l10n environment matches that of mozilla-central.
Flags: needinfo?(jaws)
We are also planning to include mozmill tests for nightlies on the holly branch. For details see our discussion on https://groups.google.com/forum/#!topic/mozilla.dev.automation/_7mUnkc6468
Duplicate of this bug: 940382
Depends on: 940375
Bug 940382 asks for signed nightly builds for Holly, which is mostly captured here already, but fyi.
Nick, we are now ready to start building signed nightlies. This should exist for the Fx28 Nightly and potentially the Fx29 Nightly.
Flags: needinfo?(nthomas)
We don't need l10n builds for holly. Australis added strings but didn't remove any because we expected to back out on Nightly, and the extra CPU cycles needed to run l10n builds doesn't seem worth it.
Ok, I'm working on the patch for this.
Flags: needinfo?(nthomas)
Sorry for the delay here, RelEng is having a work week so we have less time than normal.
Any update on this?
Assignee: nobody → nthomas
Status: NEW → ASSIGNED
Flags: needinfo?(nthomas)
Nick's out sick. Let me see if I can take a stab at it in between crises.
Attached patch holly.diffSplinter Review
Let me know if you want me to move this review elsewhere.  (Or the other one.)
Attachment #8338080 - Flags: review?(hwine)
Attached patch holly_aus.diffSplinter Review
go go cvs!
(I did a |php config-dist.php| to make sure I don't blow up AUS like I did with fig.)
Attachment #8338082 - Flags: review?(hwine)
Attached patch builderdiffSplinter Review
builder diff
mysql> delete from schedulers where name like '%holly%' and state like '{"last_processed": 2%';
Query OK, 2 rows affected (0.01 sec)

Trying to avoid another scheduler hang...
Comment on attachment 8338080 [details] [diff] [review]
holly.diff

Review of attachment 8338080 [details] [diff] [review]:
-----------------------------------------------------------------

/me learned about signing server config; lgtm
Attachment #8338080 - Flags: review?(hwine) → review+
Comment on attachment 8338082 [details] [diff] [review]
holly_aus.diff

Review of attachment 8338082 [details] [diff] [review]:
-----------------------------------------------------------------

matches fig
Attachment #8338082 - Flags: review?(hwine) → review+
Comment on attachment 8338082 [details] [diff] [review]
holly_aus.diff

Landed, but then I thought about Balrog.
Checking in config-dist.php;
/cvsroot/mozilla/webtools/aus/xml/inc/config-dist.php,v  <--  config-dist.php
new revision: 1.279; previous revision: 1.278
done
Attachment #8338082 - Flags: checked-in+
Ben, Rail, can we get Balrog updates for holly without dealing with the config-dist.php, uh, fun?
I can back out if so.
I can file the blocking IT bug if not.
Flags: needinfo?(rail)
Flags: needinfo?(bhearsum)
(In reply to Aki Sasaki [:aki] from comment #19)
> Ben, Rail, can we get Balrog updates for holly without dealing with the
> config-dist.php, uh, fun?
> I can back out if so.
> I can file the blocking IT bug if not.

Yup, this is easy, and really the only way to do it. (You'd have to modify in-tree code to point back at aus3 to do it there.) Do you want to learn how to do it, or do you just want someone to do it for you?
Flags: needinfo?(rail)
Flags: needinfo?(bhearsum)
(In reply to Ben Hearsum [:bhearsum] from comment #20)
> (In reply to Aki Sasaki [:aki] from comment #19)
> > Ben, Rail, can we get Balrog updates for holly without dealing with the
> > config-dist.php, uh, fun?
> > I can back out if so.
> > I can file the blocking IT bug if not.
> 
> Yup, this is easy, and really the only way to do it. (You'd have to modify
> in-tree code to point back at aus3 to do it there.) Do you want to learn how
> to do it, or do you just want someone to do it for you?

Awesome.  Either works for me.  Learning how probably scales better.
in production
https://tbpl.mozilla.org/?tree=Holly&rev=eebfbe8105f5&jobname=nightly
Once those finish, I think I can populate Balrog with the update channel, and resolve this bug.
Flags: needinfo?(nthomas)
Added a rule for Firefox-holly-nightly-latest in Balrog.

I think we're done here, although I might back out comment 18.
Assignee: nthomas → aki
Backed out:
Checking in config-dist.php;
/cvsroot/mozilla/webtools/aus/xml/inc/config-dist.php,v  <--  config-dist.php
new revision: 1.280; previous revision: 1.279
done
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 944565
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.