Browser would not restart after check update from About Holly

RESOLVED DUPLICATE of bug 944774

Status

()

Toolkit
Application Update
--
blocker
RESOLVED DUPLICATE of bug 944774
4 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: mconley)

Tracking

({regression})

28 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28-)

Details

(Whiteboard: [Holly][Australis:P1])

(Reporter)

Description

4 years ago
Build Identifier:
http://hg.mozilla.org/projects/holly/rev/f58b1b0c9973
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131127040205

An error shown when I click "Restart To Update" button. And Browser would not restart.

Timestamp: 2013/11/29 10:21:21
Error: TypeError: this.addons is undefined
Source File: chrome://browser/content/aboutDialog.js
Line: 271

Steps To Reproduce:
1. Download firefox-28.0a1.en-US.win32.zip from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-11-27-04-02-05-holly/
2. Extract it
3. Start nightly Holly build
4. Help > About Holly, and Click "Check for Updates" button
5. And then click "Restart To Update" button

Actual Results:
Browser would not restart.

Expected Results:
Browser should restart. And Update should complete.
(Reporter)

Updated

4 years ago
Component: General → Application Update
Product: Firefox → Toolkit
(Reporter)

Updated

4 years ago
Keywords: regression
(Reporter)

Updated

4 years ago
Whiteboard: [Holly]
(Reporter)

Updated

4 years ago
Severity: normal → blocker
Blocks: 870032
Whiteboard: [Holly] → [Holly][Australis:P1]
I'll investigate this today.
Assignee: nobody → mconley

Comment 2

4 years ago
This is a hit and miss thing. Sometime it restarts, other times it doesn't. Even when it does, though the update isn't applied. Bug 944774

Another scenario is that, after the partial update is downloaded, Fx starts. However, an error message appears saying that the partial update could not be applied and that Fx is downloading the full version - but it never does this.

Comment 3

4 years ago
(In reply to JoeG from comment #2)
> This is a hit and miss thing. Sometime it restarts, other times it doesn't.
> Even when it does, though the update isn't applied. Bug 944774
> 
> Another scenario is that, after the partial update is downloaded, Fx starts.
> However, an error message appears saying that the partial update could not
> be applied and that Fx is downloading the full version - but it never does
> this.

This bug is fixed now. Alice, if you download a nightly from yesterday or the day before (assuming there are any), can you update successfully now?
Blocks: 937948
Flags: needinfo?(alice0775)

Updated

4 years ago
Depends on: 944774
Yep, this is a dupe of bug 944774. Sorry about that =(.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 944774
(Reporter)

Updated

4 years ago
Flags: needinfo?(alice0775)
Resolution: DUPLICATE → FIXED
(Reporter)

Updated

4 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 944774

Updated

4 years ago
tracking-firefox28: ? → -
You need to log in before you can comment on or make changes to this bug.