switch to tooltool gcc from bug 913442

RESOLVED DUPLICATE of bug 1075183

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1075183
4 years ago
3 years ago

People

(Reporter: tbsaunde, Assigned: tbsaunde)

Tracking

unspecified
mozilla29
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
I'd need to dig through email to get the links but I've tested the following things on try
- try: -b do -p linux,linux64 -u all builds and has no unexpected test issues.
- talos results are the same as trunk, with the exception of cracken (or however its spelled) which seems to have improved? but may just be a fluke.
- 10 or so retriggers don't cause any ICEs

So I guess we might as well try putting this in actual production unless glandium or froydnj have an objection.
(Assignee)

Comment 1

4 years ago
Created attachment 832769 [details] [diff] [review]
gcc.patch
Attachment #832769 - Flags: review?(mh+mozilla)
Attachment #832769 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 2

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fd717549b5a
(Assignee)

Comment 3

4 years ago
backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/b50d2b2f98e0 because b2g desktop builds don't seem to get tooltool packages
(Assignee)

Comment 4

4 years ago
and after adding the manifest to b2g/config/tooltool/linux{32,64}/ we hit https://tbpl.mozilla.org/php/getParsedLog.php?id=30916585&tree=Try because those builds are done in the mozilla-centos-i686 env :( so I guess we can either block on releng  changing that or hack around it somehow.
(Assignee)

Updated

4 years ago
Depends on: 947462

Updated

4 years ago
Blocks: 880419
Blocks: 946639
Comment on attachment 832769 [details] [diff] [review]
gcc.patch

Review of attachment 832769 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/unix/mozconfig.linux
@@ +4,5 @@
> +CXX="$topsrcdir/gcc/bin/g++"
> +
> +# We want to make sure we use binutils and other binaries in the tooltool
> +# package.
> +mk_add_options PATH="$topsrcdir/gcc:$PATH"

while I'm (re)looking at this: there's a missing /bin here.
(Assignee)

Comment 6

4 years ago
Created attachment 8368269 [details] [diff] [review]
gcctest

turns out in addition to b2g be done on i686 vlagrind jobs don't use tooltool at all :/
Attachment #832769 - Attachment is obsolete: true
Attachment #8368269 - Flags: review?(mh+mozilla)
Comment on attachment 8368269 [details] [diff] [review]
gcctest

Review of attachment 8368269 [details] [diff] [review]:
-----------------------------------------------------------------

Note the patch summary refers to the wrong bug ;)

::: build/unix/mozconfig.linux
@@ +1,4 @@
>  . "$topsrcdir/build/mozconfig.common"
>  
> +# some b2g desktop builds still happen on i686 machines, and the tooltool
> +# toolchain is x86_64 only.

b2g desktop should be building on x86-64, but it doesn't use tooltool manifests.

@@ +3,5 @@
> +# some b2g desktop builds still happen on i686 machines, and the tooltool
> +# toolchain is x86_64 only.
> +# We also deal with valgrind builds here, they don't use tooltool manifests at
> +# all yet.
> +if [ -z "$building_b2g" -a -z "$building_valgrind" ]

might as well make that $no_tooltool
Attachment #8368269 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5509778fb65b
https://hg.mozilla.org/mozilla-central/rev/5509778fb65b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
I believe this broke l10n, see bug 966793
Blocks: 966793
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
No longer blocks: 966793
Depends on: 966793
Let's say this is a dupe of bug 1075183. There's bug 965151 for the valgrind part.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1075183
You need to log in before you can comment on or make changes to this bug.