Closed Bug 939504 Opened 6 years ago Closed 6 years ago

Leftover <CanGC> Template on AtomizeChars in BIG ENDIAN case breaking the build

Categories

(Core :: JavaScript Engine, defect)

Sun
OpenBSD
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla28

People

(Reporter: gaston, Assigned: gaston)

References

Details

Attachments

(1 file)

Sparc64 tip fails to build with

/home/buildslave/mozilla-central-sparc64/build/js/src/jsatom.cpp: In function 'bool js::XDRAtom(js::XDRState<mode>*, js::MutableHandleAtom)':
/home/buildslave/mozilla-central-sparc64/build/js/src/jsatom.cpp:507:24: error: no match for 'operator<' (operand types are 'JSAtom*(js::ExclusiveContext*, const jschar*, size_t, js::InternBehavior) {aka JSAtom*(js::ExclusiveContext*, const char16_t*, long unsigned int, js::InternBehavior)}' and 'js::AllowGC')
     atom = AtomizeChars<CanGC>(cx, chars, nchars);

(from http://buildbot.rhaalovely.net/builders/mozilla-central-sparc64/builds/614/steps/build/logs/stdio)

It seems to be a fallout of the last commit to jsatom.cpp removing those templates, but forgetting to update the !LITTLE_ENDIAN side.

changeset:   154277:53b2cdf230dc
user:        Brian Hackett <bhackett1024@gmail.com>
date:        Sat Nov 09 19:53:53 2013 -0700
summary:     Bug 928050 - Don't GC during atomization, r=billm.
Will remove <CanGC> on my builder and report success/failure..
Blocks: 928050
Build seems to go much further with <CanGC> removed, see http://buildbot.rhaalovely.net/builders/mozilla-central-sparc64/builds/615
Assignee: nobody → landry
Attachment #833422 - Flags: review?(bhackett1024)
note: this build failed later on because of bug 939355 but js was definitely built
Attachment #833422 - Flags: review?(bhackett1024) → review+
https://hg.mozilla.org/mozilla-central/rev/3d3a8f13aa66
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Duplicate of this bug: 939741
You need to log in before you can comment on or make changes to this bug.