Closed Bug 940157 Opened 8 years ago Closed 8 years ago

[wifi][flatfish] wifi enable/disable button in setting doesn't take effect

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 940188

People

(Reporter: seinlin, Unassigned)

References

Details

Wifi can be configured in Launch first time. It can be enabled/disabled through drop down menu and does function properly.

In setting App, wifi enable/disable button doesn't take effect and do not display AP list.


Gaia commit ID: fa29c2b37b44247a3d1e133924346b22ead41cd3

Gecko commit ID: 59d46a4dc738742b52ca201db9a34333d52ab202
The issue occured from below gaia commit:

commit 909a407cd77ea4a84710bc7378471b171a68f994 de6f6d7ab771db12914f853fefc2c036
Merge: de6f6d7 56a8163
Author: Jose M. Cantera <jmcanterafonseca@gmail.com>
Date:   Wed Nov 13 09:58:48 2013 -0800

    Merge pull request #13650 from rnowm/938028
    
    Bug 938028 - Avoid CSS Gecko warnings and declaration drops due to unsupport
Console error log:

E/GeckoConsole( 3561): [JavaScript Warning: "Expected 'none' or URL but found 'drop-shadow('.  Error in parsing value for 'filter'.  Declaration dropped." {file: "app://settings.gaiamobile.org/style/apps.css" line: 12 column: 10 source: "  filter: drop-shadow(0px 2px 1px rgba(0,0,0,0.5));"}]
Summary: [wifi] wifi enable/disable button in setting doesn't take effect → [wifi][flatfish] wifi enable/disable button in setting doesn't take effect
Blocks: flatfish
The log in comment 2 is not correct, the correct console error log:

E/GeckoConsole( 4779): [JavaScript Error: "TypeError: mobileConnection is undefined" {file: "app://settings.gaiamobile.org/js/connectivity.js" line: 25}]
E/GeckoConsole( 4779): [JavaScript Error: "TypeError: IccHelper is undefined" {file: "app://settings.gaiamobile.org/js/settings.js" line: 684}]
E/GeckoConsole( 4779): [JavaScript Error: "TypeError: document.getElementById(...) is null" {file: "app://settings.gaiamobile.org/js/nfc.js" line: 8}]
E/GeckoConsole( 4779): [JavaScript Warning: "Expected 'none' or URL but found 'drop-shadow('.  Error in parsing value for 'filter'.  Declaration dropped." {file: "app://settings.gaiamobile.org/style/apps.css" line: 12 column: 10 source: "  filter: drop-shadow(0px 2px 1px rgba(0,0,0,0.5));"}]
E/GeckoConsole( 4779): [JavaScript Error: "TypeError: Connectivity is undefined" {file: "app://settings.gaiamobile.org/js/wifi.js" line: 75}]
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940188
You need to log in before you can comment on or make changes to this bug.