Closed Bug 941430 Opened 6 years ago Closed 6 years ago

Max tab width is smaller in Australis

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: billm, Assigned: dao)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [Australis:P4+])

Attachments

(5 files, 1 obsolete file)

At first I thought this was a design issue, but I asked MattN and he doesn't think it is. Before Australis, if I had seven tabs open, they would take up the entire horizontal width of the window. Now there's just a lot of empty space on the right side. It's annoying because I can't see as much of the tab title as before.

Screenshots will follow.
Attached image screenshot-old.png
Before Australis.
Attached image screenshot-new.png
And the after picture.
The screenshots have the same number of tabs and the same window size.

Before Australis:
Width of a tab: ~224px
Usable width for text: ~172px

Australis:
Width of a tab: ~181px
Usable width for text: ~115px

So the tab width went down by about 20% and the text width went down by about 30%. I can file the text issue as a separate problem if need be.
(In reply to Bill McCloskey (:billm) from comment #0)
> At first I thought this was a design issue, but I asked MattN and he doesn't
> think it is. Before Australis, if I had seven tabs open, they would take up
> the entire horizontal width of the window. Now there's just a lot of empty
> space on the right side. It's annoying because I can't see as much of the
> tab title as before.

It is part of the design but my point was more that I hadn't seen much discussion around this case. Many people who have been complaining about the titles of tabs have had tab overflow and so the *minimum* width was the issue. In your case you're interested in the *maximum* width.

I double-checked and we have the correct dimensions according to the spec [1].

Stephen, was the reduction in max-width intentional? Would you consider increasing the max-width? If not, please resolve the bug.

[1] https://people.mozilla.org/~shorlander/files/australis-designSpecs/australis-designSpecs-linux-mainWindow.html
Assignee: nobody → shorlander
Status: NEW → ASSIGNED
Flags: needinfo?(shorlander)
OS: Linux → All
Hardware: x86_64 → All
Duplicate of this bug: 941483
Blocks: 826689
Keywords: regression
Tabs are overlaping by 15px, so maybe we need to set max-width to 265px
Whiteboard: [Australis:P4]
I just wanted to note that I changed max-width for .tabbrowser-tab:not([pinned]) in my userChrome.css file. The tabs do get wider, but when I start opening and closing tabs, they appear at the wrong places. There must be other places in the code that I would have to change :-(.
(In reply to Bill McCloskey (:billm) from comment #8)
> I just wanted to note that I changed max-width for
> .tabbrowser-tab:not([pinned]) in my userChrome.css file. The tabs do get
> wider, but when I start opening and closing tabs, they appear at the wrong
> places. There must be other places in the code that I would have to change
> :-(.

You may want to see bug 875180.
Blocks: 924888
Whiteboard: [Australis:P4] → [Australis:P4+]
Attached image max-width set to 220px
I think we could set the maximum tab width to something like 220px without any aesthetic fallout.
(In reply to Philipp Sackl [:phlsa] from comment #10)
> Created attachment 8385646 [details]
> max-width set to 220px
> 
> I think we could set the maximum tab width to something like 220px without
> any aesthetic fallout.

It's quite bigger than the current tab at 180. AFAIK Google Chrome has more or less the same width.

The Firefox pre-Australis was 250, but the tabs were huge. I think 200 or 210 would be perfect.
Assignee: shorlander → dao
Flags: needinfo?(shorlander)
Attached patch patch (obsolete) — Splinter Review
Attachment #8386129 - Flags: review?(MattN+bmo)
Comment on attachment 8386129 [details] [diff] [review]
patch

Review of attachment 8386129 [details] [diff] [review]:
-----------------------------------------------------------------

This may affect TART results so you should probably do a Try build before landing to be safe (even if it's just to be prepared to say that the change in result is fine).

r=me with the changes and assuming no major TART regression.

::: browser/base/content/browser.css
@@ +103,5 @@
>  }
>  
>  .tabbrowser-tab:not([pinned]) {
>    -moz-box-flex: 100;
> +  max-width: 220px;

phlsa found that 210px looked better so please use that max-width

@@ +108,4 @@
>    min-width: 100px;
>    width: 0;
>    transition: min-width 200ms ease-out,
> +              max-width 240ms ease-out;

phlsa says we could leave this as it was
Attachment #8386129 - Flags: review?(MattN+bmo) → review+
(In reply to Matthew N. [:MattN] from comment #13)
> This may affect TART results so you should probably do a Try build before
> landing to be safe (even if it's just to be prepared to say that the change
> in result is fine).

I think we can just land this, especially if we keep the transition duration as is -- if there's a reasonably small change due to a few more pixels being drawn, we can disregard that as expected. If there's a larger change, we can still back out / investigate after the fact.
I would prefer to avoid the churn so some other regression doesn't slip in before the backout. It doesn't take that long to do a talos run on try
Attached patch patch v2Splinter Review
Attachment #8386129 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/a31dbdb555db
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8386284 [details] [diff] [review]
patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 826689
User impact if declined: less room for tab labels
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8386284 - Flags: approval-mozilla-aurora?
Attachment #8386284 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.