Closed Bug 941714 Opened 6 years ago Closed 6 years ago

Allowing hidden plugins directly from the CTP doorhanger should make the notification bar disappear

Categories

(Core :: Plug-ins, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla28
Tracking Status
firefox26 --- wontfix
firefox27 --- verified
firefox28 --- verified

People

(Reporter: pauly, Assigned: gfritzsche)

References

(Depends on 2 open bugs)

Details

Attachments

(2 files)

STR:
1. Set Flash to 'Ask to activate'
2. Open http://benjamin.smedbergs.us/tests/ctptests/flash-hidden.html
3. Click on the CTP doorhanger and "Allow Now"

AR: Plugin is allowed. The notification bar is still saying to "Continue blocking/Allow"
ER: Dismiss the notification bar instantly
Summary: Allowing plugins directly from the CTP doorhanger should make the notification bar disappear → Allowing hidden plugins directly from the CTP doorhanger should make the notification bar disappear
Good catch. Not a blocker.

gfritzsche, I think we can fix this by simply adding a call to _setPluginNotificationIcon at http://hg.mozilla.org/mozilla-central/annotate/09e33431c543/browser/base/content/browser-plugins.js#l769

Can you try that and add a test for this case?
Assignee: nobody → georg.fritzsche
Priority: -- → P2
Comment on attachment 8336472 [details] [diff] [review]
Fix notification bar not getting removed

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Click-to-play notification bar, bug 932854.
User impact if declined: Notification bar not disappearing after allowing plugin via notification icon.
Testing completed (on m-c, etc.): Automated testing, more pending.
Risk to taking this patch (and alternatives if risky): Low-risk, minimal change.
String or IDL/UUID changes made by this patch: None.
Attachment #8336472 - Flags: approval-mozilla-aurora?
I don't think this is urgent enough for beta uplift, right?
Flags: needinfo?(benjamin)
Keywords: verifyme
Correct, I think this can ride the trains.
Flags: needinfo?(benjamin)
https://hg.mozilla.org/mozilla-central/rev/3d18e85a5340
https://hg.mozilla.org/mozilla-central/rev/d1f4fda9c0aa
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
QA Contact: twalker
Comment on attachment 8336472 [details] [diff] [review]
Fix notification bar not getting removed

Approving the low risk patch on aurora. Also adding :tracy as a QA contact to help with testing.

Please let QA know if any additional testing is needed here, other than the testcase in the description.
Attachment #8336472 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Ok, i have no idea how the flags got reset with the last comment.
Target Milestone: --- → mozilla28
(In reply to bhavana bajaj [:bajaj] from comment #10)
> Please let QA know if any additional testing is needed here, other than the
> testcase in the description.

No additional testing is needed.
Allowing hidden plugins directly from the CTP doorhanger makes the notification bar disappear.
Verified fixed 28.0a1 (2013-11-25) Win 7.
Depends on: 943393
Depends on: 945617
Allowing hidden plugins directly from the CTP doorhanger makes the notification bar disappear.
Verified as fixed on Aurora 27.0a2(build id 20131204004002)
Win 7
Os X 10.8.5
Ubuntu 13.04 x64
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: twalker
You need to log in before you can comment on or make changes to this bug.