Australis removes bookmarks/history sidebar toolbar button

RESOLVED DUPLICATE of bug 881436

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 881436
4 years ago
4 years ago

People

(Reporter: tetsuharu, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

# env
http://hg.mozilla.org/mozilla-central/rev/cf378dddfac8

Australis removes bookmarks/history sidebar toolbar buttons.

These buttons aren't used with their panel toolbar buttons by user on the same times. User would make a choice between "sidebar" button or "panel" one.

We're able to compatible to stand their "sidebar" toolbar buttons and "panel" one.
(Reporter)

Updated

4 years ago
Blocks: 872617
These were removed in bug 867368.
Blocks: 939862
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(In reply to Jared Wein [:jaws] from comment #1)
> These were removed in bug 867368.

OK. I understand that Bookmark sidebar icon is hard to restore because the icon double with the indicator for bookmark status of the current page. But history sidebar icon doesn't have such state,  we're reuse history "panel" toolbar icon for it, and it doesn't need large maintenance cost.

If we cannot restore "sidebar" icons, we don't have the way to access the bookmark/history search and the all result of the search by mouse. (the application menubar is not provided on Windows by default).
Thus we should implement to open "Places Library" in tabs until shipping Australis to release channel.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
There's also a difference between bookmarks and history cause the bookmarks panel includes a View Bookmarks Sidebar option, while the history panel is missing it. I think they should at least be coherent, either direction. I guess until we have a better tool to search history we may want to add a View History Sidebar to the history panel.

Comment 4

4 years ago
(In reply to Marco Bonardo [:mak] from comment #3)
> There's also a difference between bookmarks and history cause the bookmarks
> panel includes a View Bookmarks Sidebar option, while the history panel is
> missing it. I think they should at least be coherent, either direction. I
> guess until we have a better tool to search history we may want to add a
> View History Sidebar to the history panel.

And for this reason, while the original bug is more of a dupe of bug 879388, that was duped to bug 881436, and I'll do the same with this bug.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881436

Updated

4 years ago
Duplicate of this bug: 1005450
You need to log in before you can comment on or make changes to this bug.