Closed Bug 94210 Opened 21 years ago Closed 14 years ago

Import/export to and from Mail.app on Mac OS X

Categories

(MailNews Core :: Import, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: raccettura, Unassigned)

References

Details

(Keywords: helpwanted)

Attachments

(1 file)

How about the ability to import/export from Mail.app?  It's a very popular app
for Mac OS X.
The only thing that could be imported from Apple's Mail app are Mail account configurations. 
Addresses and such are accessed via Apple's Address Book application.

Profile Migration probably isn't the right component for these ideas, since it's just about 
migrating profiles from Netscape 4.x to Mozilla or Netscape 6. Moving to Account Manager, 
although the Address Book part may belong in Directory.
Status: UNCONFIRMED → NEW
Component: Profile Migration → Account Manager
Ever confirmed: true
Why not importing Mail.app stored mail?
I posted this to the npm.macosx discussion on this - it might help somebody out with the format:
-----

I did a script back in March:

http://www.zettabyte.net/downloads/convertmail.pl

to go from Mozilla MailNews to Mail.app (since I needed a mailer that
could filter on Sender: for mailing lists).  I only switched once, so
I didn't go the other way.  There may or not be a problem with the
Sent Messages folder needing a different format, but I'm not sure.  I
thought it had worked but then I later saw some artifacts in that
folder that may be due to the script or may be due to Mail.app's
instability.   Let's call this GPL, so if somebody figures that out,
please share.

-Bill
I looked at the script, and it didn't look very advanced.  I know nothing about 
mail.app's data structure, or Mozilla's, could someone use the theory behind this 
script for importing data into Mozilla from mail.app?
We don't have an import/export mailnews bugzilla component? Hm.
Better summary
Summary: Mail.app → Import/export to and from Mail.app on Mac OS X
mac os X mail bug -> ducarroz
Assignee: sspitzer → ducarroz
Marking nsbranch. Is this important for Enterprise?
Keywords: nsbranch
QA Contact: esther → nbaca
Removing nsbranch. I see now that this is specific to OS X and probably not
important to enterprise at this time.
Keywords: nsbranch
Kevin, is this important for the next release?
Would be nice to have somebody helping with this feature.
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → Future
This should probably be helpwanted.
Anyone?  This ability is a blocker for many on OS X who having been using 
Mail.app.  Now that Mozilla is 1.0, it's considered stable enough for regular use 
by many, who would switch... but don't want to leave mail behind.  

Now more than ever is the time to create this ability.  Mail.app is very popular 
in the Mac OS X community.  Being able to convert over to Mozilla would be a 
benefit to many who are stuck with Mail.app.... Mozilla has a great email client, 
and with Navzilla looks really good too.  Keeping both programs open can be a 
pain though.
if those people used IMAP, it wouldn't be much of an issue. but if you care, 
then please do some homework, come back with an explanation of the file format 
for mail (if it's mbox, then the work should be relatively trivial), address 
book, ... and a list of API calls we should probably make.
Assignee: ducarroz → cavin
Status: ASSIGNED → NEW
Component: Account Manager → Import
Bill McGonigle did it a while back with a Perl script, though I don't have a 
copy, and the link is dead.

IMAP is a good solution, but who has enough space in an account to upload all 
that.  My mail now is way more than that... I like to be able to go back to old 
messages, I don't know how people afford not to.  

I believe the format is MBOX, though I have not been able to confirm that yet.
According to a post on MacOSX-dev, Mail.app uses UNIX mbox format to store mail:

http://www.omnigroup.com/mailman/archive/macosx-dev/2002-December/031459.html

Filters are stored at ~/Library/Mail/MessageSorting.plist, using Apple's
Property List doctype. The doctype is available at:

http://www.apple.com/DTDs/PropertyList-1.0.dtd

As noted in comment 1, Mail.app uses Apple's Address Book for addresses. Reading
from/to Apple's Address Book is bug 203927.
I am beginning to use thunderbird to which a default theme is set to pinstripe
and is becoming little by little good.
And having regretted first is that this import function does not exist...
*** Bug 242750 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Assignee: cavin → nobody
QA Contact: nbaca
*** Bug 289206 has been marked as a duplicate of this bug. ***
Since I have a rather complex hierarchy of local folders in Mail, containing
several years worth of mail. I needed a programatic way of importing mailboxes
into Thunderbird.

This script worked for me. It may work for you as well.

No warranty expressed or implied, use at your own risk.
*** Bug 290954 has been marked as a duplicate of this bug. ***
The script only imports mailboxes. It does not import yhe address book itself.
It is useless for impoting addresses purpose
(In reply to comment #22)
> The script only imports mailboxes. It does not import yhe address book itself.
> It is useless for impoting addresses purpose

It does exactly what it says it does.  (Which part of the description didn't you
understand?)

Perhaps you'd like to write a script to work with addresses.
*** Bug 291027 has been marked as a duplicate of this bug. ***
There is almost no Mac OS X support right now in Thunderbird. To get standard OS X users to migrate, this is required.
I tried Tom Blake's import AppleScript on a fresh TB install. It created an "Imported folders" account, but unfortunately it was empty.
(In reply to comment #26)

Unfortunately, my script does not work with the mail client that ships with Mac OS X 10.4 (AKA "Tiger.")

(Earlier versions of "Mail" stored messages in the "standard" mbox format.)
Oh no, did Apple change this? :-(

Is anyone aware of good documentation for the new format?
(In reply to comment #28)

It's a "feature!" Instead of storing all of the messages in a single file, they now store each message in a separate file.

Q: "Why would they do that!?"
A: "So 'Spotlight' can search mail messages just like other files!"
   (Something I never wanted to do, thank-you.
    I was quite happy searching for mail messages using "Mail.")

So, anyway, to make my script with with 10.4 I need to build my own .mbox files.  It ain't exactly rocket surgery, but I haven't taken the time to do it yet.

"It's on my list..."
So, Tom Blake and I have been discussing this.

Since Mail has such excellent AppleScripting support, the best solution seems to be to move all the hard work onto a script that will create a .mbox file with as many of the flags (replied-to etc) as possible. 

A very good result of this is that the script would work not only with the new Mail-format in Tiger but also in older versions, since we delegate the work to Mail itself.

The work that can't be done by the script we'll have to do ourselves.

If my time permits I will have a go at the thunderbird implementation of this, and it seems that Tom might be able to whip up a script.
I just wanted to point out bug 290057. That bug is quite unrelated [spotlight integration] to this one, but then again Spotlight integration also requires fiddling with our mailbox file formats, as pointed out by comment 29.

Maybe when this bug is looked into, it should consider the broader implications of mailbox formats on OS X?
*** Bug 338946 has been marked as a duplicate of this bug. ***
Would be nice to have this in the future, nominating...
Flags: blocking-thunderbird3?
Depends on: 420472
(In reply to comment #33)
> Would be nice to have this in the future, nominating...

Nice to have, not blocking, nominating wanted-thunderbird3 instead.
Flags: blocking-thunderbird3? → wanted-thunderbird3?
FYI, I have importing mostly finished in bug 420472. The reason I didn't morph this bug is because it included exporting, which I'm not implementing.
Mail importing from Mail.app has been implemented on the trunk. 

raccettura, can you clarify what kind of export abilities you would like to have and then morph it, or just close it out if that ability is not relevant anymore? Thanks.
Assuming the "import" part of this bug was really the primary reason it existed (since when do we have exporters to all other clients? They should take care to import from Thunderbird instead) - I'm going to go ahead and close this bug as worksforme, now that importing from Mail.app has been implemented.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.