Closed Bug 942680 Opened 6 years ago Closed 6 years ago

Regression: Google Search engine and search suggestions opt-in hidden behind urlbar

Categories

(Firefox for Android :: Awesomescreen, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
firefox27 - unaffected
firefox28 + verified
fennec 28+ ---

People

(Reporter: tetsuharu, Assigned: wesj)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files, 1 obsolete file)

Attached image screenshot-1
# environment
* http://hg.mozilla.org/mozilla-central/rev/74ab61b8d0f0
* Nexus 5

# Summary
* See screenshots.

* On the awesome screen, search results are buried in locationbar.
  * see the screenshot-1
  * This is always reproducible.

* Viewport margin-top is broken. The margin-top is sometimes too wide.
  * see the screenshot-2
  * This is sometimes reproducible if we set "browser.chrome.dynamictoolbar=false".
Keywords: regression
Attached image screenshot-2 (obsolete) —
Do you have steps to reproduce? I too have a Nexus 5, but am not not seeing any issues with the margins in Google as the case is in your second screenshot.
Keywords: steps-wanted
Needed search suggestions my mistake. Yes, I see this on my Galaxy S4 as well.
tracking-fennec: --- → ?
Regression from bug 768667? This also pushes the opt-in search suggestion prompt off the screen on first-run.
These appear to be two separate issues, both reproducible on my Galaxy Nexus. I'm changing this issue to resolve the issue in screenshot-1 (search results are hidden behind the url bar) and filed bug 943083 for screenshot-2 (margin at the top of the page with dynamic toolbar disabled).

And to be clear:

> Needed search suggestions my mistake. Yes, I see this on my Galaxy S4 as well.

Relevant to this bug.

> Regression from bug 768667?

Unlikely since (I believe) this uses a different code path. Likely relevant to bug 943083, however.
Summary: Regression: viewport screen margin top is broken → Regression: Google Search engine and search suggestions opt-in hidden behind urlbar
Comment on attachment 8337507 [details]
screenshot-2

Linked from bug 943083.
Attachment #8337507 - Attachment is obsolete: true
Component: General → Awesomescreen
Duplicate of this bug: 943075
Blocks: 768667
While bug 743644 is undoubtedly a separate issue, perhaps it should be duped over to this one?
(In reply to Paul [sabret00the] from comment #9)
> While bug 743644 is undoubtedly a separate issue, perhaps it should be duped
> over to this one?

It's similarity. But I think this bug is caused by the near changeset.
Severity: normal → major
tracking-fennec: ? → 28+
Duplicate of this bug: 945793
Assignee: nobody → wjohnston
Attached patch PatchSplinter Review
I thought I uploaded this :( Its probably in a different bug
Attachment #8342482 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 8342482 [details] [diff] [review]
Patch

You've uploaded this to bug 943083. I've reviewed it there :-)
Attachment #8342482 - Flags: review?(lucasr.at.mozilla)
Attachment #8342482 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/4d64a37dac18
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.