Deprecation warning "PlacesBackups.getMostRecent is deprecated and will be removed in a future version" in nsSuiteGlue.js (port bug 859695)

RESOLVED FIXED in seamonkey2.58

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
5 years ago
3 months ago

People

(Reporter: ssitter, Assigned: frg)

Tracking

(Blocks: 2 bugs)

Trunk
seamonkey2.58
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.58 fixed)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 SeaMonkey/2.25a1 (BuildID: 20131124011553)

When opening e.g. Tools > Add-ons Manager I get various deprecation errors in console:

Error: DEPRECATION WARNING: PlacesBackups.getMostRecent is deprecated and will be removed in a future version. You may find more details about this deprecation at: https://bugzilla.mozilla.org/show_bug.cgi?id=859695
resource://gre/modules/PlacesBackups.jsm 194 PB_getMostRecent
resource://gre/components/nsSuiteGlue.js 710 null
resource://gre/components/nsSuiteGlue.js 196 null

Error: DEPRECATION WARNING: PlacesBackups.entries is deprecated [...]

Error: DEPRECATION WARNING: PlacesBackups.folder is deprecated [...]
(In reply to Stefan Sitter from comment #0)
> Error: DEPRECATION WARNING: PlacesBackups.entries is deprecated [...]
> 
> Error: DEPRECATION WARNING: PlacesBackups.folder is deprecated [...]

At least as far as the nsSuiteGlue.js:710 occurrence is concerned, these are only due to getMostRecent() being called in the first place.

Otherwise, all this is just trying to tell us that we need to port bug 859695. Since that has TM mozilla27, I guess any SM version beginning with 2.24 (now on Beta) is affected (by the deprecation warnings; nothing has been removed yet, not even on trunk).
Status: UNCONFIRMED → NEW
Component: General → Bookmarks & History
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Deprecation warning "PlacesBackups.getMostRecent is deprecated and will be removed in a future version" in nsSuiteGlue.js → Deprecation warning "PlacesBackups.getMostRecent is deprecated and will be removed in a future version" in nsSuiteGlue.js (port bug 859695)
Version: SeaMonkey 2.25 Branch → Trunk
[Mozilla/5.0 (Windows NT 6.0; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30; 20141013232806]
{
Erreur : DEPRECATION WARNING: PlacesBackups.getMostRecent is deprecated and will be removed in a future version
You may find more details about this deprecation at: https://bugzilla.mozilla.org/show_bug.cgi?id=859695
resource://gre/modules/PlacesBackups.jsm 263 PB_getMostRecent
resource://gre/components/nsSuiteGlue.js 723 SuiteGlue.prototype._initPlaces
resource://gre/components/nsSuiteGlue.js 199 SuiteGlue.prototype.observe
null 0 null

Fichier Source : resource:///modules/Deprecated.jsm
Ligne : 79
}
Depends on: 859695
Note: this code is going away in bug 1433979 - likely to land in the next day or so. It should be easy to copy from nsBrowserGlue.js where this affects, although you might need to check for other call locations.
(Assignee)

Comment 4

6 months ago
Thanks. I did a wip patch some time ago. Will look into it.
Blocks: 1433370
(Assignee)

Updated

5 months ago
status-seamonkey2.53: --- → affected
status-seamonkey2.57esr: --- → affected
(Assignee)

Comment 5

5 months ago
Created attachment 8953824 [details] [diff] [review]
942937-part1-profileshutdown-257.patch

part 1 for sports
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
(Assignee)

Comment 6

5 months ago
Created attachment 8953825 [details] [diff] [review]
942937-part2-placesinit-257.patch

part 2 breakage fix
(Assignee)

Updated

5 months ago
Depends on: 1439220, 1378089
(Assignee)

Comment 7

5 months ago
Created attachment 8953826 [details] [diff] [review]
942937-part1-profileshutdown-253.patch

2.53 version part 1
(Assignee)

Comment 8

5 months ago
Created attachment 8953827 [details] [diff] [review]
942937-part2-placesinit-253.patch

2.53 version part 2
(Assignee)

Comment 9

5 months ago
Should we keep the lock strings in notification.properties or match Fx as in this bug? Not an exact match because we show a notification but otherwise almost identical.
Flags: needinfo?(iann_bugzilla)
(Assignee)

Comment 10

5 months ago
Created attachment 8955778 [details] [diff] [review]
942937-part1-profileshutdown-257.patch

Rebased after Bug 1436605 landed.
Attachment #8953824 - Attachment is obsolete: true
(Assignee)

Comment 11

5 months ago
Created attachment 8955779 [details] [diff] [review]
942937-part2-placesinit-257.patch

Rebased after Bug 1436605 landed.
Attachment #8953825 - Attachment is obsolete: true

Comment 12

4 months ago
(In reply to Frank-Rainer Grahl (:frg) from comment #9)
> Should we keep the lock strings in notification.properties or match Fx as in
> this bug? Not an exact match because we show a notification but otherwise
> almost identical.

Having them just in places.properties is fine.
Flags: needinfo?(iann_bugzilla)
(Assignee)

Comment 13

3 months ago
Comment on attachment 8955778 [details] [diff] [review]
942937-part1-profileshutdown-257.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 967839 
User impact if declined: bookmarks backup not working possible startup crash
Testing completed (on m-c, etc.): 2.53 
Risk to taking this patch (and alternatives if risky): --
String changes made by this patch: --
Attachment #8955778 - Flags: review?(iann_bugzilla)
Attachment #8955778 - Flags: approval-comm-beta?
(Assignee)

Comment 14

3 months ago
Comment on attachment 8955779 [details] [diff] [review]
942937-part2-placesinit-257.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 967839 
User impact if declined: bookmarks backup not working possible startup crash
Testing completed (on m-c, etc.): 2.53 
Risk to taking this patch (and alternatives if risky): --
String changes made by this patch: --
Attachment #8955779 - Flags: review?(iann_bugzilla)
Attachment #8955779 - Flags: approval-comm-beta?
(Assignee)

Comment 15

3 months ago
Comment on attachment 8955779 [details] [diff] [review]
942937-part2-placesinit-257.patch

Regression actually cuased by Bug 1433979. Comment is correct.

Comment 16

3 months ago
Comment on attachment 8955778 [details] [diff] [review]
942937-part1-profileshutdown-257.patch

LGTM r/a=me
Attachment #8955778 - Flags: review?(iann_bugzilla)
Attachment #8955778 - Flags: review+
Attachment #8955778 - Flags: approval-comm-beta?
Attachment #8955778 - Flags: approval-comm-beta+

Comment 17

3 months ago
Comment on attachment 8955779 [details] [diff] [review]
942937-part2-placesinit-257.patch

LGTM r/a=me
Attachment #8955779 - Flags: review?(iann_bugzilla)
Attachment #8955779 - Flags: review+
Attachment #8955779 - Flags: approval-comm-beta?
Attachment #8955779 - Flags: approval-comm-beta+

Comment 18

3 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/aad618543d32
Move onProfileShutdown logic to quit-application-granted phase. r=IanN
https://hg.mozilla.org/comm-central/rev/1ad208ac3369
Clean up places init and remove deprecated PlacesBackups calls. r=IanN
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
(Assignee)

Updated

3 months ago
status-seamonkey2.58: --- → fixed
Target Milestone: --- → Seamonkey2.58
You need to log in before you can comment on or make changes to this bug.