Closed Bug 944834 Opened 8 years ago Closed 8 years ago

dom/mobilemessage/src/ipc/SmsIPCService.cpp:285:5: error: use of undeclared identifier 'dom' in non-unified builds

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 943712

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

dom/mobilemessage/src/ipc/SmsIPCService.cpp:285:5: error: use of undeclared identifier 'dom'; did you mean 'mozilla::dom'?
    dom::MmsAttachment& attachment = params.mAttachments.Value()[i];
    ^~~
    mozilla::dom
Erf, ironically, the patch to make it build in unified mode is what broke it in non-unified mode.
Blocks: 943712
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Comment on attachment 8340572 [details] [diff] [review]
Fix non-unified build in dom/mobilemessage after bug 943712

bjacob landed a fix.
Attachment #8340572 - Flags: review?(gene.lian)
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 943712
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.