Closed Bug 945653 Opened 8 years ago Closed 7 years ago

Missing Email-notification by caldav-calendars

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 2.6.3
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: christian.moling, Unassigned)

References

Details

Since the version TB 24.1.1 and Lightning 2.6.3 and ONLY in combination with Caldav-calendars the email-notification is not sending on the participants wehn I insert a new event. When I delete the inserted event the email-notification is sending.
The problem not persists by local calendars or Google-calendars.
Priority: -- → P2
Some here. After installing Lightning 2.6.2 everything works. But don't want to install old Lightning to all users and disable automatic updateing :(
I'm still seeing this bug as well, Thunderbird 24.1.1/Lightning 2.6.3 on Linux and Windows.
Invitations are sent to attendees uniquely on event deletion, never on creation or modification.
Most probably just another CalDAV regression caused by the incomplete patch in Bug 930132. Will be fixed with the upcoming Lightning 2.6.4.
Hi, to my latest tests with manual apply patches to 2.6.3 with TB 24.2 linux 64, caldav offline sync now works fine ,same with 2.6.4 ( latest  releases/comm-esr24 ) but i still cannot send invite mail with caldav server ( horde ) where no caldav scheduling is implemented yet.
I still have this problem with TB 24.2.0 and Lightning 2.6.3 - calendar invitations are not sent to the invitee when new calendar entries are created. If I revert to Lightning 2.6.2 it works fine.
Now with the new version of Lightning (2.6.4) the problem is solfed. Thanx a lot!!
Now with the new version of Lightning (2.6.4) the problem is solved. Thanx a lot!!
Now with the new version of Lightning (2.6.4) the problem is solved. Thanx a lot too!!
Its not solved at my setup with 2.6.4
Priority: P2 → --
I can confirm that the problem not completely solved. 

Setup: 
Windows7-64b Ultimate, Thunderbird 24.4.0, Lightning 2.6.4, CalDAV calendar.

Problem:
When I created a new event, some attendees get email notification, but not all,
specifically, not the event organizer (i.e. me). Same problem when the later the
event is updated, e.g. adding new attendees, changing event time, or deleting event. 
No popup window for asking whether to send notification to attendees. And the
"Notify Attendees" checkbox is greyed out.

No such problem when using a local calendar. Please help. Thanks!
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
Is this still an issue with the current version 2.6.6?
Robert, Cliff, Oliver and SamV: Is this still an issue for you with the current version 3.3.x?

If so, please additionally provide information about which calendar server you use and whether cache is enabled for the respective caldav calendar.
Hi , with latest changes on Kronolith Horde 5 (4.2.1) its working 3.3.x Ligtning by sending
Email-notification from Horde/Kronolith itself ,but it may config related. However at recent it seems solved to me.
No, this is no longer a problem for me. Many thanks, Cliff
Resolving WFM as per comments 13 and 14.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1072457
(In reply to MakeMyDay from comment #12)
> Robert, Cliff, Oliver and SamV: Is this still an issue for you with the
> current version 3.3.x?
> 
> If so, please additionally provide information about which calendar server
> you use and whether cache is enabled for the respective caldav calendar.

Sorry for the late reply. Now running Thunderbird 13.2.0, Lightning 3.3.1.
Still seeing the same problem. Tried both calendar caching on/off -- no difference.

Thanks in advance for your help.
(In reply to SamV from comment #17)
> 
> Sorry for the late reply. Now running Thunderbird 13.2.0, Lightning 3.3.1.
> Still seeing the same problem. Tried both calendar caching on/off -- no
> difference.
> 
> Thanks in advance for your help.

Typo fix. Should be Thunderbird 31.2.0. 
About calendar server, it's a corporate IMAP mail server.
(In reply to SamV from comment #18)
Hi,

I would like to emphasize that my problem has been with the Event Organizer not getting ANY
email notification at all, even if the person's Thunderbird email (default) is added to the 
invitees list. The other invitees are getting it, for event create/edit/delete, as expected. 
My Issue: After I set up a meeting calendar, often I need to forward the meeting notification 
email to someone I forgot to invite initially, or to someone requested to attend my meeting 
at the last minute. I can't do that if I receive no notification email after creating the event.

My work-around for the problem -- I created a dummy invitee, using one of my alternate email, 
invite the dummy to all my meetings, and then forward the dummy's event notification email
to my normal email account for later use. It's a rather inconvenient. Is there a better way?
Any idea why the Event Organizer got filtered out when sending out event notification?

Thanks again for your help!
(In reply to SamV from comment #19)

The problem you describe just started happening to me today. I'm running Ubuntu 12.04 and get all my Thunderbird updates through the Ubuntu update manager, so I'm assuming it's a recent update. (I update regularly and often, somethimg more than 1x week.) My workaround is that the e-mail notification does appear in my sent mail folder, so I just pull it out of there and put in my Inbox. Still, this is annoying.
Rick, SamyV,that the organizer does not get a email notification to his/her own events is by design. He/she has already the full control on the event. Simply add the additional attendee using the event dialog to get his/her notified.

Also this bug wss about not sending notifications to attendees, so this bug is different from what you expirience.
You need to log in before you can comment on or make changes to this bug.