Closed Bug 947131 Opened 7 years ago Closed 7 years ago

[DSDS]Call Log shows which SIM was involved in call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S3 (14mar)

People

(Reporter: wmathanaraj, Assigned: etienne)

References

Details

(Whiteboard: [ucid:, 1.4, ft:comms])

User Story

Update acceptance criteria based on product manager's last comment.

As a user, I want to see in the call log on which SIM card the call has been made or received

AC1: The information must be shown on the "ALL" tab and on the "MISSED" tab
AC2: I want to easily find this information without navigating a big menu tree  
AC3: If I have multiple calls from a single user then I want to see the last received via which SIM.

Attachments

(4 files)

As a user, I want to see in the call log on which SIM card the call has been made or received

AC1: The information must be shown on the "ALL" tab and on the "MISSED" tab
AC2: I want to easily find this information without navigating a big menu tree  
AC3: I want to see both information, SIM card number and phone number of the receiving SIM
AC4: If I have multiple calls from a single user then I want to see the last received via which SIM.
AC5: If the call log contains entries for a combined conference  call and I tap on the conference call item to see via which SIM each  users call has been received.
Summary: [DSDS] Call Log shows which SIM was involved in call → [DSDS][Dialer] Call Log shows which SIM was involved in call
Summary: [DSDS][Dialer] Call Log shows which SIM was involved in call → [DSDS][Dialer][Call log] Call Log shows which SIM was involved in call
(In reply to Wilfred Mathanaraj [:WDM] from comment #0)

> AC3: I want to see both information, SIM card number and phone number of the
> receiving SIM
Hi Wilfred, 

Just want confirm, does the information include SIM card number and incoming or outgoing phone number?

Thanks.
Flags: needinfo?(wmathanaraj)
(In reply to Wilfred Mathanaraj [:WDM] from comment #0)
> AC4: If I have multiple calls from a single user then I want to see the last
> received via which SIM.

Sorry, missed this one. So does this mean call log will merge all records of a phone number into one? Can we check all the detail records of a single number?
currently, in a single SIM solution, if we get multiple calls from the same number - we collapse the call long into one single item. 

in dual SIM situation we want to have call logs for each of the dual SIM - both call logs are displayed combined in one single list.

when we receive multiple calls from the same remote user (the remote user may use either one of the dual SIMs or a combination of the dual SIMs) we display still a single line in the call log for that user (remote MSISDN still remains the same)  

we display the SIM number (of the dual SIM) on the call log to show which dual SIM received the last call from that remote user.
I will leave it up to UX to see if we want to press on the cal log item to display more details but I dont think this is a required feature to display for each call from the user which dual sim the call was received on.

hope this answers your question...
Flags: needinfo?(wmathanaraj)
(In reply to Wilfred Mathanaraj [:WDM] from comment #3)
> currently, in a single SIM solution, if we get multiple calls from the same
> number - we collapse the call long into one single item. 
> 
> in dual SIM situation we want to have call logs for each of the dual SIM -
> both call logs are displayed combined in one single list.
> 
> when we receive multiple calls from the same remote user (the remote user
> may use either one of the dual SIMs or a combination of the dual SIMs) we
> display still a single line in the call log for that user (remote MSISDN
> still remains the same)  
> 
> we display the SIM number (of the dual SIM) on the call log to show which
> dual SIM received the last call from that remote user.
> I will leave it up to UX to see if we want to press on the cal log item to
> display more details but I dont think this is a required feature to display
> for each call from the user which dual sim the call was received on.
> 
> hope this answers your question...

Yes, thank you so much.
AC3 and AC5 are removed as acceptance criteria.
Update acceptance criteria based on product manager's last comment.

AC1: The information must be shown on the "ALL" tab and on the "MISSED" tab
AC2: I want to easily find this information without navigating a big menu tree  
AC3: If I have multiple calls from a single user then I want to see the last received via which SIM.
Update acceptance criteria based on product manager's last comment.

AC1: The information must be shown on the "ALL" tab and on the "MISSED" tab
AC2: I want to easily find this information without navigating a big menu tree  
AC3: If I have multiple calls from a single user then I want to see the last received via which SIM.
User Story: (updated)
Summary: [DSDS][Dialer][Call log] Call Log shows which SIM was involved in call → [DSDS][fugu][Dialer][Call log] Call Log shows which SIM was involved in call
Assignee: nobody → anthony
Target Milestone: --- → 1.4 S1 (14feb)
Attached image Call_Log.png
Visuals and visual specs related to DSDS. NI to Carrie in order to review the correct IxD implementation.
Flags: needinfo?(cawang)
Attached image SPEC_DSDS.CallLog.png
Attached file DSDS_Assets.zip
Hi Jose,

Looks fine. :) 
Thanks!
Flags: needinfo?(cawang)
features should not block release, remove blocking flag
blocking-b2g: 1.4+ → ---
Whiteboard: [ucid:, 1.4, ft:comms]
Flags: in-moztrap?(atsai)
QA Contact: atsai
Target Milestone: 1.4 S1 (14feb) → 1.4 S2 (28feb)
#11674
Flags: in-moztrap?(atsai) → in-moztrap+
Target Milestone: 1.4 S2 (28feb) → 1.4 S3 (14mar)
Summary: [DSDS][fugu][Dialer][Call log] Call Log shows which SIM was involved in call → [DSDS]Call Log shows which SIM was involved in call
From page 13 of the spec: "The SIM indication will always be kept no matter the SIM is removed or switched.
e.g. Remove SIM 2 from the SIM slot, the call history related to SIM 2 will still remain the same."

So that means if I had SIM First in slot1 and SIM Second in slot2, I make some calls, I turn off the phone, I switch the SIMs in the slots, turn the phone back on then I'll see that calls made with SIM First are displayed as SIM1 even though SIM First is now in slot 2?

I need that answer to land that patch because it involves a database migration.
Flags: needinfo?(cawang)
I started working on this but I can't get the tests to pass. Anyway, here is a branch with my WIP.
https://github.com/Rik/gaia/compare/dsds-calllog-947131

needinfo-ing Etienne if he can work on this on Friday.
Flags: needinfo?(etienne)
Yes Anthony, I've discussed with the engineers from Gecko side, and we all agree that we shouldn't make it too complicated on this stage. Since the history has passed, it's passed. Getting involved with this is not our high priority now. Thanks!
Flags: needinfo?(cawang)
Ok, it's early enough that I can steal this for today and still ask you for review :)
Let's see how it goes.
Assignee: anthony → etienne
Flags: needinfo?(etienne)
Attached file Gaia PR
Here we go!
Attachment #8391201 - Flags: review?(anthony)
Comment on attachment 8391201 [details] [review]
Gaia PR

I don't feel confident r+ing this so asking Fernando. Not enough experience on call log.

A few comments:
- Do we have to upgrade the DB version?
- Do we have enough new tests for call_log_db? It seems that we are adding serviceId to more paths than we're testing.
- Instead of adding so many images, could we add the SIM number via a ::before pseudo-element? That would reduce the number of selectors too.
I'm merely asking, doesn't have to be addressed to land.
Attachment #8391201 - Flags: review?(ferjmoreno)
Attachment #8391201 - Flags: review?(anthony)
Attachment #8391201 - Flags: feedback+
(In reply to Anthony Ricaud (:rik) from comment #19)
> A few comments:
> - Do we have to upgrade the DB version?

Nope. We're storing objects :)

> - Do we have enough new tests for call_log_db? It seems that we are adding
> serviceId to more paths than we're testing.

I can guarantee you that no line of this patch can be changed/removed without making a test (or more) fail :)

> - Instead of adding so many images, could we add the SIM number via a
> ::before pseudo-element? That would reduce the number of selectors too.
> I'm merely asking, doesn't have to be addressed to land.

Yes let's keep that in mind for the redesign.
Comment on attachment 8391201 [details] [review]
Gaia PR

Looks good! I only added a few questions to the PR.
Attachment #8391201 - Flags: review?(ferjmoreno) → feedback+
Comment on attachment 8391201 [details] [review]
Gaia PR

patch updated :)
Attachment #8391201 - Flags: review?(ferjmoreno)
Comment on attachment 8391201 [details] [review]
Gaia PR

r=me

Thank Etienne!
Attachment #8391201 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/5a5a25b2f04525bb11969cdb3aaa607e9d0f13b1
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Just a quick heads up here: the new images added here are pretty small but running them through the png_recompress.sh script (*) yields some small savings. It's probably not worth doing it here but please make sure that all new images are fully recompressed so we can keep the distribution nice and small.

*) It's in the tools directory in a gaia checkout, you need the optipng 0.7.x and advancecomp packages installed to run it
Blocks: 984475
Filed bug 984475.
Works fine on this 
Gaia      d2651c13d6370d62bf833b31c7e2e5f054510136
Gecko     c8a17e25111585c0eebb829f8208190ea432c71e
BuildID   20140318053055
Version   30.0a1
Status: RESOLVED → VERIFIED
Keywords: verifyme
Duplicate of this bug: 991873
QA Whiteboard: [fxosqa-auto-backlog?]
Depends on: 1093608
QA Whiteboard: [fxosqa-auto-backlog?] → [fxosqa-auto-backlog+]
Clearing backlog as bug 1093608 was created.
QA Whiteboard: [fxosqa-auto-backlog+]
You need to log in before you can comment on or make changes to this bug.